Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 97259 - neat or rhc-network encouter unhandled exception and dies
Summary: neat or rhc-network encouter unhandled exception and dies
Status: CLOSED DUPLICATE of bug 88147
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2003-06-12 04:28 UTC by Joe Sauer
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-02-21 18:56:40 UTC

Attachments (Terms of Use)

Description Joe Sauer 2003-06-12 04:28:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
normally I've just used netconfig or edited
/etc/sysconfig/network-scripts/ifcfg-ethX to get the specific network setting I
want. But I tried running neat to see how it was. It died and caused the
following output:

Component: redhat-config-network
Version: 1.2.0
Summary: TB
expected string or buffer
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
line 154, in __init__
line 225, in load
line 232, in loadDevices
line 210, in getDeviceList
line 117, in load
line 34, in load
line 52, in load
  File "/usr/src/build/228093-i386/install/usr/lib/python2.2/", line 137,
in search
    return _compile(pattern, flags).search(string)
TypeError: expected string or buffer

After this I tried editing the ifcfg-eth0 files and it just would not work
properly since ifup appeard to be using /etc/sysconfig/networking files instead.
(I have not had time to look into this part yet) As of now I've had to manually
set network setting w/ ifconfig and route add in order to get connectivity. I'll
try editing the networking profiles file and see about fixing this for me, but
the exception is probably the key that needs fixing
It looks like during the build it somehow got the build dirs in the path to the
application when it should have been chrooted, maybe? 

Version-Release number of selected component (if applicable):
redhat-config-network-1.2.0-2 redhat-config-network-tui-1.2.0-2

How reproducible:

Steps to Reproduce:
1. manually edit /etc/sysconfig/network-scripts/ifcfg-ethX 
2. run neat or rhc-network, and it happens every tie
3.I haven't reproduced it on an other sytem but at least one other person I've
spoken to has seen similar behaviour and bug 97252 has some similarities...

Actual Results:  same error as seen in description. 

Additional info:

Comment 1 Harald Hoyer 2003-06-16 11:23:18 UTC

*** This bug has been marked as a duplicate of 88147 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:56:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.