Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 970249 - PathsTestCase intermittent failure
Summary: PathsTestCase intermittent failure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: EAP 6.3.0
Assignee: Pavel Jelinek
QA Contact:
URL:
Whiteboard:
Depends On: 1055511
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-03 19:26 UTC by Aleksandar Kostadinov
Modified: 2015-03-11 08:40 UTC (History)
4 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 13:56:13 UTC
Type: Bug


Attachments (Terms of Use)
testChangeDependentServiceNotificationIsCascaded error report (deleted)
2013-06-03 19:26 UTC, Aleksandar Kostadinov
no flags Details


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBQA-8832 Critical Closed PathsTestCase intermittent failure 2015-03-11 08:40:40 UTC

Description Aleksandar Kostadinov 2013-06-03 19:26:12 UTC
Created attachment 756486 [details]
testChangeDependentServiceNotificationIsCascaded error report

This test seems to not be stable enough failing when running test suite in EC2 environment large instance.

> org.jboss.as.controller.services.path.PathsTestCase.testChangeDependentServiceNotificationIsCascaded

Attaching error report.

Comment 2 Pavel Jelinek 2013-07-19 06:49:18 UTC
Hi Ondra. Who will be testsuite component owner instead of you?

Comment 5 Jan Martiska 2014-01-16 13:00:53 UTC
Aleks, can you confirm that this is still happening with 6.2.0 code? Have you encountered this more than once? It looks like a very rare race condition or something.

Comment 6 Jan Martiska 2014-01-17 13:16:15 UTC
Ok I managed to reproduce it with 6.2.0. Will look into it ASAP and try to find a cause.

Comment 7 Jan Martiska 2014-07-28 13:56:13 UTC
This is quite likely fixed already - Bug 1055511 seems to be not reproducible anymore in EAP 6.3.

Comment 8 JBoss JIRA Server 2015-03-11 08:40:40 UTC
Jan Martiska <jmartisk@redhat.com> updated the status of jira JBQA-8832 to Closed


Note You need to log in before you can comment on or make changes to this bug.