Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 970115 - [Webadmin] [User Portal] Removing disk from VM doesn't generate event when "Remove permanently" is checked
Summary: [Webadmin] [User Portal] Removing disk from VM doesn't generate event when "R...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.4.0
Assignee: Tal Nisan
QA Contact: Leonid Natapov
URL:
Whiteboard: storage
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-06-03 13:36 UTC by movciari
Modified: 2016-02-10 17:58 UTC (History)
7 users (show)

Fixed In Version: av1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-12 14:05:14 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)

Description movciari 2013-06-03 13:36:13 UTC
Description of problem:
Removing disk from VM using Disks subtab under VMs tab does not generate any event when "Remove permanently" is checked.

Version-Release number of selected component (if applicable):
3.2.0-11.29 (sf17.3)

How reproducible:
always

Steps to Reproduce:
1. Create VM with disk
2. In Disks subtab of VM, remove disk


Actual results:
No event is generated

Expected results:
There should be some event telling that disk has been removed, and who removed it, in webadmin events tab and in events subtab of VM to which it was attached before removing, in both webadmin and userportal

Additional info:

Comment 2 Tal Nisan 2014-02-13 14:38:43 UTC
Just tested some scenarios, all of the permanent removals were logged correctly in the general events tab:
"Disk VM1_Disk3 was successfully removed from domain NfsDomain1 (User admin."
The event did not appear in the VM events and it's by design since a disk removal isn't in a specific VM context since a disk can be connected to a few VMs at the same time, it wouldn't be correct to create the event in the specific VM context.

Comment 3 Leonid Natapov 2014-02-17 09:51:29 UTC
3.4.0-0.7.beta2.el6. fixed.

Comment 4 Itamar Heim 2014-06-12 14:05:14 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.