Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 965525 - Inaccurate message displayed after VM live migration finishes
Summary: Inaccurate message displayed after VM live migration finishes
Keywords:
Status: CLOSED DUPLICATE of bug 836780
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Shahar Havivi
QA Contact: Tareq Alayan
URL:
Whiteboard: virt
: 970928 (view as bug list)
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-05-21 10:28 UTC by Alexander Bisogiannis
Modified: 2018-12-04 15:24 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-13 08:42:41 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Alexander Bisogiannis 2013-05-21 10:28:34 UTC
Description of problem:
Upon live migration of a VM, the Event log reports

"VM <vm_name> is down. Exit Message: Migration succeeded"


Version-Release number of selected component (if applicable):

RHEVM 3.1.0-50

How reproducible:
Live migrating any VM gives the same message. Appears to be move prevalent when live-migrating multiple VM concurrently, for instance when placing a loaded hypervisor into maintenance mode.

Steps to Reproduce:
1.
2.
3.

Actual results:

Confusing message appears, probably from source host reporting that the VM is down.

Expected results:

The message should note if the migration succeeded or not, not from the source host saying that the VM is down.

Additional info:


The message comes from the source host reporting that he VM is down, which is technically correct, but irrelevant.

Comment 1 Michal Skrivanek 2013-05-22 14:14:31 UTC
there seems to be a race in setDownStatus, it first set status to Down and only after that actually stop the statistics thread. If you're unlucky the stats get sent in the meantime

vdsm logs would help to confirm

Comment 2 Martin Polednik 2013-09-11 11:34:03 UTC
After investigation, we've agreed on moving this bug to engine, as from vdsm's point of view the status of migrated VM is simply poweroff/nonexistant and no further information should be sent. Engine should supress the message and focus on success of migration on destination host.

Comment 3 Michal Skrivanek 2013-09-17 06:32:51 UTC
*** Bug 970928 has been marked as a duplicate of this bug. ***

Comment 5 Shahar Havivi 2013-10-27 13:26:36 UTC
Does the message is error message or a regular event log?

Comment 7 Michal Skrivanek 2014-04-01 09:06:39 UTC
we want to suppress this to not alarm users…it's a normal case and you get the migration succeeded event afterwards anyway

Comment 12 Michal Skrivanek 2014-05-13 08:42:41 UTC

*** This bug has been marked as a duplicate of bug 836780 ***


Note You need to log in before you can comment on or make changes to this bug.