Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 964644 - webadmin [TEXT]: unclear warning when exporting a vm dependent on template without the template
Summary: webadmin [TEXT]: unclear warning when exporting a vm dependent on template wi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.2.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Tal Nisan
QA Contact: Ori Gofen
URL:
Whiteboard: storage
Depends On: 1106458 1107945 1111153 1116815
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-05-19 10:50 UTC by Dafna Ron
Modified: 2016-02-10 17:41 UTC (History)
10 users (show)

Fixed In Version: ovirt-engine-3.5.0_alpha1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 19:10:00 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 25239 None None None Never

Description Dafna Ron 2013-05-19 10:50:42 UTC
Description of problem:

if we export a vm without its template and remove the template from the setup 
the vm will no longer be usable. 

the warning that we give the user is the below:

The following templates are missing on the target Export Domain:
Template testt (for testtt)

I am not sure that this explain the remifications to the user. 

Version-Release number of selected component (if applicable):

sf17

How reproducible:

100%

Steps to Reproduce:
1. create a vm based on template
2. export the vm to an export domain without the template
3.
  
Actual results:

we get a warning that alerts the user that the vm is exported without its template but I am not sure that the user will understand why we need the template to be backed up as well. 

Expected results:

I think that further info should be added to the warning. 

Additional info:

Comment 1 Liron Aravot 2013-07-09 11:29:07 UTC
Chreryn, perhaps you have a suggestion for a clearer message to the user?

Comment 2 Ayal Baron 2013-09-09 05:04:31 UTC
Andy, any suggestions?

Comment 3 Cheryn Tan 2013-09-09 06:16:08 UTC
Liron, I'm really sorry for the late reply, this seems to have slipped through my filters. 

Maybe a warning like this would work:

"Virtual machine ${vm-name} was created from template ${template-name}, and cannot be used in a domain where ${template-name} does not exist. Export template ${template-name} to ${target-export-domain}."

Comment 4 Ayal Baron 2014-02-09 12:47:11 UTC
(In reply to Cheryn Tan from comment #3)
> Liron, I'm really sorry for the late reply, this seems to have slipped
> through my filters. 
> 
> Maybe a warning like this would work:
> 
> "Virtual machine ${vm-name} was created from template ${template-name}, and
> cannot be used in a domain where ${template-name} does not exist. Export
> template ${template-name} to ${target-export-domain}."

This is does not explain the the problem.
The problem is that the user is now exporting virtual machines which cannot function without the templates and these templates do not exist on the export domain.  This means that later, when the user will want to import these VMs back into the system or into another system this will only be possible if the templates have been already imported or if the user exports the templates to the export domain after exporting the VMs.

The message should be something like:
"The following virtual machines are based on templates which do not exist on the export domain and are required for the virtual machines to function. If you proceed you will not be able to import these virtual machines unless you already have the relevant templates on the target domains. Continue? yes/no"

Comment 5 Cheryn Tan 2014-02-28 02:10:50 UTC
(In reply to Ayal Baron from comment #4)
> (In reply to Cheryn Tan from comment #3)
> > Liron, I'm really sorry for the late reply, this seems to have slipped
> > through my filters. 
> > 
> > Maybe a warning like this would work:
> > 
> > "Virtual machine ${vm-name} was created from template ${template-name}, and
> > cannot be used in a domain where ${template-name} does not exist. Export
> > template ${template-name} to ${target-export-domain}."
> 
> This is does not explain the the problem.
> The problem is that the user is now exporting virtual machines which cannot
> function without the templates and these templates do not exist on the
> export domain.  This means that later, when the user will want to import
> these VMs back into the system or into another system this will only be
> possible if the templates have been already imported or if the user exports
> the templates to the export domain after exporting the VMs.
> 
> The message should be something like:
> "The following virtual machines are based on templates which do not exist on
> the export domain and are required for the virtual machines to function. If
> you proceed you will not be able to import these virtual machines unless you
> already have the relevant templates on the target domains. Continue? yes/no"

Thanks for the explanation Ayal. The new error message looks good.

Comment 6 Ori Gofen 2014-07-29 11:28:29 UTC
verified on beta.2

Comment 8 Allon Mureinik 2015-02-16 19:10:00 UTC
RHEV-M 3.5.0 has been released, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.