Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 960379 - PRD35 - [RFE] Support to configure kdump via ssh/local for Automated Installation
Summary: PRD35 - [RFE] Support to configure kdump via ssh/local for Automated Installa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: rebase-ovirt-node-3.1 1150377
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-05-07 06:52 UTC by haiyang,dong
Modified: 2016-02-10 20:05 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Partial configuration of kdump is now supported during auto-installation of the Red Hat Enterprise Virtualization Hypervisor. 'kdump_local=1' can now be used to store core dumps locally, and 'kdump_ssh' and 'kdump_ssh_key' can be used to configure kdump for remote storage of the core dump.
Clone Of:
Environment:
Last Closed: 2015-02-11 20:44:26 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 17894 master MERGED Add parameters and code to back kdump autoinstall parameters Never

Description haiyang,dong 2013-05-07 06:52:46 UTC
Description of problem:
Right now rhev-h support to configure kdump via nfs/ssh/local for TUI,
but for Automated Installation, it only support to configure kdump via nfs.
So it's better to also support to configure kdump via ssh/local for Automated Installation  

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20130501.0.el6_4

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
rhev-h only support to configure kdump via nfs for Automated Installation

Expected results:
rhev-h support to configure kdump via nfs/ssh/local for Automated Installation

Additional info:

Comment 4 Doron Fediuck 2014-06-13 10:01:55 UTC
Resetting this since the attached patch handles something else.

Comment 5 Ryan Barry 2014-06-13 14:59:13 UTC
It does not, or should not, handle another issue, though it's been a while since I've looked at it.

We initially depended on adding support for SSH keys (which happened here: http://gerrit.ovirt.org/#/c/18149/2 )

The attached patch explicitly handles allowing SSH/local kdump in autoinstall. See:

http://gerrit.ovirt.org/#/c/17894/13/scripts/ovirt-auto-install.py
http://gerrit.ovirt.org/#/c/17894/13/scripts/ovirt-init-functions.sh.in

Comment 6 Fabian Deutsch 2014-06-19 08:12:20 UTC
Sorry, it was my fault while reviewing. I actually mixed up two bugs.

Comment 10 haiyang,dong 2014-11-12 08:49:47 UTC
Test version:
rhev-hypervisor6-6.6-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch

Auto install for kdump
1. Default it will configure kdump with local type- function pass
2. auto install with "disable_kdump" parameter --function pass
3.auto install with "kdump_ssh+kdump_ssh_key" parameter --function failed

For case 3,could see configuration in kdump page and "/etc/kdump".
But service kdump fails to start by default.For this issue, i have reported a new bug 1163016 to track kdump start failed by default issue.

so this bug has been fixed in in rhevh 6.6 for RHEV 3.5 bulid version, change the status into "VERIFIED"

Comment 12 errata-xmlrpc 2015-02-11 20:44:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.