Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 958151 - Action installation package from activation key failed when all packages were installed and next events were not picked up.
Summary: Action installation package from activation key failed when all packages were...
Keywords:
Status: CLOSED DUPLICATE of bug 960524
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2013-04-30 13:54 UTC by Pavel Studeník
Modified: 2013-07-16 17:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-16 17:17:00 UTC


Attachments (Terms of Use)

Description Pavel Studeník 2013-04-30 13:54:42 UTC
Description of problem:
I created activation key for registering system to satellite. Activation key contained configuration channel with files and rhncfg-* packages. This packages were installed on this machine before registration. Field "Configuration File Deployment" was checked and I registered system with this activation key. But files were not deployed from configuration channel to this system.

Version-Release number of selected component (if applicable):
rhn-setup-1.0.0.1-4.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. create configuration channel and add some files to this channel

2. create activation key with this parameters: 
   a) Add-On Entitlements: Provisioning, choose channel with rhn-tools 
   b) set Configuration File Deployment: checked
   c) join created configuration channel
   d) add these packages rhncfg, rhncfg-actions, rhncfg-client to this activation key

3. before registration install rhncfg-* package and enable deploy:
>> yum install rhncfg-*
>> rhn-actions-control --enable-all
>> rhn-actions-control --report 
deploy is enabled
diff is enabled
upload is enabled
mtime_upload is enabled

4. use activation key for registration
>> rhnreg_ks --activationkey=...

5. check deploying files:
>> rhncfg-client verify
Using server name <hostname>
 missing /mnt/test1.txt
 missing /mnt/test2.txt

Actual results in WebUI:
*) Failed Package Install scheduled by (none)
Client execution returned "Error while executing packages action: empty transaction [[6]]" (code -1)
Packages Scheduled:

    rhncfg
    rhncfg-client
    rhncfg-actions

And next events were not picked up from queue.

*) Schedule a config deploy for activation key scheduled by (none)
This action's status is: Failed.
This action has not yet been picked up. 

Expected results:
All events were picked up.

Comment 2 Clifford Perry 2013-05-20 13:46:04 UTC
I do not think this is a regression, one event is dependent on the other. If it fails, the the other will not happen.

Comment 5 Lukas Pramuk 2013-07-16 17:17:00 UTC

*** This bug has been marked as a duplicate of bug 960524 ***


Note You need to log in before you can comment on or make changes to this bug.