Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 957939 - PRD34 - [RFE] When changing the cluster and data centre compatibility versions, it should be clearly stated that changing from version 3.0 makes the data domains incompatible with RHEV 3,0 and roll back will not be possible.
Summary: PRD34 - [RFE] When changing the cluster and data centre compatibility version...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Allon Mureinik
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-04-30 00:47 UTC by Pieter Demmers
Modified: 2018-12-06 15:05 UTC (History)
10 users (show)

Fixed In Version: av2
Doc Type: Enhancement
Doc Text:
A cluster and data center compatibility version change from 3.0 now triggers the message: "You are about to change the Data Center Compatibility Version. This will upgrade all the Storage Domains belonging to the Data Center, and make them unusable with versions older than 3.1. Are you sure you want to continue?"
Clone Of:
Environment:
Last Closed: 2014-06-09 14:59:00 UTC
oVirt Team: ---
Target Upstream Version:
scohen: needinfo+
scohen: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2014:0506 normal SHIPPED_LIVE Moderate: Red Hat Enterprise Virtualization Manager 3.4.0 update 2014-06-09 18:55:38 UTC
oVirt gerrit 24028 None None None Never
oVirt gerrit 24374 None None None Never

Comment 5 Sandro Bonazzola 2014-02-19 12:27:20 UTC
This bug is referenced in ovirt-engine-3.4.0-beta3 logs. Moving to ON_QA

Comment 6 Aharon Canan 2014-03-09 12:51:59 UTC
Creating 3.0 DC and editing to 3.4 doesn't give informative popup (like asked in the description) .

I got - 
=====
You are about to change the Data Center Compatibility Version. Are you sure you want to continue?

Comment 7 Aharon Canan 2014-03-09 13:05:39 UTC
TCMS run - https://tcms.engineering.redhat.com/run/119792/

My mistake, configuration issue, 
looks o.k.

message - 
=======
You are about to change the Data Center Compatibility Version. This will upgrade all the Storage Domains belonging to the Data Center, and make them unusable with versions older than 3.1. Are you sure you want to continue?

Comment 8 Colin Coe 2014-03-09 22:40:03 UTC
I know this is stating the obvious, but this is going to make it into future revisions, right?   Not just 3.1 as this bugzilla states?

CC

Comment 9 Aharon Canan 2014-03-10 08:23:57 UTC
DC 3.0 uses SD v1 and v2, 
Starting 3.1 we are using only SD v3

which means that in case you upgrade the DC version we will change the SD version. 
It doesn't matter to what version, 3.1 or above.

Comment 10 errata-xmlrpc 2014-06-09 14:59:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2014-0506.html


Note You need to log in before you can comment on or make changes to this bug.