Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 955641 - webadmin: we can create a V1 format posix domain when selecting "None" option in Data Center
Summary: webadmin: we can create a V1 format posix domain when selecting "None" option...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.2.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Tal Nisan
QA Contact: Ori Gofen
URL:
Whiteboard: storage
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-04-23 12:57 UTC by Dafna Ron
Modified: 2016-05-26 01:48 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0-alpha2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 19:13:19 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)
screen shot and logs (deleted)
2013-04-23 12:57 UTC, Dafna Ron
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 28130 master MERGED webadmin: When adding new domain disable V1 format in Posix & Gluster Never

Description Dafna Ron 2013-04-23 12:57:59 UTC
Created attachment 738994 [details]
screen shot and logs

Description of problem:

we can create a V1 posix domain but since posix was introduced in 3.1 and V1 domains are not compatible to 3.1 DC level and up, there is not much point in creating a V1 posix domain which we cannot add to any DC.

Version-Release number of selected component (if applicable):

sf13.1

How reproducible:

100%

Steps to Reproduce:
1. new domain dialogue -> Data Center=None -> storage type=Data/POSIX
2. select format V1 (VFS Type=nfs)
3. after domain is created try to attach it to a posix DC
 
Actual results:

the domain is created as V1 but since posix domain is only supported starting with 3.1 DC level compatibility we cannot attach the domain.

Expected results:

we should remove the V1 from roller selection for posix domains since we cannot actually use such a domain.

Additional info: screen shot and logs

Comment 1 Allon Mureinik 2013-06-24 11:54:23 UTC
Same should apply to glusterfs

Comment 3 Aharon Canan 2014-03-11 09:48:46 UTC
No reason to close it. we need to fix

Comment 4 Ori Gofen 2014-07-08 11:36:51 UTC
verified on alpha2

Comment 6 Allon Mureinik 2015-02-16 19:13:19 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 7 Allon Mureinik 2015-02-16 19:13:19 UTC
RHEV-M 3.5.0 has been released, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.