Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 953101 (razorqt) - Review Request: razorqt - Lightweight desktop toolbox
Summary: Review Request: razorqt - Lightweight desktop toolbox
Keywords:
Status: CLOSED ERRATA
Alias: razorqt
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brendan Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: qt-reviews
TreeView+ depends on / blocked
 
Reported: 2013-04-17 11:29 UTC by Eugene A. Pivnev
Modified: 2014-06-18 16:07 UTC (History)
7 users (show)

Fixed In Version: razorqt-0.5.2-9.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-14 04:37:33 UTC
brendan.jones.it: fedora-review+
kevin: fedora-cvs+


Attachments (Terms of Use)

Comment 1 Rex Dieter 2013-04-17 12:08:32 UTC
Some initial comments:

1.  in fedora at least, you can omit:
%dir %{_datadir}/apps/
%dir %{_datadir}/apps/kdm/
%dir %{_datadir}/apps/kdm/sessions/
%{_datadir}/apps/kdm/sessions/razor*.desktop

kdm is configured to use /usr/share/xsessions exclusively in fedora (and besides, fedora's kde4 uses a /usr/share/kde4/apps prefix instead of /usr/share/apps)

2.  -autosuspend subpkg includes icons, but there are no icon scriptlets

a general comment about many of the subpackages here... I personally would drop many of the subpackages as I can't imagine many users wanting only parts of razorqt.  Having the main metapackage helps though.  Could you describe the justifications and/or use-case for the fine-grained splitting? (I have an idea what you may say, but it will be nice to document it here for posterity anyway).

Comment 2 Eugene A. Pivnev 2013-04-17 18:06:32 UTC
(In reply to comment #1)
> 1.  in fedora at least, you can omit:
> %dir %{_datadir}/apps/
> %dir %{_datadir}/apps/kdm/
> %dir %{_datadir}/apps/kdm/sessions/
> %{_datadir}/apps/kdm/sessions/razor*.desktop

I'm aimed to EL6+ and f17..rawhide.

> kdm is configured to use /usr/share/xsessions exclusively in fedora (and
> besides, fedora's kde4 uses a /usr/share/kde4/apps prefix instead of
> /usr/share/apps)

I can 1) move files using spec, 2) patch cmakefiles, 3) to bother upstream.
What would be the best option?

> 2.  -autosuspend subpkg includes icons, but there are no icon scriptlets
Will be fixed.
Current todolist: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt_todo.txt

> a general comment about many of the subpackages here... I personally would
> drop many of the subpackages as I can't imagine many users wanting only
> parts of razorqt.  Having the main metapackage helps though.  Could you
> describe the justifications and/or use-case for the fine-grained splitting?
> (I have an idea what you may say, but it will be nice to document it here
> for posterity anyway).

No problem.
1. End-user will just install "razorqt" meta-package. All-inclusive.
2. But you can tune package set for your machine. E.g. - minimal razorqt set - http://qtdesktop.googlecode.com/svn/trunk/spins/F17_QDE-min-0.5.ks

Comment 3 Eugene A. Pivnev 2013-04-18 08:46:42 UTC
(In reply to comment #1)
> 1.  in fedora at least, you can omit:
> %dir %{_datadir}/apps/

I check live (working) EL6 (CentOS6) - seems that it uses _datadir/xsessions/ too.

So - my current todo for razorqt: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt_todo.txt

Any additional comments?

Comment 4 Mario Blättermann 2013-04-18 08:52:06 UTC
(In reply to comment #1)
> a general comment about many of the subpackages here... I personally would
> drop many of the subpackages as I can't imagine many users wanting only
> parts of razorqt.  Having the main metapackage helps though.  Could you
> describe the justifications and/or use-case for the fine-grained splitting?
> (I have an idea what you may say, but it will be nice to document it here
> for posterity anyway).

(In reply to comment #2)
> 1. End-user will just install "razorqt" meta-package. All-inclusive.
> 2. But you can tune package set for your machine. E.g. - minimal razorqt set
> - http://qtdesktop.googlecode.com/svn/trunk/spins/F17_QDE-min-0.5.ks

I agree. Most of the razor-qt parts are usable standalone. We shouldn't force users to install the whole razor-qt stuff if they just want to use one of the modules in a different environment. They might want to use the app launcher to replace the ugly one in Fluxbox, for example.

Comment 5 Eugene A. Pivnev 2013-04-21 10:42:34 UTC
Release 2 - total cleanup.
I think - this package is ready for real review.

Spec URL: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt.spec
SRPM URL: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt-0.5.2-2.fc18.src.rpm

Koji (dist-6E-epel f17 f18 f19 rawhide):
http://koji.fedoraproject.org/koji/taskinfo?taskID=5284369
http://koji.fedoraproject.org/koji/taskinfo?taskID=5284392
http://koji.fedoraproject.org/koji/taskinfo?taskID=5284405
http://koji.fedoraproject.org/koji/taskinfo?taskID=5284420
http://koji.fedoraproject.org/koji/taskinfo?taskID=5284430

fedora-review result: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt_review-0.5.2-2.txt

= Explanations =

* "Package installs a %{name}.desktop using desktop-file-install if there is such a file."
There is no %{name}.desktop. Other *.desktops are installing with "make".

* "Large data in /usr/share should live in a noarch subpackage if package is arched."
Most of them are translations. razorqt-data can be noarch but contents executable /usr/lib/razor-xdg-tools/*.

* "W: no-documentation", "W: no-manual-page-for-binary"
I know.

* "W: spelling-error", "W: non-conffile-in-etc /etc/xdg/autostart/", "W: devel-file-in-non-devel-package /usr/bin/razor-config"
rpmlint is wrong.

* "razorqt.i686: E: no-binary"
I don't know how to solve this. Same error is producing for "wine" meta package.

* "razorqt-data.i686: W: only-non-binary-in-usr-lib"
These are patched xdg bash scripts - "it will be removed when it becomes part of upstream".

Comment 6 Christopher Meng 2013-04-21 10:49:49 UTC
Oh....

I just wrote a feature page for this, anything can I help here?

http://fedoraproject.org/wiki/Features/Razor-qt

Comment 7 Eugene A. Pivnev 2013-04-21 10:57:43 UTC
(In reply to comment #6)
> Oh....
> 
> I just wrote a feature page for this, anything can I help here?

To review :-)

I think - to rename Razor-qt wiki into QtDesktop will be better.
Because razorqt is not real DE (as KDE or GNOME) - it is "desktop toolbox".
But "QtDesktop" environment is collection of qt-based applications. With RazorQt ahead, yes.

Comment 8 Christopher Meng 2013-04-21 11:05:51 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Oh....
> > 
> > I just wrote a feature page for this, anything can I help here?
> 
> To review :-)
> 
> I think - to rename Razor-qt wiki into QtDesktop will be better.
> Because razorqt is not real DE (as KDE or GNOME) - it is "desktop toolbox".
> But "QtDesktop" environment is collection of qt-based applications. With
> RazorQt ahead, yes.

DONE. http://fedoraproject.org/wiki/Features/QtDesktop

And please add your name here. This page still need modification.

In fact I tried to package it yesterday...But now you've done what I tried to do. I will comaintain this when available.

Comment 9 Eugene A. Pivnev 2013-04-21 11:13:44 UTC
(In reply to comment #8)
> DONE. http://fedoraproject.org/wiki/Features/QtDesktop
Thank you.

> And please add your name here. This page still need modification.
Where? Into "Owner"?
I never used fedora wiki.

> In fact I tried to package it yesterday...But now you've done what I tried to do.

I spent two weeks to prepare razorqt for fedora review.
After 4 years of maintaining in OBS.
It is not so trivial :-)

> I will comaintain this when available.
Thank #2.

Comment 10 Christopher Meng 2013-04-21 11:20:56 UTC
(In reply to comment #9)
> I never used fedora wiki.

I think this is feature name cover a lot of things listed here:

http://www.qtdesktop.org/applist

Right?

If so, I think bring so many packages into Fedora can be a feature, and of course this is a feature, just talk about razor-qt, it's a desktop environment, after porting this into Fedora we can also make spins...or whatever. QtDesktop contains a lot of tools and of course many of them is not in Fedora, I've done search via pkgs.org.

> After 4 years of maintaining in OBS.

I know of course~ In fact I'm using your spec as my source yesterday.

Comment 11 Eugene A. Pivnev 2013-04-21 11:35:28 UTC
(In reply to comment #10)
> I think this is feature name cover a lot of things listed here:
> http://www.qtdesktop.org/applist
> Right?

Yes.

> If so, I think bring so many packages into Fedora can be a feature, and of
> course this is a feature, just talk about razor-qt, it's a desktop
> environment, after porting this into Fedora we can also make spins...or
> whatever. QtDesktop contains a lot of tools and of course many of them is
> not in Fedora, I've done search via pkgs.org.

Main idea was to add new environment to main distros.
And application set unified as for Windows as for MacOS as for Linux.
Then - it must be not-gtk and not-kde.
OBS repo was created for this task - to push qt apps into rpm-based distros.
Only thing that was absent - pure qt WM. After razorqt appears QtDesktop is all-sufficient.
Next stage was to push packages from OBS to Fedora and OpenSUSE (as OBS repo is comaintained by Petr Vanek (razorqt leading developer and OpenSUSE user) and me (not developer and RH-based user)).

But all of these are not subject of this (953101) bug.

Comment 12 Christopher Meng 2013-04-21 11:38:20 UTC
(In reply to comment #11)

OK. Let's talk in pivate later.

Comment 13 Brendan Jones 2013-04-22 21:33:38 UTC
I'll take this review on. Just a few things before I get started:

 * Consider https://fedoraproject.org/wiki/Packaging:Guidelines#Requiring_Base_Package for your arch specific sub-packages

 * Again, there are -O3 optimizations present in the build

Comment 14 Brendan Jones 2013-04-22 21:43:24 UTC
For sub-packages that package .qm help files you will need to use the %find_lang macro:

https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#Handling_Locale_Files

Also some issues in rpmlint that can be handled (should the metapackage be noarch? thus negating my previous comment)
razorqt.x86_64: E: no-binary

and

razorqt-data.x86_64: W: only-non-binary-in-usr-lib

Comment 15 Eugene A. Pivnev 2013-04-23 09:55:30 UTC
(In reply to comment #13)
>  * Again, there are -O3 optimizations present in the build

Seems that it is really %cmake macro bug/feature.

Comment 16 Eugene A. Pivnev 2013-04-23 10:02:58 UTC
(In reply to comment #14)
> For sub-packages that package .qm help files you will need to use the
> %find_lang macro:

I am to make some "researches". Will be in next package release (-4).

> Also some issues in rpmlint that can be handled (should the metapackage be
> noarch? thus negating my previous comment)
> razorqt.x86_64: E: no-binary

Setting main package (=== meta-packages) in noarch make all subpackages noarch too.
Same "error" is in wine metapackage.

> razorqt-data.x86_64: W: only-non-binary-in-usr-lib

Fixed - razorqt-data is noarch now and binaries removed.
Note: that binaries was xdg-utils replacement. After hot discussion (https://groups.google.com/forum/?fromgroups#!topic/razor-qt/c_AFBYwJSM8) I desided to remove these utils from package. This means that razorqt will be ok in Fedora17+, but _can_ be not fine in EL6 (without fresh xdg-utils).

Spec URL: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt.spec
SRPM URL: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt-0.5.2-3.fc18.src.rpm

Comment 17 Eugene A. Pivnev 2013-04-23 10:09:58 UTC
(In reply to comment #14)
> For sub-packages that package .qm help files you will need to use the
> %find_lang macro:
> 
> https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/
> Guidelines#Handling_Locale_Files

Sorry - "You _can_ then use that file to include all of the locales".
All qms in all subpackages are installing with make_install to proper folders and I need no to do something special with them.
IMO.

Comment 18 Brendan Jones 2013-04-23 10:24:09 UTC
As they are not being stored in %{_datadir}/locale/ you are right.

Comment 19 Eugene A. Pivnev 2013-04-23 10:39:23 UTC
(In reply to comment #18)
> As they are not being stored in %{_datadir}/locale/ you are right.

No one.
As I found - preferred way for qt-aps developers - to put translations into _datadir/%{name}/{translations,l10n,i18n,locale,etc).
This is easier for cross-platform applications.

Comment 20 Kevin Kofler 2013-04-23 16:00:35 UTC
> Sorry - "You _can_ then use that file to include all of the locales".

You misunderstand the guidelines. You MUST use %find_lang to handle locales if possible. And if it is not possible, you MUST tag every single .qm (and/or .mo etc.) file with a %lang tag for the appropriate language, e.g.:
%lang(de) /path/to/de.qm
But in this case, %find_lang should work fine, so there is no need to do it manually.

> All qms in all subpackages are installing with make_install to proper folders
> and I need no to do something special with them.

It's not a matter of where the files are installed, but how they're tagged for RPM. Translations need to be tagged with the appropriate language so the RPM feature of only installing translations for a subset of languages (useful for very space-constrained environments) works.

> As they are not being stored in %{_datadir}/locale/ you are right.

Wrong. The location of the files does not matter. The language they're in does.

> As I found - preferred way for qt-aps developers - to put translations into
> _datadir/%{name}/{translations,l10n,i18n,locale,etc).
> This is easier for cross-platform applications.

This is a very crappy and broken way to handle translations, but that's an upstream issue. All that YOU need to care about is using %find_lang so the correct %lang metadata gets generated.

Comment 21 Eugene A. Pivnev 2013-04-24 07:56:44 UTC
(In reply to comment #20)
> All that YOU need to care about is using %find_lang so the
> correct %lang metadata gets generated.

Ok, I get - metadata are important.
I will try to use find_lang and then will update all of my packages.
Thank you.

Comment 22 Eugene A. Pivnev 2013-04-24 07:57:52 UTC
Package updated - -O3 solved.
Spec URL: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt.spec
SRPM URL: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt-0.5.2-4.fc18.src.rpm

As for me - there is no [critical] errors in it :-)

Comment 23 Kevin Kofler 2013-04-24 18:21:19 UTC
So I had written:
> This is a very crappy and broken way to handle translations, but that's an
> upstream issue.

But actually, unfortunately, there doesn't seem to be any standard location for .qm files. To be honest, the real problem is Qt reinventing gettext in the first place… Most normal software including KDE software installs gettext .mo files to /usr/share/locale/$LANG/LC_MESSAGES/*.mo, but putting .qm files in there is probably not that great an idea anyway. And I see that most Qt-only stuff puts the translations somewhere under %{_datadir}/name. So I guess keep things the way they are. I think it would theoretically be better to have something under /use/share/locale (maybe /usr/share/locale/$LANG/QT_MESSAGES or something like that?), but if only one package uses that, it's not very helpful.

Comment 24 Eugene A. Pivnev 2013-04-24 19:47:18 UTC
(In reply to comment #23)
> So I had written:
> > This is a very crappy and broken way to handle translations, but that's an
> > upstream issue.
> 
> But actually, unfortunately, there doesn't seem to be any standard location
> for .qm files. To be honest, the real problem is Qt reinventing gettext in
> the first place… Most normal software including KDE software installs
> gettext .mo files to /usr/share/locale/$LANG/LC_MESSAGES/*.mo, but putting
> .qm files in there is probably not that great an idea anyway. And I see that
> most Qt-only stuff puts the translations somewhere under %{_datadir}/name.
> So I guess keep things the way they are. I think it would theoretically be
> better to have something under /use/share/locale (maybe
> /usr/share/locale/$LANG/QT_MESSAGES or something like that?), but if only
> one package uses that, it's not very helpful.

Keep in mind that:
* Windows has no /usr/share/...
* MacOS - has no...
* Symbian...
* QNX
* Android
* ...

Comment 25 Kevin Kofler 2013-04-24 21:39:04 UTC
Keep in mind that crappy non-*nix OSes are completely irrelevant when it comes to the FHS. :-)

Comment 26 Kevin Kofler 2013-04-24 21:40:30 UTC
Oh, and the current version of Mac OS does in fact have /usr/share. :-) (And I think QNX does too, and Android behind the scenes too, but I'm not sure about those.)

Comment 27 Eugene A. Pivnev 2013-04-26 17:17:01 UTC
(In reply to comment #13)
> I'll take this review on. Just a few things before I get started:

I'm sorry but... what can I do to speed up reviewing process?

Comment 28 Brendan Jones 2013-04-26 17:24:28 UTC
Patience Eugene

Comment 29 Brendan Jones 2013-04-26 18:01:08 UTC
You still have not tagged the locale files? Kevin stands me corrected on this count.

Comment 30 Eugene A. Pivnev 2013-04-26 19:10:54 UTC
(In reply to comment #29)
> You still have not tagged the locale files? Kevin stands me corrected on
> this count.

"Under construction" :-(
If this is the only bug...

Comment 31 Brendan Jones 2013-04-26 20:05:30 UTC
Its quite significant actually because I imagine you will need to tag all of these files within each sub-package.

The rest looks pretty good. I personally am looking forward to the a future Fedora Audio spin based on razor rather than KDE

Comment 32 Eugene A. Pivnev 2013-04-26 20:19:23 UTC
(In reply to comment #31)
> Its quite significant actually because I imagine you will need to tag all of
> these files within each sub-package.
> 
> The rest looks pretty good. I personally am looking forward to the a future
> Fedora Audio spin based on razor rather than KDE

Ok - I'll prepare and upload new (final?) pre-applying package release tomorrow today (now is MSK 00:22):
- xdg-utils workaround back (for rhel) in separate subpakage;
- find_lang;

as for simple project - find_lang approving looks like this:
 %install
+%find_lang %{name} --with-qt
...
-%files
+%files -f %{name}.lang
...
-%{_datadir}/%{name}
+#{_datadir}/%{name}
+%dir %{_datadir}/%{name}
+%{_datadir}/%{name}/theme/

So - I am to exclude all of %_datadir/%name - but to include all of subfolders _excluding_ translations.

PS. you can start Fedora Turbo Audio spin here: http://qtdesktop.googlecode.com/svn/trunk/spins/

Comment 33 Brendan Jones 2013-04-26 20:44:24 UTC
(In reply to comment #32)
> (In reply to comment #31)
> > Its quite significant actually because I imagine you will need to tag all of
> > these files within each sub-package.
> > 
> > The rest looks pretty good. I personally am looking forward to the a future
> > Fedora Audio spin based on razor rather than KDE
> 
> Ok - I'll prepare and upload new (final?) pre-applying package release
> tomorrow today (now is MSK 00:22):
> - xdg-utils workaround back (for rhel) in separate subpakage;
> - find_lang;
> 
> as for simple project - find_lang approving looks like this:
>  %install
> +%find_lang %{name} --with-qt
> ...
> -%files
> +%files -f %{name}.lang

I'm pretty sure %find_lang is not going to find them and you will need to tag them as Kevin has suggested

> 
> PS. you can start Fedora Turbo Audio spin here:
> http://qtdesktop.googlecode.com/svn/trunk/spins/

Cool! Its probably a bit late for this release but count me in for the next one. Consider joining the music_creation group if interested

Comment 34 Eugene A. Pivnev 2013-04-26 20:51:20 UTC
(In reply to comment #33)
> I'm pretty sure %find_lang is not going to find them and you will need to
> tag them as Kevin has suggested

Maybe - I read him inattentively:
"You MUST use %find_lang to handle locales if possible. And if it is not possible, you MUST tag every single .qm (and/or .mo etc.) file with a %lang tag for the appropriate language, e.g.:
%lang(de) /path/to/de.qm
But in this case, %find_lang should work fine, so there is no need to do it manually."

In this case - fine - no need manually.

Comment 35 Brendan Jones 2013-04-26 21:04:06 UTC
I tried it and it didn't work for me here.

Comment 36 Eugene A. Pivnev 2013-04-26 21:06:02 UTC
(In reply to comment #35)
> I tried it and it didn't work for me here.

What I am to do to repeate "didn't work"?

Comment 37 Brendan Jones 2013-04-26 21:15:18 UTC
No translations found for --with-qt in /home/bsjones/rpmbuild/BUILDROOT/razorqt-0.5.2-4.fc18.x86_64
error: Bad exit status from /var/tmp/rpm-tmp.q04v0G (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.q04v0G (%install)

Comment 38 Eugene A. Pivnev 2013-04-26 21:20:33 UTC
(In reply to comment #37)
> No translations found for --with-qt in
> /home/bsjones/rpmbuild/BUILDROOT/razorqt-0.5.2-4.fc18.x86_64
> error: Bad exit status from /var/tmp/rpm-tmp.q04v0G (%install)
> 
> 
> RPM build errors:
>     Bad exit status from /var/tmp/rpm-tmp.q04v0G (%install)

Sorry - razorqt -5 not ready yet.
Try this: http://tieugene.fedorapeople.org/rpms/qxkb/

Comment 39 Eugene A. Pivnev 2013-04-27 15:33:05 UTC
(In reply to comment #33)
> I'm pretty sure %find_lang is not going to find them and you will need to
> tag them as Kevin has suggested

I don't know why, but adding translations using lang-files break dependecies.
Like this:

= spec =
-%files autosuspend
+%files autosuspend -f razor-autosuspend.lang -f razor-config-autosuspend.lang
...
-%{_datadir}/razor/razor-autosuspend/
-%{_datadir}/razor/razor-config-autosuspend/
+%dir %{_datadir}/razor/razor-autosuspend/
+%dir %{_datadir}/razor/razor-config-autosuspend/

= fedora-review =
(manual translation to En)
...
Installation errors
-------------------
...
Error: Package: razorqt-0.5.2-6.fc18.i686 (/razorqt-0.5.2-6.fc18.i686)
            Requires: razorqt-autosuspend = 0.5.2-6.fc18

Comment 40 Eugene A. Pivnev 2013-04-27 17:01:35 UTC
Some fixes, find_lang ready:

Spec URL: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt.spec
SRPM URL: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt-0.5.2-5.fc18.src.rpm

Note about find_lang: I tried some tens times - dependency error. You can try yourself: http://tieugene.fedorapeople.org/rpms/razorqt.lang/

Comment 41 Kevin Kofler 2013-04-27 20:47:20 UTC
Brendan:
> No translations found for --with-qt in
> /home/bsjones/rpmbuild/BUILDROOT/razorqt-0.5.2-4.fc18.x86_64

Your %find_lang syntax is wrong, the order of the parameters matters.
Try:
%find_lang razorqt --with-qt --without-mo

Eugene:
> %files autosuspend -f razor-autosuspend.lang -f razor-config-autosuspend.lang

This is not going to work, you can use only one -f file. So you need to do this after calling %find_lang:
cat razor-config-autosuspend.lang >>razor-autosuspend.lang
Then you can use:
%files autosuspend -f razor-autosuspend.lang
and everything will work fine.

Comment 42 Eugene A. Pivnev 2013-04-28 10:02:21 UTC
(In reply to comment #41)
> Brendan:
> > No translations found for --with-qt in
> > /home/bsjones/rpmbuild/BUILDROOT/razorqt-0.5.2-4.fc18.x86_64
> 
> Your %find_lang syntax is wrong, the order of the parameters matters.
> Try:
> %find_lang razorqt --with-qt --without-mo

You tested too old sources.

http://tieugene.fedorapeople.org/rpms/razorqt.lang/razorqt-0.5.2-6.spec :

for i in `cat %{SOURCE1}`; do %find_lang $i --with-qt --without-mo; done

> > %files autosuspend -f razor-autosuspend.lang -f razor-config-autosuspend.lang
> This is not going to work, you can use only one -f file.

1. As for https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#Handling_Locale_Files :

%files -f %{name}.lang -f bar.lang

2. Anyway - I tried to add lang to lib subpackage:

%files	libs -f librazorqt.lang

And no one can find this library.

Comment 43 Eugene A. Pivnev 2013-04-28 11:29:25 UTC
(In reply to comment #41)
> Then you can use:
> %files autosuspend -f razor-autosuspend.lang
> and everything will work fine.

Trivial test (for http://tieugene.fedorapeople.org/rpms/razorqt/razorqt.spec):

<code>
--- razorqt.spec.orig        2013-04-28 14:09:01.752525655 +0400
+++ razorqt.spec        2013-04-28 15:11:08.544630933 +0400
@@ -522,9 +522,9 @@
 %{_datadir}/razor/razor-power/
 %{_datadir}/applications/razor-power.desktop

-%files runner
+%files runner -f razor-runner.lang
 %{_bindir}/razor-runner
-%{_datadir}/razor/razor-runner/
+%dir %{_datadir}/razor/razor-runner/
 %{_sysconfdir}/xdg/autostart/razor-runner.desktop

 %files session
</code>

Result:

Error: Package: razorqt-0.5.2-5.fc18.i686 (/razorqt-0.5.2-5.fc18.i686)
            Requires: razorqt-runner = 0.5.2-5.fc18

Comment 44 Eugene A. Pivnev 2013-04-29 18:47:12 UTC
Show must go on (c) F. Mercury.

Comment 45 Brendan Jones 2013-04-30 04:34:31 UTC
Hi Eugene can you please post your latest SRPM

Comment 46 Brendan Jones 2013-04-30 04:40:17 UTC
(In reply to comment #45)
> Hi Eugene can you please post your latest SRPM

Including %files x -f x.lang etc and I'll have a look

Comment 47 Brendan Jones 2013-04-30 04:46:51 UTC
(In reply to comment #43)
> 
> Result:
> 
> Error: Package: razorqt-0.5.2-5.fc18.i686 (/razorqt-0.5.2-5.fc18.i686)
>             Requires: razorqt-runner = 0.5.2-5.fc18

I'm not seeing this with your test. How are yu installign it? Is this simply an issue with fedora-review ?

Comment 48 Eugene A. Pivnev 2013-04-30 08:23:05 UTC
(In reply to comment #46)
> (In reply to comment #45)
> > Hi Eugene can you please post your latest SRPM
> 
> Including %files x -f x.lang etc and I'll have a look

http://tieugene.fedorapeople.org/rpms/razorqt/ - latest reviewable release (5).

Testing release (with included langs): http://tieugene.fedorapeople.org/rpms/razorqt.lang/ - release 6 (something like "not published").

Patch in comment #43 appliable to release 5.

Comment 49 Brendan Jones 2013-04-30 09:02:41 UTC
Please just post a link to your complete SRPM. 

Do the same with all the other file sections as you have done with runner and I'll look at it.

Comment 50 Eugene A. Pivnev 2013-04-30 09:16:00 UTC
Ok.
* This is srpm with generated but not included lang files: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt-0.5.2-5.fc18.src.rpm
* This is the same but runner includes lang: http://tieugene.fedorapeople.org/rpms/razorqt.runner/razorqt-0.5.2-6.fc18.src.rpm
* This is all lang files included: http://tieugene.fedorapeople.org/rpms/razorqt.lang/razorqt-0.5.2-6.fc18.src.rpm

Comment 51 Brendan Jones 2013-05-02 04:50:35 UTC
OK, this scratch builds OK, so I'm not going to worry about th install log in fedora-review

Just two things:

 * all of your sub-packages need to Require razorqt-data such that the license is always installed.
 * could clean up your change log and commetns. Use %% where appropriate and you've got some double hyphenating

I'm used to seeing the %description right after the %package declaration but thats a matter of style.

You could also consider using an epoch to trump the razorqt repo, but thats entirely up to you. 

Fix the license requires and I'll approve. Good job


Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Package installs properly.
  Note: Installation errors (see attachment)
  See: https://fedoraproject.org/wiki/Packaging:Guidelines
- Package installs a %{name}.desktop using desktop-file-install if there is
  such a file.
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#desktop


===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Header files in -devel subpackage, if present.
[x]: ldconfig called in %post and %postun if required.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[!]: Changelog in prescribed format.
Make sure macros are escaped with %% and you have some double hypenating going on
[!]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf %{buildroot} present but not required
[x]: Sources contain only permissible code or content.
[x]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Fully versioned dependency in subpackages, if present.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in libqtxdg ,
     libqtxdg-devel , razorqt-devel , razorqt-data , razorqt-about , razorqt-
     appswitcher , lightdm-razorqt , razorqt-theme-amego , razorqt-theme-
     ambiance , razorqt-theme-green , razorqt-theme-light , razorqt-themes
[x]: Package complies to the Packaging Guidelines
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "GPL", "LGPL (v2 or later)", "Unknown or generated", "*No copyright*
     WTFPL WTFPL (v2)", "LGPL (v2.1 or later)", "GPL (v3)", "GPL (v2)". 7
     files have unknown license. Detailed output of licensecheck in
     /home/bsjones/review-razorqt/licensecheck.txt
[!]: License file installed when any subpackage combination is installed.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: update-desktop-database is invoked when required
     Note: desktop file(s) in razorqt-about, razorqt-appswitcher, lightdm-
     razorqt
[x]: Useful -debuginfo package or justification otherwise.
[x]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 112640 bytes in 13 files.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: %config files are marked noreplace or the reason is justified.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package contains desktop file if it is a GUI application.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: No %config files under /usr.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[ ]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise justified.
[x]: Scriptlets must be sane, if used.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[ ]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Uses parallel make.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[!]: Rpmlint is run on all installed packages.
     Note: Mock build failed
[ ]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
     Note: Arch-ed rpms have a total of 3358720 bytes in /usr/share 296960
     razorqt-session-0.5.2-6.fc18.x86_64.rpm 337920 razorqt-
     libs-0.5.2-6.fc18.x86_64.rpm 491520 razorqt-
     desktop-0.5.2-6.fc18.x86_64.rpm 81920 razorqt-
     runner-0.5.2-6.fc18.x86_64.rpm 81920 lightdm-
     razorqt-0.5.2-6.fc18.x86_64.rpm 204800 razorqt-
     notifications-0.5.2-6.fc18.x86_64.rpm 122880 razorqt-
     globalkeyshortcuts-0.5.2-6.fc18.x86_64.rpm 184320 razorqt-
     config-0.5.2-6.fc18.x86_64.rpm 71680 razorqt-policykit-
     agent-0.5.2-6.fc18.x86_64.rpm 51200 libqtxdg-0.5.2-6.fc18.x86_64.rpm
     1034240 razorqt-panel-0.5.2-6.fc18.x86_64.rpm 266240 razorqt-
     autosuspend-0.5.2-6.fc18.x86_64.rpm 10240 razorqt-
     about-0.5.2-6.fc18.x86_64.rpm 61440 razorqt-power-0.5.2-6.fc18.x86_64.rpm
     61440 razorqt-openssh-askpass-0.5.2-6.fc18.x86_64.rpm
[x]: Spec file according to URL is the same as in SRPM.


Installation errors
-------------------
INFO: mock.py version 1.1.31 starting...
Start: init plugins
INFO: selinux disabled
Finish: init plugins
Start: run
Mock Version: 1.1.31
INFO: Mock Version: 1.1.31
Start: lock buildroot
INFO: installing package(s): /home/bsjones/review-razorqt/results/razorqt-0.5.2-6.fc18.x86_64.rpm /home/bsjones/review-razorqt/results/libqtxdg-0.5.2-6.fc18.x86_64.rpm /home/bsjones/review-razorqt/results/libqtxdg-devel-0.5.2-6.fc18.x86_64.rpm /home/bsjones/review-razorqt/results/razorqt-devel-0.5.2-6.fc18.x86_64.rpm /home/bsjones/review-razorqt/results/razorqt-data-0.5.2-6.fc18.noarch.rpm /home/bsjones/review-razorqt/results/razorqt-about-0.5.2-6.fc18.x86_64.rpm /home/bsjones/review-razorqt/results/razorqt-appswitcher-0.5.2-6.fc18.x86_64.rpm /home/bsjones/review-razorqt/results/lightdm-razorqt-0.5.2-6.fc18.x86_64.rpm /home/bsjones/review-razorqt/results/razorqt-theme-amego-0.5.2-6.fc18.noarch.rpm /home/bsjones/review-razorqt/results/razorqt-theme-ambiance-0.5.2-6.fc18.noarch.rpm /home/bsjones/review-razorqt/results/razorqt-theme-green-0.5.2-6.fc18.noarch.rpm /home/bsjones/review-razorqt/results/razorqt-theme-light-0.5.2-6.fc18.noarch.rpm /home/bsjones/review-razorqt/results/razorqt-themes-0.5.2-6.fc18.noarch.rpm
ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/fedora-18-x86_64/root/', 'install', '/home/bsjones/review-razorqt/results/razorqt-0.5.2-6.fc18.x86_64.rpm', '/home/bsjones/review-razorqt/results/libqtxdg-0.5.2-6.fc18.x86_64.rpm', '/home/bsjones/review-razorqt/results/libqtxdg-devel-0.5.2-6.fc18.x86_64.rpm', '/home/bsjones/review-razorqt/results/razorqt-devel-0.5.2-6.fc18.x86_64.rpm', '/home/bsjones/review-razorqt/results/razorqt-data-0.5.2-6.fc18.noarch.rpm', '/home/bsjones/review-razorqt/results/razorqt-about-0.5.2-6.fc18.x86_64.rpm', '/home/bsjones/review-razorqt/results/razorqt-appswitcher-0.5.2-6.fc18.x86_64.rpm', '/home/bsjones/review-razorqt/results/lightdm-razorqt-0.5.2-6.fc18.x86_64.rpm', '/home/bsjones/review-razorqt/results/razorqt-theme-amego-0.5.2-6.fc18.noarch.rpm', '/home/bsjones/review-razorqt/results/razorqt-theme-ambiance-0.5.2-6.fc18.noarch.rpm', '/home/bsjones/review-razorqt/results/razorqt-theme-green-0.5.2-6.fc18.noarch.rpm', '/home/bsjones/review-razorqt/results/razorqt-theme-light-0.5.2-6.fc18.noarch.rpm', '/home/bsjones/review-razorqt/results/razorqt-themes-0.5.2-6.fc18.noarch.rpm']
Error: Package: razorqt-0.5.2-6.fc18.x86_64 (/razorqt-0.5.2-6.fc18.x86_64)
           Requires: razorqt-desktop = 0.5.2-6.fc18
Error: Package: razorqt-0.5.2-6.fc18.x86_64 (/razorqt-0.5.2-6.fc18.x86_64)
           Requires: razorqt-notifications = 0.5.2-6.fc18
Error: Package: razorqt-appswitcher-0.5.2-6.fc18.x86_64 (/razorqt-appswitcher-0.5.2-6.fc18.x86_64)
           Requires: librazorqxt.so.0()(64bit)
Error: Package: lightdm-razorqt-0.5.2-6.fc18.x86_64 (/lightdm-razorqt-0.5.2-6.fc18.x86_64)
           Requires: librazorqt.so.0()(64bit)
Error: Package: razorqt-about-0.5.2-6.fc18.x86_64 (/razorqt-about-0.5.2-6.fc18.x86_64)
           Requires: librazorqt.so.0()(64bit)
Error: Package: razorqt-0.5.2-6.fc18.x86_64 (/razorqt-0.5.2-6.fc18.x86_64)
           Requires: razorqt-config = 0.5.2-6.fc18
Error: Package: razorqt-0.5.2-6.fc18.x86_64 (/razorqt-0.5.2-6.fc18.x86_64)
           Requires: razorqt-session = 0.5.2-6.fc18
Error: Package: razorqt-appswitcher-0.5.2-6.fc18.x86_64 (/razorqt-appswitcher-0.5.2-6.fc18.x86_64)
           Requires: librazorqt.so.0()(64bit)
Error: Package: razorqt-0.5.2-6.fc18.x86_64 (/razorqt-0.5.2-6.fc18.x86_64)
           Requires: razorqt-runner = 0.5.2-6.fc18
Error: Package: razorqt-devel-0.5.2-6.fc18.x86_64 (/razorqt-devel-0.5.2-6.fc18.x86_64)
           Requires: librazormount.so.0()(64bit)
 You could try using --skip-broken to work around the problem
Error: Package: razorqt-0.5.2-6.fc18.x86_64 (/razorqt-0.5.2-6.fc18.x86_64)
           Requires: razorqt-globalkeyshortcuts = 0.5.2-6.fc18
Error: Package: razorqt-0.5.2-6.fc18.x86_64 (/razorqt-0.5.2-6.fc18.x86_64)
           Requires: razorqt-power = 0.5.2-6.fc18
Error: Package: razorqt-0.5.2-6.fc18.x86_64 (/razorqt-0.5.2-6.fc18.x86_64)
           Requires: razorqt-policykit-agent = 0.5.2-6.fc18
Error: Package: razorqt-0.5.2-6.fc18.x86_64 (/razorqt-0.5.2-6.fc18.x86_64)
           Requires: razorqt-autosuspend = 0.5.2-6.fc18
Error: Package: razorqt-devel-0.5.2-6.fc18.x86_64 (/razorqt-devel-0.5.2-6.fc18.x86_64)
           Requires: librazorqxt.so.0()(64bit)
Error: Package: razorqt-devel-0.5.2-6.fc18.x86_64 (/razorqt-devel-0.5.2-6.fc18.x86_64)
           Requires: razorqt-libs(x86-64) = 0.5.2-6.fc18
Error: Package: razorqt-devel-0.5.2-6.fc18.x86_64 (/razorqt-devel-0.5.2-6.fc18.x86_64)
           Requires: librazorqt.so.0()(64bit)
Error: Package: razorqt-0.5.2-6.fc18.x86_64 (/razorqt-0.5.2-6.fc18.x86_64)
           Requires: razorqt-panel = 0.5.2-6.fc18
Error: Package: razorqt-0.5.2-6.fc18.x86_64 (/razorqt-0.5.2-6.fc18.x86_64)
           Requires: razorqt-openssh-askpass = 0.5.2-6.fc18
 You could try running: rpm -Va --nofiles --nodigest



Rpmlint
-------
Checking: razorqt-0.5.2-6.fc18.x86_64.rpm
          libqtxdg-0.5.2-6.fc18.x86_64.rpm
          libqtxdg-devel-0.5.2-6.fc18.x86_64.rpm
          razorqt-devel-0.5.2-6.fc18.x86_64.rpm
          razorqt-data-0.5.2-6.fc18.noarch.rpm
          razorqt-about-0.5.2-6.fc18.x86_64.rpm
          razorqt-appswitcher-0.5.2-6.fc18.x86_64.rpm
          lightdm-razorqt-0.5.2-6.fc18.x86_64.rpm
          razorqt-theme-amego-0.5.2-6.fc18.noarch.rpm
          razorqt-theme-ambiance-0.5.2-6.fc18.noarch.rpm
          razorqt-theme-green-0.5.2-6.fc18.noarch.rpm
          razorqt-theme-light-0.5.2-6.fc18.noarch.rpm
          razorqt-themes-0.5.2-6.fc18.noarch.rpm
razorqt.x86_64: E: no-binary
razorqt.x86_64: W: no-documentation
libqtxdg-devel.x86_64: W: no-documentation
razorqt-devel.x86_64: W: spelling-error %description -l en_US amongst -> among st, among-st, among
razorqt-devel.x86_64: W: no-documentation
razorqt-devel.x86_64: W: no-manual-page-for-binary razor-x11info
razorqt-about.x86_64: W: no-documentation
razorqt-about.x86_64: W: no-manual-page-for-binary razor-about
razorqt-appswitcher.x86_64: W: spelling-error %description -l en_US config -> con fig, con-fig, configure
razorqt-appswitcher.x86_64: W: no-documentation
razorqt-appswitcher.x86_64: W: non-conffile-in-etc /etc/xdg/autostart/razor-appswitcher.desktop
razorqt-appswitcher.x86_64: W: no-manual-page-for-binary razor-appswitcher
lightdm-razorqt.x86_64: W: no-documentation
lightdm-razorqt.x86_64: W: no-manual-page-for-binary razor-lightdm-greeter
razorqt-theme-amego.noarch: W: spelling-error Summary(en_US) mego -> MEGO, meg, ego
razorqt-theme-amego.noarch: W: spelling-error %description -l en_US mego -> MEGO, meg, ego
razorqt-theme-amego.noarch: W: no-documentation
razorqt-theme-ambiance.noarch: W: no-documentation
razorqt-theme-green.noarch: W: no-documentation
razorqt-theme-light.noarch: W: no-documentation
razorqt-themes.noarch: W: no-documentation
13 packages and 0 specfiles checked; 1 errors, 20 warnings.




Requires
--------
razorqt-theme-light (rpmlib, GLIBC filtered):
    razorqt-data

razorqt (rpmlib, GLIBC filtered):
    razorqt-about
    razorqt-appswitcher
    razorqt-autosuspend
    razorqt-config
    razorqt-data
    razorqt-desktop
    razorqt-globalkeyshortcuts
    razorqt-notifications
    razorqt-openssh-askpass
    razorqt-panel
    razorqt-policykit-agent
    razorqt-power
    razorqt-runner
    razorqt-session

razorqt-theme-ambiance (rpmlib, GLIBC filtered):
    razorqt-data

razorqt-about (rpmlib, GLIBC filtered):
    libQtCore.so.4()(64bit)
    libQtDBus.so.4()(64bit)
    libQtGui.so.4()(64bit)
    libQtXml.so.4()(64bit)
    libX11.so.6()(64bit)
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libm.so.6()(64bit)
    libmagic.so.1()(64bit)
    libqtxdg.so.0()(64bit)
    librazorqt.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    razorqt-data
    rtld(GNU_HASH)

libqtxdg-devel (rpmlib, GLIBC filtered):
    /usr/bin/pkg-config
    libqtxdg(x86-64)
    libqtxdg.so.0()(64bit)

razorqt-data (rpmlib, GLIBC filtered):
    config(razorqt-data)
    razorqt-theme-light
    redhat-menus

razorqt-theme-green (rpmlib, GLIBC filtered):
    razorqt-data

razorqt-devel (rpmlib, GLIBC filtered):
    /usr/bin/pkg-config
    libQtCore.so.4()(64bit)
    libQtDBus.so.4()(64bit)
    libQtGui.so.4()(64bit)
    libQtXml.so.4()(64bit)
    libX11.so.6()(64bit)
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libm.so.6()(64bit)
    libmagic.so.1()(64bit)
    libqtxdg.so.0()(64bit)
    librazormount.so.0()(64bit)
    librazorqt.so.0()(64bit)
    librazorqxt.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    razorqt-libs(x86-64)
    rtld(GNU_HASH)

razorqt-themes (rpmlib, GLIBC filtered):
    razorqt-theme-ambiance
    razorqt-theme-amego
    razorqt-theme-green
    razorqt-theme-light

razorqt-theme-amego (rpmlib, GLIBC filtered):
    razorqt-data

libqtxdg (rpmlib, GLIBC filtered):
    /sbin/ldconfig
    libQtCore.so.4()(64bit)
    libQtDBus.so.4()(64bit)
    libQtGui.so.4()(64bit)
    libQtXml.so.4()(64bit)
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libm.so.6()(64bit)
    libmagic.so.1()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    rtld(GNU_HASH)

lightdm-razorqt (rpmlib, GLIBC filtered):
    /bin/sh
    /usr/sbin/update-alternatives
    libQtCore.so.4()(64bit)
    libQtDBus.so.4()(64bit)
    libQtGui.so.4()(64bit)
    libQtNetwork.so.4()(64bit)
    libQtXml.so.4()(64bit)
    libX11.so.6()(64bit)
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    liblightdm-qt-2.so.0()(64bit)
    libm.so.6()(64bit)
    libmagic.so.1()(64bit)
    libqtxdg.so.0()(64bit)
    librazorqt.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    lightdm
    razorqt-data
    rtld(GNU_HASH)

razorqt-appswitcher (rpmlib, GLIBC filtered):
    libQtCore.so.4()(64bit)
    libQtDBus.so.4()(64bit)
    libQtGui.so.4()(64bit)
    libQtXml.so.4()(64bit)
    libX11.so.6()(64bit)
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libm.so.6()(64bit)
    libmagic.so.1()(64bit)
    libqtxdg.so.0()(64bit)
    librazorqt.so.0()(64bit)
    librazorqxt.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    razorqt-data
    rtld(GNU_HASH)



Provides
--------
razorqt-theme-light:
    razorqt-theme
    razorqt-theme-light

razorqt:
    razorqt
    razorqt(x86-64)

razorqt-theme-ambiance:
    razorqt-theme
    razorqt-theme-ambiance

razorqt-about:
    razorqt-about
    razorqt-about(x86-64)

libqtxdg-devel:
    libqtxdg-devel
    libqtxdg-devel(x86-64)
    pkgconfig(qtxdg)

razorqt-data:
    config(razorqt-data)
    razorqt-data

razorqt-theme-green:
    razorqt-theme
    razorqt-theme-green

razorqt-devel:
    pkgconfig(razormount)
    pkgconfig(razorqt)
    pkgconfig(razorqxt)
    razorqt-devel
    razorqt-devel(x86-64)

razorqt-themes:
    razorqt-themes

razorqt-theme-amego:
    razorqt-theme
    razorqt-theme-amego

libqtxdg:
    libqtxdg
    libqtxdg(x86-64)
    libqtxdg.so.0()(64bit)

lightdm-razorqt:
    lightdm-greeter
    lightdm-razorqt
    lightdm-razorqt(x86-64)

razorqt-appswitcher:
    razorqt-appswitcher
    razorqt-appswitcher(x86-64)



MD5-sum check
-------------
http://razor-qt.org/downloads/razorqt-0.5.2.tar.bz2 :
  CHECKSUM(SHA256) this package     : ac8a890eba7a24a20a2c0ea7a5020c6001853997c1e1b1b927ff4700b0e0e1ad
  CHECKSUM(SHA256) upstream package : ac8a890eba7a24a20a2c0ea7a5020c6001853997c1e1b1b927ff4700b0e0e1ad


Generated by fedora-review 0.4.0 (660ce56) last change: 2013-01-29
Buildroot used: fedora-18-x86_64
Command line :/usr/bin/fedora-review -m fedora-18-x86_64 -n razorqt

Comment 52 Eugene A. Pivnev 2013-05-04 14:40:26 UTC
(In reply to comment #51)
> OK, this scratch builds OK, so I'm not going to worry about th install log
> in fedora-review

Koji just builds packages but not tries to install them. Not?
So - what final resume will be: to use lang files - or not?
I propose to leave _prepared_ spec - but not use them. Untill fedora-review will be ok.

Comment 53 Eugene A. Pivnev 2013-05-04 15:31:06 UTC
Hm... I tried in my own host - packages with lang files are installing ok.
Seems that fedora-review has bugs.

Comment 54 Eugene A. Pivnev 2013-05-05 09:55:45 UTC
(In reply to comment #20)
> You MUST use %find_lang to handle locales if possible.

http://kojipkgs.fedoraproject.org//work/tasks/2314/5332314/build.log

Comment 55 Eugene A. Pivnev 2013-05-05 11:04:14 UTC
(In reply to comment #51)
>  * all of your sub-packages need to Require razorqt-data such that the
> license is always installed.

Fixed.
Note #1: instead of adding -data to Requires I added licenses to libqxtdg and -libs. According to dependency graph (http://tieugene.fedorapeople.org/rpms/razorqt/razorqt.svg or http://tieugene.fedorapeople.org/rpms/razorqt/razorqt.dot) any other subpackage requires one/some/all of them.
Note #2: -xdg is not part of razorqt - it is just fixed version of xdg-utils for EL6.

>  * could clean up your change log and commetns. Use %% where appropriate and
> you've got some double hyphenating
Fixed.

> I'm used to seeing the %description right after the %package declaration but
> thats a matter of style.
I'd like to choose something one - "section > subpackage" or "package > section" order. In 2nd case I'm to put package > %description > %files (together). I prefere _strict_ "section > subpackage" order, sorry.

> Fix the license requires and I'll approve. Good job

Whew...
Thank you very much.

Koji builds (dist-6E-epel, f17..rawhide):
http://koji.fedoraproject.org/koji/taskinfo?taskID=5332318
http://koji.fedoraproject.org/koji/taskinfo?taskID=5332332
http://koji.fedoraproject.org/koji/taskinfo?taskID=5332337
http://koji.fedoraproject.org/koji/taskinfo?taskID=5332360
http://koji.fedoraproject.org/koji/taskinfo?taskID=5332365

Spec URL: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt.spec
SRPM URL: http://tieugene.fedorapeople.org/rpms/razorqt/razorqt-0.5.2-7.fc18.src.rpm

Comment 56 Brendan Jones 2013-05-05 14:04:09 UTC
(In reply to comment #55)
> (In reply to comment #51)
> >  * all of your sub-packages need to Require razorqt-data such that the
> > license is always installed.
> 
> Fixed.
> Note #1: instead of adding -data to Requires I added licenses to libqxtdg
> and -libs. According to dependency graph
> (http://tieugene.fedorapeople.org/rpms/razorqt/razorqt.svg or
> http://tieugene.fedorapeople.org/rpms/razorqt/razorqt.dot) any other
> subpackage requires one/some/all of them.
> Note #2: -xdg is not part of razorqt - it is just fixed version of xdg-utils
> for EL6.

Works for me.

This package is APPROVED

Comment 57 Kevin Kofler 2013-05-05 14:07:26 UTC
> http://kojipkgs.fedoraproject.org//work/tasks/2314/5332314/build.log

>   /usr/share/razor/razor-config/razor-config-appearance_sr@latin.qm
>   /usr/share/razor/razor-panel/razor-panel_sr@latin.qm
Well, it's a bug in %find_lang that it doesn't find those files. Just list them manually, they're just 2 files:
%lang(sr) %{_datadir}/razor/razor-config/razor-config-appearance_sr@latin.qm
%lang(sr) %{_datadir}/razor/razor-panel/razor-panel_sr@latin.qm
(Use %lang(sr) to tag them.)

> I'd like to choose something one - "section > subpackage" or "package >
> section" order. In 2nd case I'm to put package > %description > %files
> (together). I prefere _strict_ "section > subpackage" order, sorry.

Almost all packages in Fedora use the ordering as in:
http://pkgs.fedoraproject.org/cgit/qt.git/tree/qt.spec

In other words:
Definition of the main package
%description
%package foo1
%description foo1
%package foo2
%description foo2
…
%package fooN
%description fooN
%prep
%build
%install
%check (if used)
%clean (if used)
%pre/%post/%preun/%postun/%posttrans (for the main package) as needed
%pre/%post/%preun/%postun/%posttrans foo1 as needed
%pre/%post/%preun/%postun/%posttrans foo2 as needed
…
%pre/%post/%preun/%postun/%posttrans fooN as needed
%files
%files foo1
%files foo2
…
%files fooN
%changelog

I see no valid reason to do this differently. It's much easier to read other people's specfiles if they all use the agreed ordering.

Comment 58 Eugene A. Pivnev 2013-05-05 14:12:13 UTC
(In reply to comment #57)
Ok - will fix both things befor commiting to bodhi.
Thank you.

Comment 59 Eugene A. Pivnev 2013-05-05 14:18:34 UTC
New Package SCM Request
=======================
Package Name: razorqt
Short Description: Lightweight desktop toolbox
Owners: tieugene
Branches: f17 f18 f19 el6
InitialCC:

Comment 60 Gwyn Ciesla 2013-05-06 12:28:21 UTC
Git done (by process-git-requests).

Comment 61 Eugene A. Pivnev 2013-05-06 13:45:29 UTC
(In reply to comment #57)
> Well, it's a bug in %find_lang that it doesn't find those files. Just list
> them manually, they're just 2 files:
> %lang(sr) %{_datadir}/razor/razor-config/razor-config-appearance_sr@latin.qm
> %lang(sr) %{_datadir}/razor/razor-panel/razor-panel_sr@latin.qm
> (Use %lang(sr) to tag them.)

Fedora uses "%lang (sr@latin) ..."

Comment 62 Kevin Kofler 2013-05-06 15:02:53 UTC
I don't think this is being used consistently, but %lang(sr@latin) is probably more correct, so you can use it.

Comment 63 Fedora Update System 2013-05-06 16:38:20 UTC
razorqt-0.5.2-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/razorqt-0.5.2-8.fc17

Comment 64 Fedora Update System 2013-05-06 16:39:34 UTC
razorqt-0.5.2-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/razorqt-0.5.2-8.fc18

Comment 65 Fedora Update System 2013-05-06 16:40:31 UTC
razorqt-0.5.2-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/razorqt-0.5.2-8.fc19

Comment 66 Fedora Update System 2013-05-07 18:27:58 UTC
razorqt-0.5.2-8.fc18 has been pushed to the Fedora 18 testing repository.

Comment 67 Fedora Update System 2013-05-14 04:37:33 UTC
razorqt-0.5.2-8.fc19 has been pushed to the Fedora 19 stable repository.

Comment 68 Fedora Update System 2013-05-15 14:36:25 UTC
razorqt-0.5.2-9.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/razorqt-0.5.2-9.el6

Comment 69 Fedora Update System 2013-05-16 02:50:50 UTC
razorqt-0.5.2-8.fc17 has been pushed to the Fedora 17 stable repository.

Comment 70 Fedora Update System 2013-05-16 03:03:44 UTC
razorqt-0.5.2-8.fc18 has been pushed to the Fedora 18 stable repository.

Comment 71 Fedora Update System 2013-05-31 17:54:17 UTC
razorqt-0.5.2-9.el6 has been pushed to the Fedora EPEL 6 stable repository.

Comment 72 Eugene A. Pivnev 2014-06-13 13:27:32 UTC
Package Change Request
======================
Package Name: razorqt
New Branches: epel7
Owners: tieugene

Comment 73 Kevin Fenzi 2014-06-18 16:07:23 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.