Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 950553 - Boot rhev-h failed in uefi mode machine.
Summary: Boot rhev-h failed in uefi mode machine.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1150377
Blocks: 951688 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-04-10 12:10 UTC by haiyang,dong
Modified: 2016-02-10 20:09 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously .cfg was used as the grub configuration file suffix instead of .conf. Calls to copy a non-existent .conf file into a compatible EFI boot directory caused the hypervisor to be unbootable. Now the correct .conf suffix is used, so an installed hypervisor can be successfully booted in EFI mode.
Clone Of:
Environment:
Last Closed: 2015-02-11 20:44:09 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
attached Screenshot for grub setup page (deleted)
2013-04-10 12:10 UTC, haiyang,dong
no flags Details
attached Screenshot (deleted)
2013-10-09 08:13 UTC, haiyang,dong
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 18343 None None None Never

Description haiyang,dong 2013-04-10 12:10:25 UTC
Created attachment 733658 [details]
attached Screenshot for grub setup page

Description of problem:
Insert the installation media(CD-ROM/USB) in uefi mode machine, and start the system, When the automatic boot prompt appears, press Enter.
then selected boot option "Reinstall RHEV Hypervisor-6.4-20130409.0.el6_4",
After install rhev-h in uefi mode machine success, then boot it from uefi mode,but it failed to boot rhev-h and will enter into grub setup page.
(Seen grub setup page.png) 

Version-Release number of selected component (if applicable):
rhevh-6.4-20130409.0.el6_4

How reproducible:
100% 
 
Steps to Reproduce:
1.Insert the installation media(CD-ROM/USB) in uefi mode, and start the system.
2.Start the system. When the automatic boot prompt appears, press Enter.
3.selected boot option "Reinstall RHEV Hypervisor-6.4-20130409.0.el6_4".

Actual result:
After install rhev-h in uefi mode machine success, then boot it from uefi mode,but it failed to boot rhev-h and will enter into grub setup page.

Expect result:
After install rhev-h in uefi mode machine success, then boot it from uefi mode should be successfully.

Additional info:

No this issue on build rhev-hypervisor6-6.4-20130318.1.el6_4, so it's a regression bug

Comment 1 Fabian Deutsch 2013-04-10 14:35:36 UTC
parted revealed that the second (ext2) partition has the boot flag set, and not the first (fat16) partition.

Comment 3 Fabian Deutsch 2013-04-10 16:09:11 UTC
Okay, it was an incorrect grub config file suffix (cfg instead of conf).

Tested as follows:
1. Install test build and reboot
2. Machine boots from HD

Comment 8 wanghui 2013-07-26 10:13:41 UTC
Test version:
RHEV Hypervisor 6.5-20130725.0.el6
ovirt-node-3.0.0-6.1.el6.noarch

Test steps:
1.Insert the installation media(CD-ROM/USB) in uefi mode, and start the system.
2.Start the system. When the automatic boot prompt appears, press Enter.
3.Selected boot option "Install or Upgrade RHEV Hypervisor-6.5-20130725.0.el6".
4.After finished installation,boot from UEFI mode.
5.Renter to UEFI mode and select "Reinstall RHEV Hypervisor-6.5-20130725.0.el6"
6.After finished installation, boot form UEFI mode.

Test results:
After finished installation/reinstallation, it can not boot from UEFI mode.

So it is not fixed in RHEV Hypervisor 6.5-20130725.0.el6. Change the status from ON_QA to ASSIGNED.

Comment 9 Fabian Deutsch 2013-08-09 09:04:22 UTC
Hui,

I tried to reproduce this bug in a EFI enabled VM, but couldn't reproduce it using your steps in comment 8.
Have you got a screenshot of the error you face?

Comment 10 Fabian Deutsch 2013-08-20 10:10:27 UTC
I was now able to reproduce this on a Dell machine.

Observations:
1. Installation
   - goes fine
   - EFI boot entry is added 0000
2. Reinstallation
   - VG is removed
   - EFI boot entry 0000 (from 1.) remains
   - Second EFI boot entry is added, 0004
3. Reboot
   - Old EFI boot entry 0000 is listed as unavailable, but selected to boot
   - New EFI boot entry 0004 is also listed, but not set as boot device

Comment 11 Fabian Deutsch 2013-09-16 15:32:41 UTC
The fix landed in upstream 3.0

Comment 12 Fabian Deutsch 2013-09-16 16:00:26 UTC
Could you please verify this bug with rhev-hypervisor6-6.5-20130912.0.iso?

Comment 15 wanghui 2013-09-17 09:31:41 UTC
Test version:
rhev-hypervisor6-6.5-20130916.0.el6ev.iso
ovirt-node-3.0.1-1.el6.noarch

Test steps:
1.Insert the installation media(CD-ROM/USB) in uefi mode, and start the system.
2.Start the system. When the automatic boot prompt appears, press Enter.
3.Selected boot option "Install or Upgrade RHEV Hypervisor-6.5-20130725.0.el6".
4.After finished installation,boot from UEFI mode.


Test results:
Because there has a bug#1008759, it blocks the testing. The host can't boot up.

So it hasn't fixed in build rhev-hypervisor6-6.5-20130916.0.el6ev.iso

Comment 16 Fabian Deutsch 2013-09-19 10:30:26 UTC
Not all EFI fixes landed in upstream 3.0.1:

9a436357e188f4209cb145ccbad9f95543e08638
[efi-fixes bd3ff17] installer: Fix EFI boot entry removal
 3 files changed, 142 insertions(+), 24 deletions(-)

be189b35c16f3dbbf295f2164bc4e4d4d3f3552b
[efi-fixes 9769dd7] remove existing efi entries when uninstall rhev-h in efi boot
 Author: hadong <hadong0720@gmail.com>
 1 file changed, 5 insertions(+)

a3f6f8fb9f9d98c33b9bac23482be1fa10b28141
[efi-fixes 3a3774d] Fix EFI boot entry shown "fedora" issue
 Author: hadong <hadong0720@gmail.com>
 1 file changed, 11 insertions(+), 5 deletions(-)

We need to backport them.

Comment 20 haiyang,dong 2013-10-09 08:13:34 UTC
Created attachment 809745 [details]
attached Screenshot

Test version:
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso        
ovirt-node-3.0.1-3.el6.noarch

Test steps:
1.Insert the installation media(CD-ROM/USB) in uefi mode, and start the system.
2.Start the system. When the automatic boot prompt appears, press Enter.
3.selected boot option "Reinstall RHEV Hypervisor-6.5-20130930.0.auto665.el6".

Test results:
After finished einstallation, it can not boot from UEFI mode. it will enter into grub setup console.

Comment 22 haiyang,dong 2013-10-18 09:22:45 UTC
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6

Test steps:
1.Insert the installation media(CD-ROM/USB) in uefi mode, and start the system.
2.Start the system. When the automatic boot prompt appears, press Enter.
3.selected boot option "Reinstall RHEV Hypervisor-6.5-20131017.0.el6".

Test results:
After finished installation, boot from UEFI mode successs. so this bug has been fixed.

Hey Fabian,

Please change the status of this bug from "POST" to "ON_QA", so i could verify this bug.

Comment 23 haiyang,dong 2013-10-18 09:31:57 UTC
According to comment 22, change this status from "ON_QA" to "VERIFIED"

Comment 27 Ying Cui 2014-07-29 08:34:22 UTC
Change this bug to ON_QA, as its flag is rhev 3.5, we need to test and verify this bug on rhevh 7.0 + ovirt-node 3.1 build.

Comment 28 haiyang,dong 2014-11-11 11:49:45 UTC
Test version:
rhev-hypervisor6-6.6-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch

Test steps:
1.Insert the installation media(CD-ROM/USB) in uefi mode, and start the system.
2.Start the system. When the automatic boot prompt appears, press Enter.
3.selected boot option "Reinstall RHEV Hypervisor-6.6-20141107.0.iso".

Test results:
After finished installation, boot from UEFI mode successs. so this bug has been fixed in rhevh 6.6 for RHEV 3.5 bulid version, change the status into "VERIFIED"

Comment 30 errata-xmlrpc 2015-02-11 20:44:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.