Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 950076 - ovirt-engine-restapi : Missing description for quota name in RSDL
Summary: ovirt-engine-restapi : Missing description for quota name in RSDL
Keywords:
Status: CLOSED DUPLICATE of bug 893927
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Doron Fediuck
QA Contact: Ondra Machacek
URL:
Whiteboard: sla
Depends On: 893927
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-04-09 15:06 UTC by Oded Ramraz
Modified: 2016-02-10 20:14 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-08 16:16:07 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)

Description Oded Ramraz 2013-04-09 15:06:24 UTC
Description of problem:


When trying to add Quota from CLI , auto complete does not suggest name parameter although it is mandatory ( see Additional Parameter ) 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

add quota --datacenter-identifier

[RHEVM shell (connected)]# add quota --datacenter-identifier 5febe649-9fc2-4f76-8d2b-01fa3b88baac

error: 
status: 400
reason: Bad Request
detail: Quota [name] required for add


## When adding name parameter I get another error ( will file separate busy for this issue )

[RHEVM shell (connected)]# add quota --datacenter-identifier 5febe649-9fc2-4f76-8d2b-01fa3b88baac --name quotatest

error: 
status: 500
reason: Internal Server Error
detail: JBWEB000065: HTTP Status 500 - java.lang.NullPointerException

Comment 1 Doron Fediuck 2013-07-21 10:58:54 UTC
Quota has no implemented API, and in 3.3 you will not be able to use "add quota".
This will be handled in the next version as a part of bug 893927.

Comment 2 Doron Fediuck 2014-01-12 16:02:52 UTC
Suggesting for to be included in 3.5.

Comment 3 Juan Hernández 2014-05-07 12:13:42 UTC
Currently the RESTAPI has limited support for quota. There are quota resources, like /datacenter/{datacenter:id}/quotas, but they are read only.

This has probably changed since this bug was reported, but today the quota isn't presented as an alternative in autocompletion for the "add" command, and if typed manually it generates a reasonable error message:

  [RHEVM shell (connected)]# add quota --datacenter-identifier 00000002-0002-0002-0002-000000000117

  ==================================== ERROR =================================
                              no such action "add"
  ============================================================================

Same if the --name parameter is added:

  [RHEVM shell (connected)]# add quota --datacenter-identifier 00000002-0002-0002-0002-000000000117 --name myquota

  ==================================== ERROR =================================
                              no such action "add"
  ============================================================================

Once the quota support is implemented in the RESTAPI and the SDK is regenerated these commands will work correctly, without any change to the CLI.

I suggest to close this bug as fixed in the current version, or as a duplicate of bug 893927.

Comment 4 Doron Fediuck 2014-05-08 16:16:07 UTC
Closing as duplicate, based on comment 3.

*** This bug has been marked as a duplicate of bug 893927 ***


Note You need to log in before you can comment on or make changes to this bug.