Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 950 - Symbolic links are sometimes stored in RPMs with wrongs mode
Summary: Symbolic links are sometimes stored in RPMs with wrongs mode
Keywords:
Status: CLOSED DUPLICATE of bug 528
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 5.2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-24 21:46 UTC by Ziv, Alon
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-02-16 22:17:30 UTC


Attachments (Terms of Use)

Description Ziv, Alon 1999-01-24 21:46:03 UTC
In some packages of the Apollo release, there are symbolic
links which RPM thinks should have mode lrwxr-xr-x (despite
the fact that *every* symlink *always* has mode lrwxrwxrwx).
See e.g. `/usr/bin/X11' in package `filesystem'.

Fix:
In build/files.c:add_file(), don't reset the file's mode if
it is a symlink (i.e., if S_ISLNK(p->statbuf)).  Also, in
lib/verify.c:rpmVerifyFile(), don't verify the file's mode
it it is a symlink.

Comment 1 Aleksey Nogin 1999-01-26 03:43:59 UTC
This is a duplicate of #528, #533 and #535

Comment 2 Jeff Johnson 1999-02-16 22:17:59 UTC
*** This bug has been marked as a duplicate of 528 ***


Note You need to log in before you can comment on or make changes to this bug.