Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 928275 - Post APT-update: Application or service 'BalloonService' could not be restarted
Summary: Post APT-update: Application or service 'BalloonService' could not be restarted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Windows Guest Tools
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
low
high
Target Milestone: ---
: 3.4.0
Assignee: Lev Veyde
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On:
Blocks: 1067416 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-03-27 09:54 UTC by Jiri Belka
Modified: 2014-09-18 12:24 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when upgrading from 3.1.9 via APT, an error message, "Application or service 'BalloonService' could not be restarted", appeared in the event log. Now, "BaloonService" can be restarted.
Clone Of:
: 1067416 (view as bug list)
Environment:
Last Closed: 2014-06-09 14:05:50 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
WGT install logs (deleted)
2013-03-27 09:54 UTC, Jiri Belka
no flags Details
events (deleted)
2014-03-10 15:32 UTC, Jiri Belka
no flags Details
install logs (deleted)
2014-03-10 15:33 UTC, Jiri Belka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0669 normal SHIPPED_LIVE rhev-guest-tools-iso bug fix and enhancement update 2014-06-09 18:02:51 UTC

Description Jiri Belka 2013-03-27 09:54:35 UTC
Created attachment 716973 [details]
WGT install logs

Description of problem:
When upgrading from 3.1.9 to 3.2.4 via APT (APT from 3.2.4 had to be updated manually as key for signatures changed), after APT installation does reboot there's following msg in eventlog (I'm suspicious this could be related to BZ880278, which disabled blnsvr service to start automatically):

Log Name:      Application
Source:        Microsoft-Windows-RestartManager
Date:          3/27/2013 10:34:33 AM
Event ID:      10007
Task Category: None
Level:         Error
Keywords:      
User:          SYSTEM
Computer:      jb-w7-x86
Description:
Application or service 'BalloonService' could not be restarted.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-RestartManager" Guid="{0888E5EF-9B98-4695-979D-E92CE4247224}" />
    <EventID>10007</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8000000000000000</Keywords>
    <TimeCreated SystemTime="2013-03-27T09:34:33.921875000Z" />
    <EventRecordID>1193</EventRecordID>
    <Correlation />
    <Execution ProcessID="1176" ThreadID="2296" />
    <Channel>Application</Channel>
    <Computer>jb-w7-x86</Computer>
    <Security UserID="S-1-5-18" />
  </System>
  <UserData>
    <RmApplicationEvent xmlns:auto-ns2="http://schemas.microsoft.com/win/2004/08/events" xmlns="http://www.microsoft.com/2005/08/Windows/Reliability/RestartMan
ager/">
      <RmSessionId>0</RmSessionId>
      <FullPath>C:\PROGRA~1\Redhat\RHEV\Drivers\balloon\blnsvr.exe</FullPath>
      <DisplayName>BalloonService</DisplayName>
      <AppVersion>0</AppVersion>
      <AppType>3</AppType>
      <TSSessionId>0</TSSessionId>
      <Status>262178</Status>
      <Pid>1396</Pid>
      <nFiles>0</nFiles>
      <Files>
        <File>
        </File>
      </Files>
    </RmApplicationEvent>
  </UserData>
</Event>

Version-Release number of selected component (if applicable):
3.1.9 -> 3.2.4
w7 32bit

How reproducible:
100%

Steps to Reproduce:
1. Have 3.1.9 WGT
2. Install APT from 3.2.4 (without this step APT cannot read new WGT iso)
3. Shutdown and start again with 3.2.4 WGT iso connected
  
Actual results:
Application or service 'BalloonService' could not be restarted

Expected results:
No error msg in eventlog

Additional info:

Comment 1 Jiri Belka 2013-07-31 12:49:11 UTC
Issue exists even when upgrading to latest 3.1 WGT - 3.1.14.

Comment 2 Lev Veyde 2013-08-14 08:00:07 UTC
(In reply to Jiri Belka from comment #1)
> Issue exists even when upgrading to latest 3.1 WGT - 3.1.14.

The 3.1 releases don't disable the Balloon service, like a 3.2 release.

Comment 12 Ronen Hod 2013-12-04 13:48:50 UTC
Vadim, Gal, Please read comment 9.

Comment 13 Vadim Rozenfeld 2013-12-05 07:40:55 UTC
two questions:
- which build number (driver version) we use?
- is it reproducible if we install the balloon service 
manually?

Thanks,
Vadim.

Comment 21 Jiri Belka 2014-03-10 15:32:30 UTC
Created attachment 872780 [details]
events

fail, 3.1.9 -> 3.4.1

Comment 22 Jiri Belka 2014-03-10 15:33:57 UTC
Created attachment 872781 [details]
install logs

Comment 23 Lev Veyde 2014-03-10 16:00:40 UTC
(In reply to Jiri Belka from comment #21)
> Created attachment 872780 [details]
> events
> 
> fail, 3.1.9 -> 3.4.1

The reason it fails is because during the upgrade the code executed is still from the old 3.1.9 package, and not the new one, which code was fixed.

The fix will appear only AFTER the first upgrade with the fixed version.

To test it fixed you can upgrade to 3.3-13 (which includes the backport of the fix) and then to the 3.4-1. On the first upgrade you are supposed to see the error, but not on the second one.

Comment 24 Jiri Belka 2014-03-11 16:04:05 UTC
ok, 3.1.9->3.3.13 + apt (issue exists) ->3.4.1 + apt works as mentioned in #23.

Comment 26 errata-xmlrpc 2014-06-09 14:05:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0669.html


Note You need to log in before you can comment on or make changes to this bug.