Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 92335 - htmlview can't open files with names which include spaces
Summary: htmlview can't open files with names which include spaces
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: htmlview
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-06-05 08:46 UTC by Moritz Barsnick
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 04:53:03 UTC


Attachments (Terms of Use)
patch to allow htmlview to handle file names with whitespace (deleted)
2004-11-01 14:37 UTC, Moritz Barsnick
no flags Details | Diff

Description Moritz Barsnick 2003-06-05 08:46:21 UTC
Description of problem:
htmlview fails to open files with names which have spaces or special chars. 
File names with spaces are passed as separated arguments.

Version-Release number of selected component (if applicable):
2.0.0-9

How reproducible:
always

Steps to Reproduce:
1. htmlview "/path/to/file name with spaces.html" (or any proper quoting)
2.
3.
    
Actual results:
File is not displayed, because the called viewer sees "htmlview /path/to/file"

Expected results:
File is displayed.

Additional info:
This is very obviously the classic $* vs. "$@". "$@" ist the correct way to 
pass "all arguments". There are three "exec" calls where this needs to be 
fixed. I can provide a patch, but I guess you won't need it.  ;-)  Just be sure 
to use "$@" _with_ the double quotes!

Comment 1 Moritz Barsnick 2004-11-01 14:37:21 UTC
Created attachment 106013 [details]
patch to allow htmlview to handle file names with whitespace

Still the same problem 17 months later in version 3.0.0-8. Here's a patch.

If you really don't want to allow multiple file names to be passed, try "$1".
OTOH "$*" will fail when getting multiple files and one of them contains spaces
(but I haven't checked whether the script passes this kind of arg to this
code).

Comment 2 Warren Togami 2004-11-06 22:17:37 UTC
warren@redhat.com is NOT my address.

Comment 3 Warren Togami 2005-04-25 04:53:03 UTC
Thanks.



Note You need to log in before you can comment on or make changes to this bug.