Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 923 - tzname[] vector returns wrong time zone name to sendmail and pine
Summary: tzname[] vector returns wrong time zone name to sendmail and pine
Keywords:
Status: CLOSED DUPLICATE of bug 2112
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-22 21:40 UTC by igorl+rh
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-15 22:25:39 UTC


Attachments (Terms of Use)

Description igorl+rh 1999-01-22 21:40:27 UTC
On a CST system (/etc/localtime -> ../usr/share/zoneinfo/US/
Central), the tzname[] vector returns "EST" instead of "CST."

This problem is visible wehn sendmail-8.9.2 taps the tzname[]
external for its Date: and Received: header lines. I have not
yet perused pine source code to see what it does, but the
behavior seems similar.

Within sendmail, the files conf.h and arpadate.c define and
reference "extern char *tzname[]." I have not yet found what
and how sets this array. Yet, the problem seems to be
withinthe LInuz setup rather than within sendmail.

Thanks, igor

Comment 1 igorl+rh 1999-01-23 20:03:59 UTC
Here's a little program (from Gregory Shapiro of Sendmail Inc.) that
demonstrates the problem:

#include <stdio.h>
#include <time.h>

main(int argc, char **argv)
{
	time_t t = time(NULL);
	struct tm *lt;
	extern char *tzname[];

	lt = localtime(&t);
	printf("TZ_TM_ZONE: %s\n", lt->tm_zone);
	printf("TZ_TZNAME: %s\n", tzname[lt->tm_isdst]);
	if (lt->tm_isdst > 0)
		printf("Fixed TZ_TZNAME: %s\n", tzname[1]);
	else if (lt->tm_isdst == 0)
		printf("Fixed TZ_TZNAME: %s\n", tzname[0]);
	else
		printf("Fixed TZ_TZNAME: Timezone not available\n");
}

Comment 2 Anonymous 1999-03-01 18:17:59 UTC
This problem also shows up in a RHL 5.2 CST/CDT machine using
qmail as the MTA and pine 4.04/4.05/4.10 as the MUA.

Could this be due to the glibc "enhancements?"

Comment 3 Jeff Johnson 1999-05-15 22:19:59 UTC
What version of glibc are you using? (try "rpm -q glibc")What version of glibc are you using? (try "rpm -q glibc")

Comment 4 Jeff Johnson 1999-05-15 22:25:59 UTC
*** This bug has been marked as a duplicate of 2112 ***


Note You need to log in before you can comment on or make changes to this bug.