Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 922520 - [event tab] better phrasing for actions done by unauthenticated users, currently appears as <UNKNOWN> [NEEDINFO]
Summary: [event tab] better phrasing for actions done by unauthenticated users, curren...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Douglas Schilling Landgraf
QA Contact: Oded Ramraz
URL:
Whiteboard: infra
: 921073 (view as bug list)
Depends On:
Blocks: rhev3.4beta 1123828 1142926
TreeView+ depends on / blocked
 
Reported: 2013-03-17 15:59 UTC by Tareq Alayan
Modified: 2016-02-10 19:15 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-20 13:39:55 UTC
oVirt Team: Infra
Target Upstream Version:
dyasny: needinfo? (yzaslavs)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 19627 None None None Never

Description Tareq Alayan 2013-03-17 15:59:33 UTC
Description of problem:
 <UNKOWN> is the string for unauthenticated users in the event tab. 
please consider to change to other term

Version-Release number of selected component (if applicable):
sf10

additional info:
this is a general issue on the infra process that logs events into the event tab.

Comment 1 Yair Zaslavsky 2013-03-17 17:23:59 UTC
*** Bug 921073 has been marked as a duplicate of this bug. ***

Comment 2 Yair Zaslavsky 2013-03-17 17:32:27 UTC
I suggested that <KNOWN> will be renamed to "unknown user to engine" or "non interactive user".


Dan, please advise.

Comment 3 Dan Yasny 2013-03-18 05:54:31 UTC
what kind of actions are such users allowed to take?

Comment 4 Yair Zaslavsky 2013-03-18 11:54:24 UTC
Dan - we encountered the issue during host registration.
However, this may occur at future cases as well.

Comment 5 Dan Yasny 2013-03-18 12:08:16 UTC
So we need to define a "system" user or something like that? Just trying to understand what actions are logged under <UNKNOWN>.

Can this be something done by an actual user, or are these actions performed by internal processes that belong to no real user?


//This is why reproduction steps are always needed in every BZ!

Comment 6 Yair Zaslavsky 2013-03-18 12:33:48 UTC
Dan, there are at least two sources in our flows for such events -
a. schedulers that initiate commands - I guess for this "system" can be fine
b. internal queries that initiate commands - register servlet uses an internal queryto avoid the need to login.

Comment 7 Dan Yasny 2013-03-18 14:29:30 UTC
Hmm, ok, I am looking at the event log, and I don't see too many events that even mention a user. Can we simply log things that got started without user intervention, and that aren't related to a user session, without a user mentioned at all?

Example (SPm failover):
Storage Pool Manager runs on Host paice (Address: paice.demo.lab.tlv.redhat.com).

No mention of any user starting the SPM on this host, so no need to mention a user at all

Does this make sense, or am I still missing something?

Comment 9 Sandro Bonazzola 2014-01-14 08:42:32 UTC
ovirt 3.4.0 alpha has been released

Comment 11 Shai Revivo 2014-02-20 13:39:55 UTC
This bug was fixed and is slated to be in the upcoming version. As we are focusing our testing at this phase on severe bugs, this bug was closed without going through its verification step. If you think this bug should be verified by QE, please set its severity to high and move it back to ON_QA


Note You need to log in before you can comment on or make changes to this bug.