Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 921073 - [events tab] RHEVH : Host X was added by <UNKNOWN> event message need to rephrase [TEXT]
Summary: [events tab] RHEVH : Host X was added by <UNKNOWN> event message need to rep...
Keywords:
Status: CLOSED DUPLICATE of bug 922520
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Yair Zaslavsky
QA Contact: Tareq Alayan
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-13 12:36 UTC by Tareq Alayan
Modified: 2016-02-10 19:38 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-17 17:23:59 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
engine.log (deleted)
2013-03-13 12:37 UTC, Tareq Alayan
no flags Details

Description Tareq Alayan 2013-03-13 12:36:27 UTC
Description of problem:
Host monique-vds04 was added by <UNKNOWN>.
actions should be done by process... 

Version-Release number of selected component (if applicable):
sf10

How reproducible:
always

Steps to Reproduce:
1. log in to the admin console in a rhevh
2. configure the management server
3. go to the web admin in the management server see event tab
  
Actual results:
Host monique-vds04 was added by <UNKNOWN>.

Expected results:
Host monique-vds04 was added by "admin".

Additional info:

Comment 1 Tareq Alayan 2013-03-13 12:37:03 UTC
Created attachment 709549 [details]
engine.log

Comment 2 Alon Bar-Lev 2013-03-17 15:01:41 UTC
Hello,

When registration happens, there is no interactive user.

Printing "admin" is misleading as admin user did not perform the mentioned operation.

<UNKOWN> is the string for unauthenticated users, although it may be changed to some other term, there is no bug in this subject.

If you do not agree, please reopen.
Alon

Comment 3 Oded Ramraz 2013-03-17 15:06:13 UTC
(In reply to comment #2)
> Hello,
> 
> When registration happens, there is no interactive user.
> 
> Printing "admin" is misleading as admin user did not perform the mentioned
> operation.
> 
> <UNKOWN> is the string for unauthenticated users, although it may be changed
> to some other term, there is no bug in this subject.
> 
> If you do not agree, please reopen.
> Alon

<UNKNOWN> in capital letters is not acceptable inside an event message , please find more appropriate term / translation for unauthenticated users and replace it in the event message.

Comment 4 Yair Zaslavsky 2013-03-17 15:29:47 UTC
Oded - too bad the bug title was renamed -you turned it into a general infrastructure bug.
I am not sure that we can have a unified solution for all flows.
For example - 
For the specific user the original bug was meant to - we could have detected that AddVdsCommand originated from registration and provide a different audit log type.

Comment 5 Yair Zaslavsky 2013-03-17 15:32:10 UTC
Oded, I suggest renaming back, and follow the comment I provided at comment #4
And open a new bug for the "general infra" issue - so we can track all the required changes.
What do you think?

Comment 6 Oded Ramraz 2013-03-17 15:35:08 UTC
Fine by me . let's keep this one for the specific use case and I'll open a new bug about the general infra issue . 

(In reply to comment #5)
> Oded, I suggest renaming back, and follow the comment I provided at comment
> #4
> And open a new bug for the "general infra" issue - so we can track all the
> required changes.
> What do you think?

Comment 7 Yair Zaslavsky 2013-03-17 15:36:45 UTC
My bad, it was alon suggesting the bug change.
Ok, let's do that.
I agree with the comments you and Alon provided.

Comment 8 Tareq Alayan 2013-03-17 15:37:06 UTC
Alon, 

The way to add a rhevh to a running engine is done via ssh admin@<RHEVH_IP>.
admin user inserts the ip of the management server, and then it shows in the engine hosts tab. 
So imho admin@<rhevh-ip> won't be misleading at all.

Comment 9 Alon Bar-Lev 2013-03-17 15:42:36 UTC
Yair,
This is infrastructure issue for changing the term of non-interactive user name. I don't see how it relates to the registration process and not other background processes we may have.
Just change the constant to anything people accepts.
Alon

Tareq,
Please be more specific, is it host registration or host deployment? What exactly are you doing? At comment#0 you explicitly wrote that you are doing host registration which leads to non-interactive interaction with engine.
Alon

Comment 10 Yair Zaslavsky 2013-03-17 15:58:56 UTC
Alon,
After reviewing all messages at AuditLogMessages.properties - I guess that replacing $UserName with "non interactive user" can suffice in case there is no user.
However, we still need to agree about this specific case.
As I see it from engine point of view - user is a user that is either admin@interla or user that was added from a directory service, and not rhev-h user.
I would change the add host in case of registration message not to include a user.

An event like - 
Host ${VdsName} was registered to the system.

Comment 11 Oded Ramraz 2013-03-17 16:04:38 UTC
bug https://bugzilla.redhat.com/show_bug.cgi?id=922520 was opened regarding the general issue .

Comment 12 Alon Bar-Lev 2013-03-17 16:06:17 UTC
(In reply to comment #11)
> bug https://bugzilla.redhat.com/show_bug.cgi?id=922520 was opened regarding
> the general issue .

Please do not specify full URL in bugzilla, should be bug#922520 or bug 922520.

Comment 13 Yair Zaslavsky 2013-03-17 16:42:08 UTC
To be more informative -
I prefer a solution in which we have a new event indicating the host was registered to the system.
I agree with Alon that specifying the user admin@<rhevh-ip> does not provide too much info (this is not a user of rhev-m).

For the general user <UNKNOWN> issues (and future flows we may encounter) the bz mentioned at comment #11 was opened.

Comment 14 Alon Bar-Lev 2013-03-17 17:03:44 UTC
(In reply to comment #13)
> To be more informative -
> I prefer a solution in which we have a new event indicating the host was
> registered to the system.
> I agree with Alon that specifying the user admin@<rhevh-ip> does not provide
> too much info (this is not a user of rhev-m).

We have:
VDS_REGISTER_SUCCEEDED=Host ${VdsName1} registered.

So what exactly is missing here?

Comment 15 Yair Zaslavsky 2013-03-17 17:23:59 UTC
Alon, you're correct.
I think that in this case having also the event of adding the vds is redundant. But currently we do not have a way to skip that.
Sorry for all the mess. I think the best way to handle this indeed to use the "non interactive" user as you suggested.
I will close this bug as duplicate on the new opened bug.

The audit log will contain the following events:
1. show an event for successful registration
2. show event that host was added by non interactive user (or any other mean as suggested at Bug922520 ).
3. After approval - we will have event with approving user.

*** This bug has been marked as a duplicate of bug 922520 ***


Note You need to log in before you can comment on or make changes to this bug.