Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 920126 - [RFE] Support RHEVM ON RHEL7
Summary: [RFE] Support RHEVM ON RHEL7
Keywords:
Status: CLOSED DUPLICATE of bug 1195123
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup
Version: unspecified
Hardware: Unspecified
OS: Linux
medium
low
Target Milestone: ---
: 3.6.0
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
: 1146569 (view as bug list)
Depends On: 1125811
Blocks: 1181729
TreeView+ depends on / blocked
 
Reported: 2013-03-11 11:58 UTC by Ohad Basan
Modified: 2015-04-18 01:49 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-31 11:35:37 UTC
oVirt Team: ---
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)

Description Ohad Basan 2013-03-11 11:58:06 UTC
Description of problem:
yum install rhevm yum transaction fails when running on rhel7 due to dependency problem

--> Finished Dependency Resolution
Error: Package: rhevm-iso-uploader-3.2.0-1.el6ev.noarch (rhevm)
           Requires: python(abi) = 2.6
           Installed: python-2.7.3-13.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: otopi-1.0.0-1.el6ev.noarch (rhevm)
           Requires: python(abi) = 2.6
           Installed: python-2.7.3-13.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: rhevm-cli-3.2.0.5-1.el6ev.noarch (rhevm)
           Requires: python(abi) = 2.6
           Installed: python-2.7.3-13.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: rhevm-log-collector-3.2.0-1.el6ev.noarch (rhevm)
           Requires: python(abi) = 2.6
           Installed: python-2.7.3-13.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: rhevm-image-uploader-3.2.0-1.el6ev.noarch (rhevm)
           Requires: python(abi) = 2.6
           Installed: python-2.7.3-13.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: rhevm-setup-3.2.0-10.14.beta1.el6ev.noarch (rhevm)
           Requires: python-cheetah
Error: Package: ovirt-host-deploy-1.0.0-2.el6ev.noarch (rhevm)
           Requires: python(abi) = 2.6
           Installed: python-2.7.3-13.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-ply-3.3-7.el6ev.noarch (rhevm)
           Requires: python(abi) = 2.6
           Installed: python-2.7.3-13.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: rhevm-notification-service-3.2.0-10.14.beta1.el6ev.noarch (rhevm)
           Requires: classpathx-mail
Error: Package: rhevm-3.2.0-10.14.beta1.el6ev.noarch (rhevm)
           Requires: python-cheetah
Error: Package: rhevm-sdk-3.2.0.5-1.el6ev.noarch (rhevm)
           Requires: python(abi) = 2.6
           Installed: python-2.7.3-13.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7

Comment 1 Itamar Heim 2013-03-16 21:09:26 UTC
i wonder if >=2.6 would cut it...
lets get this worked around / custom built to find the next set of issues...

Comment 3 Itamar Heim 2013-11-30 19:20:18 UTC
still relevant?

Comment 4 Ohad Basan 2013-12-01 06:59:36 UTC
I'll retest that.
we're planning on setting a rhel7 env soon also

Comment 5 Ohad Basan 2013-12-15 14:08:59 UTC
still relevant.
yes
tested with rhel7 beta

Comment 7 Sandro Bonazzola 2013-12-16 08:49:24 UTC
You should just need to rebuild the packages on RHEL7.
Python .pyc and .pyo need to be recompiled by python-2.7 interpreter and installed in the python2.7 directory.
Python dependency is automatically added to the rpm by rpmbuild if you've redhat-rpm-config package installed on the build system.

You'll need different repositories for rhel 6.z and 7.z.

Comment 9 Sandro Bonazzola 2014-09-25 14:19:13 UTC
*** Bug 1146569 has been marked as a duplicate of this bug. ***

Comment 13 Doron Fediuck 2014-10-28 13:00:57 UTC
Is this still relevant?

Comment 15 Doron Fediuck 2014-11-09 09:00:00 UTC
Eyal,
please re-assign as needed to see if still relevant.

Comment 16 Eyal Edri 2014-11-13 08:16:43 UTC
sandro - i assume this is for 3.5 hypervisor support?
do we need an RFE for it or can we just close this bug?

Comment 17 Sandro Bonazzola 2014-11-13 08:45:59 UTC
Eyal, looking at comment #0, seems like Ohad tried to install rhevm on EL7.
We can either move this to hypervisor support and close or move this to maybe 4.0.

Comment 20 Sandro Bonazzola 2015-03-31 11:35:37 UTC

*** This bug has been marked as a duplicate of bug 1195123 ***


Note You need to log in before you can comment on or make changes to this bug.