Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 92 - bug in SB AWE32 boot-time configuration
Summary: bug in SB AWE32 boot-time configuration
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: awesfx
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 790 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-16 16:42 UTC by Bill Nottingham
Modified: 2014-03-17 02:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-16 21:23:31 UTC


Attachments (Terms of Use)

Description Bill Nottingham 1998-11-16 16:42:42 UTC
Hi modular sound
folks...

here is a small bug in the RedHat 5.2 configuration
of
the awe_wave module for SoundBlaster AWE 32, using  the
awesfx package for
a
post-install:

/etc/conf.modules gets a
line
post-install awe_wave /usr/bin/sfxload
/etc/midi/GU11-ROM.SF2

but, in /etc/rc.d/rc.sysinit  , the awe_wave module is
loaded BEFORE
the /usr partition is mounted !  (so the post-install
fails)

solution #1: repackage the awesfx-0.4.2  rpm to install
sfxload into /bin
instead of /usr/bin  (simplest fix), and put out an update
on the errata page,

or

solution #2:  modify /etc/rc.d/rc.sysinit to delay loading
the sound modules
until after the local filesystems (other than /) are
mounted.


(workaround: cp -p /usr/bin/sfxload /bin/sfxload
)


Cheers!
Duncan
Haldane

Comment 1 Bill Nottingham 1998-11-16 16:43:59 UTC
Will be fixed in next awesfx/sndconfig release, in the
meantime, you can get them from ftp.redhat.com/pub/sound.

Comment 2 Bill Nottingham 1999-01-12 16:22:59 UTC
*** Bug 92 has been marked as a duplicate of this bug. ***

The soundmodule for SB AWE has a post-install script defined
in /etc/conf.modules The called file is localet in /usr/bin,
but /usr/bin is not available at this time if the /usr
Filesystem lives on a diferent partition.
Solution:
load sound module after mounting all filesystems


Note You need to log in before you can comment on or make changes to this bug.