Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 91629 - vim is a cpu hog
Summary: vim is a cpu hog
Keywords:
Status: CLOSED DUPLICATE of bug 83700
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-26 12:44 UTC by Ted Kaczmarek
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:53:14 UTC


Attachments (Terms of Use)

Description Ted Kaczmarek 2003-05-26 12:44:24 UTC
Description of problem:Vim uses too much cpu


Version-Release number of selected component (if applicable):
vim-common-6.1-29
vim-X11-6.1-29
vim-enhanced-6.1-29
vim-minimal-6.1-29

How reproducible: General use, nothing specific


Steps to Reproduce:
1.Edit some files with vi
2.General workstation use
3. Edit a file with vi
    
Actual results: Cpu load for vi hits 99%


Expected results: Would not think an editor needs so much cpu


Additional info: I have been seeing this problem on and off for the past few
versions of Redhat. I notice the problem from Bubbling Load Monitor 2.0.1 or any
other system monitor in gnome. Doing a top confirms vim is the pig. It may be
related to vim not closing gracefully if I had to guess, but I'll leave that to
the experts :-). I say this becuase I have exited vim and one is sticking
around, killall vim usually does not kill it, but sometimes it does. Doing a
kill -9 works every time.

Comment 1 Karsten Hopp 2003-05-30 12:57:53 UTC

*** This bug has been marked as a duplicate of 83700 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:53:14 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.