Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 91594 - sre.py:137:search:TypeError
Summary: sre.py:137:search:TypeError
Keywords:
Status: CLOSED DUPLICATE of bug 88147
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-25 10:17 UTC by Juha
Modified: 2007-04-18 16:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:53:14 UTC


Attachments (Terms of Use)
Data save into file from dialog (deleted)
2003-05-25 10:19 UTC, Juha
no flags Details
Screenshot of Redhat-config-network crash (deleted)
2003-05-25 10:20 UTC, Juha
no flags Details

Description Juha 2003-05-25 10:17:19 UTC
Description of problem: 
at start of redhat-config-network an "unhandled exception" occures. 
 
Version-Release number of selected component (if applicable): 
1.2.0 
 
How reproducible: 
 
System Settings -> Network 
or 
in Terminal: /usr/sbin/redhat-config-network 
 
Steps to Reproduce: 
1. 
2. 
3. 
     
Actual results: 
 
Component: redhat-config-network 
Version: 1.2.0 
Summary: TB /usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py:137:search:TypeError: 
expected string or buffer 
Traceback (most recent call last): 
  File "/usr/sbin/redhat-config-network-gui", line 154, in ? 
    window = mainDialog() 
  File 
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", 
line 154, in __init__ 
  File 
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", 
line 225, in load 
  File 
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", 
line 232, in loadDevices 
  File 
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py", 
line 210, in getDeviceList 
  File 
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py", 
line 117, in load 
  File 
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/plugins/NCDevWireless.py", 
line 34, in load 
  File 
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCWireless.py", 
line 52, in load 
  File "/usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py", line 137, in search 
    return _compile(pattern, flags).search(string) 
TypeError: expected string or buffer 
  
Local variables in innermost frame: 
pattern: ^s: 
flags: 0 
string: None 
 
Expected results: 
 
 
Additional info:

Comment 1 Juha 2003-05-25 10:19:38 UTC
Created attachment 91951 [details]
Data save into file from dialog

Comment 2 Juha 2003-05-25 10:20:59 UTC
Created attachment 91952 [details]
Screenshot of Redhat-config-network crash

Comment 3 Juha 2003-05-26 06:16:26 UTC
Found an update to redhat-config-network, but was not on up2date. 
This bug seems to be fixed with redhat-config-network-1.2.7. 
 
 

Comment 4 Harald Hoyer 2003-05-26 11:20:45 UTC

*** This bug has been marked as a duplicate of 88147 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:53:14 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.