Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 915920 (qt5-qtsvg) - Review Request: qt5-qtsvg - Qt5 - QtSvg component
Summary: Review Request: qt5-qtsvg - Qt5 - QtSvg component
Keywords:
Status: CLOSED ERRATA
Alias: qt5-qtsvg
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: qt5-qtbase, qt5-qtbase-review
Blocks: kde-reviews qt-reviews sigil-07
TreeView+ depends on / blocked
 
Reported: 2013-02-26 18:49 UTC by Rex Dieter
Modified: 2013-09-27 18:42 UTC (History)
4 users (show)

Fixed In Version: qt5-qtsvg-5.1.1-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-15 02:48:13 UTC
i: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Rex Dieter 2013-02-26 18:49:20 UTC
Spec URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtsvg.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtsvg-5.0.1-1.fc18.src.rpm
Description: Qt5 - QtSvg component
Fedora Account System Username: rdieter

Comment 2 Christopher Meng 2013-07-27 09:35:32 UTC
I need this package, I will take it.

First question, can we rename it to qtsvg5? Why qt5 packages are named with qt5 prefix?

Or just keep things then add virtual provides?

And, 5.1.0 is out, please update the spec and srpm.

Thanks!

Comment 3 Christopher Meng 2013-07-29 23:59:43 UTC
ping?

Comment 4 Rex Dieter 2013-07-30 15:39:06 UTC
See qt5-qtbase review on some discussion about the use of the qt5- prefix.

I suppose we can consider adding a 5 postfix virtual provide, if you think that needed.

Comment 5 Christopher Meng 2013-07-31 06:21:09 UTC
OK.

Then could you please provide the latest version of SPEC/SPRM?

Comment 6 Rex Dieter 2013-07-31 08:40:24 UTC
comment #1 is the latest I have.

Comment 7 Christopher Meng 2013-07-31 09:38:36 UTC
The latest version is 5.1.0, can you update it? Or just wait until main package is 5.1.0?

Thanks.

Comment 8 Rex Dieter 2013-07-31 14:57:14 UTC
we will update in due course, sure, but for now, rawhide currently includes only 5.0.2

Comment 9 Christopher Meng 2013-08-01 02:53:44 UTC
Only these 3 warnings:

qt5-qtsvg.i686: W: unused-direct-shlib-dependency /usr/lib/libQt5Svg.so.5.0.2 /lib/libpthread.so.0
qt5-qtsvg.i686: W: unused-direct-shlib-dependency /usr/lib/libQt5Svg.so.5.0.2 /lib/libGL.so.1
qt5-qtsvg.i686: W: unused-direct-shlib-dependency /usr/lib/libQt5Svg.so.5.0.2 /lib/libgcc_s.so.1

Package is good.

Comment 10 Christopher Meng 2013-08-03 02:14:52 UTC
Sorry, forgot to approve.

Comment 11 Rex Dieter 2013-08-03 02:25:23 UTC
Thanks!

New Package SCM Request
=======================
Package Name: qt5-qtsvg
Short Description: Qt5 - QtSvg Component
Owners: than rdieter jreznik kkofler ltinkl rnovacek
Branches: f18 f19
InitialCC:

Comment 12 Gwyn Ciesla 2013-08-05 12:13:43 UTC
Git done (by process-git-requests).

Comment 13 Fedora Update System 2013-08-05 13:52:18 UTC
qt5-qtsvg-5.0.2-1.fc19,qt5-qtwebkit-5.0.2-7.fc19,qt5-qtdeclarative-5.0.2-3.fc19,qt5-qtjsbackend-5.0.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qt5-qtsvg-5.0.2-1.fc19,qt5-qtwebkit-5.0.2-7.fc19,qt5-qtdeclarative-5.0.2-3.fc19,qt5-qtjsbackend-5.0.2-2.fc19

Comment 14 Fedora Update System 2013-08-05 13:53:22 UTC
qt5-qtsvg-5.0.2-1.fc18,qt5-qtwebkit-5.0.2-7.fc18,qt5-qtdeclarative-5.0.2-3.fc18,qt5-qtjsbackend-5.0.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qt5-qtsvg-5.0.2-1.fc18,qt5-qtwebkit-5.0.2-7.fc18,qt5-qtdeclarative-5.0.2-3.fc18,qt5-qtjsbackend-5.0.2-2.fc18

Comment 15 Fedora Update System 2013-08-06 00:23:33 UTC
Package qt5-qtsvg-5.0.2-1.fc19, qt5-qtwebkit-5.0.2-7.fc19, qt5-qtdeclarative-5.0.2-3.fc19, qt5-qtjsbackend-5.0.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt5-qtsvg-5.0.2-1.fc19 qt5-qtwebkit-5.0.2-7.fc19 qt5-qtdeclarative-5.0.2-3.fc19 qt5-qtjsbackend-5.0.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14290/qt5-qtsvg-5.0.2-1.fc19,qt5-qtwebkit-5.0.2-7.fc19,qt5-qtdeclarative-5.0.2-3.fc19,qt5-qtjsbackend-5.0.2-2.fc19
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2013-08-15 02:48:13 UTC
qt5-qtsvg-5.0.2-1.fc19, qt5-qtwebkit-5.0.2-7.fc19, qt5-qtdeclarative-5.0.2-3.fc19, qt5-qtjsbackend-5.0.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2013-08-15 03:02:11 UTC
qt5-qtsvg-5.0.2-1.fc18, qt5-qtwebkit-5.0.2-7.fc18, qt5-qtdeclarative-5.0.2-3.fc18, qt5-qtjsbackend-5.0.2-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Rex Dieter 2013-09-10 20:39:25 UTC
Package Change Request
======================
Package Name: qt5-qtsvg
New Branches: el6
Owners: rdieter
InitialCC: 

Co-maintainers welcome!

Comment 19 Gwyn Ciesla 2013-09-11 12:06:21 UTC
Git done (by process-git-requests).

Comment 20 Fedora Update System 2013-09-11 17:28:30 UTC
qt5-qtsvg-5.1.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/qt5-qtsvg-5.1.1-1.el6

Comment 21 Fedora Update System 2013-09-27 18:42:42 UTC
qt5-qtsvg-5.1.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.


Note You need to log in before you can comment on or make changes to this bug.