Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 915006 (qt5-qtwebkit) - Review Request: qt5-qtwebkit - Qt5 - QtWebKit components
Summary: Review Request: qt5-qtwebkit - Qt5 - QtWebKit components
Keywords:
Status: CLOSED ERRATA
Alias: qt5-qtwebkit
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gregor Tätzner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: qt5-qtbase, qt5-qtbase-review qt5-qtdeclarative angleproject
Blocks: kde-reviews qt-reviews sigil-07 qt5-qtquick1
TreeView+ depends on / blocked
 
Reported: 2013-02-24 01:02 UTC by Rex Dieter
Modified: 2013-09-11 04:33 UTC (History)
7 users (show)

Fixed In Version: qt5-qtsvg-5.0.2-1.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-15 02:47:42 UTC
gregor: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)
compact licensecheck (deleted)
2013-04-19 07:05 UTC, Gregor Tätzner
no flags Details
pre-review (deleted)
2013-06-12 09:09 UTC, Gregor Tätzner
no flags Details

Description Rex Dieter 2013-02-24 01:02:30 UTC
Spec URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtwebkit.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtwebkit-5.0.1-1.fc18.src.rpm
Description: Qt5 - QtWebKit components
Fedora Account System Username: rdieter

Comment 1 Gregor Tätzner 2013-02-26 13:06:23 UTC
Missing BuildReq: mesa-libGL-devel

Please check:
qt5-qtwebkit-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/qtwebkit-opensource-src-5.0.1/Source/WTF/wtf/MediaTime.h
qt5-qtwebkit-debuginfo.x86_64: W: hidden-file-or-dir /usr/src/debug/qtwebkit-opensource-src-5.0.1/Source/WTF/.moc
qt5-qtwebkit-debuginfo.x86_64: W: hidden-file-or-dir /usr/src/debug/qtwebkit-opensource-src-5.0.1/Source/WTF/.moc

SHOULD:
This doesn't look very nice. Something we can do about it?
qt5-qtwebkit.x86_64: W: shared-lib-calls-exit /usr/lib64/libQt5WebKit.so.5.0.1 exit@GLIBC_2.2.5
qt5-qtwebkit.x86_64: W: shared-lib-calls-exit /usr/lib64/libQt5WebKit.so.5.0.1 _exit@GLIBC_2.2.5

Comment 2 Rex Dieter 2013-02-26 14:44:51 UTC
1. Missing BuildReq: mesa-libGL-devel
as mentioned in the qttools review, I'll be adding this as a dep to qt5-qtbase-devel soon

Comment 3 Rex Dieter 2013-02-26 17:08:22 UTC
Spec URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtwebkit.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtwebkit-5.0.1-2.fc18.src.rpm

%changelog
* Mon Feb 25 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.1-2
- .prl love
- BR: pkgconfig(gl)

Comment 4 Ismael Olea 2013-04-10 20:31:22 UTC
As with qt5-qttools I'm getting an «Project ERROR: Module does not define version.» error when building (using mock here).

Just reporting.

Comment 6 Gregor Tätzner 2013-04-12 06:53:15 UTC
doesn't build on rawhide. I get a build log of 65 mb containing messages like this: generated/InspectorTypeBuilder.h:3180:25: warning: typedef 'dummycannot_cast' locally defined but not used [-Wunused-local-typedefs]
             COMPILE_ASSERT(sizeof(Error) == sizeof(InspectorObject), cannot_cast);


There is also this configure warning: Encountered 1 configuration warning(s):
 ! QtQuick module not found, QML APIs will not be built

I suppose we don't want to waive on any of them.

Comment 7 Gregor Tätzner 2013-04-12 06:54:46 UTC
oh wait, I think my build run out of space. Need to try later again...

Comment 8 Gregor Tätzner 2013-04-12 15:58:19 UTC
(In reply to comment #6)
> There is also this configure warning: Encountered 1 configuration warning(s):
>  ! QtQuick module not found, QML APIs will not be built

Oh yes, adding qtdeclarative to buildreq did the trick, though I'm getting unpackaged file errors now ;)

DEBUG: error: Installed (but unpackaged) file(s) found:
DEBUG:    /usr/lib64/qt5/qml/QtWebKit/experimental/libqmlwebkitexperimentalplugin.so
DEBUG:    /usr/lib64/qt5/qml/QtWebKit/experimental/qmldir
DEBUG:    /usr/lib64/qt5/qml/QtWebKit/libqmlwebkitplugin.so
DEBUG:    /usr/lib64/qt5/qml/QtWebKit/qmldir
DEBUG:     Installed (but unpackaged) file(s) found:
DEBUG:    /usr/lib64/qt5/qml/QtWebKit/experimental/libqmlwebkitexperimentalplugin.so
DEBUG:    /usr/lib64/qt5/qml/QtWebKit/experimental/qmldir
DEBUG:    /usr/lib64/qt5/qml/QtWebKit/libqmlwebkitplugin.so
DEBUG:    /usr/lib64/qt5/qml/QtWebKit/qmldir

Comment 9 Rex Dieter 2013-04-12 16:18:23 UTC
Good catch, I'll add the optional builddep and feature in the next pkg iteration.

In the meantime, I'd prefer if we could focus on review blockers... ;)

Comment 10 Rex Dieter 2013-04-12 19:05:28 UTC
Spec URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtwebkit.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtwebkit-5.0.2-2.fc18.src.rpm

%changelog
* Fri Apr 12 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-2
- BR: qt5-qtdeclarative-devel


Can no longer do a scratch build, due to qt5-qtdeclarative not being available yet.

Comment 11 Gregor Tätzner 2013-04-19 07:05:23 UTC
Created attachment 737531 [details]
compact licensecheck

issues:

- this project contains multiple licenses (see check), also include the license files, if available, in doc

- many subdirectories below Source/ contain licenses and changelogs, I'm sure they could be of interest

also there is some heavy bundling taking place:

Source/ThirdParty bundles - surprise - quite a lot of third party libs that are actively used during build.

- ANGLE: fedora pkg 'mingw64-angleproject'
- glu: has been adjusted by webkit team, probably copylib
- gtest: we don't run tests, so....
- gyp: fedora pkg 'node-gyp'
- jquery/qunit: probably can ignore this too

This needs to be investigated.

Comment 12 Rex Dieter 2013-05-14 18:19:52 UTC
Of those, it would appear that only ThirdParty/ANGLE is actively used during the build.

Taking a closer look now.

Comment 13 Rex Dieter 2013-05-14 18:25:43 UTC
As far as licensing is concerned, upstream intentions here is clear:
http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html

Comment 14 Rex Dieter 2013-05-14 18:43:09 UTC
and, pretty sure we don't need angle.  per
https://code.google.com/p/angleproject/
The goal of ANGLE is to allow Windows users to seamlessly run WebGL and other OpenGL ES 2.0 content by translating OpenGL ES 2.0 API calls to DirectX 9 API calls.

Looks like we're left with just
Source/Thirdparty/mt19937ar.c

and per
http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/emt.html

is fairly clear to be a copylib.  I'll poke fpc about it.

Comment 15 Rex Dieter 2013-05-14 18:59:58 UTC
mt19937ar.c copylib request:
https://fedorahosted.org/fpc/ticket/291

Comment 16 Rex Dieter 2013-05-14 19:05:51 UTC
And, grr, ANGLE actually is used, reading further down on it's project page, makes it clearer why:

Portions of the ANGLE shader compiler are used as a shader validator and translator by WebGL implementations across multiple platforms. It is used on Mac OS X, Linux, and in mobile variants of the browsers. Having one shader validator helps to ensure that a consistent set of GLSL ES shaders are accepted across browsers and platforms. The shader translator can be used to translate shaders to other shading languages, and to optionally apply shader modifications to work around bugs or quirks in the native graphics drivers. The translator targets Desktop GLSL, Direct3D HLSL, and even ESSL for native GLES2 platforms.

Comment 17 Rex Dieter 2013-05-15 17:54:43 UTC
OK, after banging against angle a bit, I found bug #858084 (mingw-qt5-qtwebkit review), and looks like unbundling angle may not be possible.

Spec URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtwebkit.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtwebkit-5.0.2-4.src.rpm

%changelog
* Wed May 15 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-4
- BR: perl(version) perl(Digest::MD5) pkgconfig(xslt)
- deal with bundled code
- add (commented) upstream link http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
  to clarify licensing

* Thu May 09 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-3
- -devel: Requires: qt5-qtdeclarative-devel

Comment 18 Gregor Tätzner 2013-05-16 06:52:40 UTC
(In reply to comment #17)
> OK, after banging against angle a bit, I found bug #858084
> (mingw-qt5-qtwebkit review), and looks like unbundling angle may not be
> possible.

ah I see, can you open a fpc ticket for angle too?

Comment 19 Rex Dieter 2013-05-18 14:04:54 UTC
as far as mt19937ar.c, turns out that code isn't used on linux either, but oh well.

angle bundling exception submitted,
https://fedorahosted.org/fpc/ticket/293

Comment 20 Panos Polychronis 2013-05-22 21:20:01 UTC
 rpmbuild --rebuild  qt5-qtwebkit-5.0.2-4.src.rpm  output:
error: Failed build dependencies:
        perl(version) is needed by qt5-qtwebkit-5.0.2-4.fc19.x86_64


while .... : 
perl --version

This is perl 5, version 16, subversion 3 (v5.16.3) built for x86_64-linux-thread-multi

Comment 21 Kevin Kofler 2013-05-22 23:24:30 UTC
perl(version) is provided by perl-version, not perl.

Comment 22 Rex Dieter 2013-05-25 21:34:10 UTC
Spec URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtwebkit.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtwebkit-5.0.2-5.src.rpm

%changelog
* Fri May 17 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-5
- unbundle angleproject code

Comment 23 Rex Dieter 2013-06-12 01:42:09 UTC
ping?  it's been almost 2 weeks since my last update, you still interested in completing this review?

Comment 24 Gregor Tätzner 2013-06-12 09:09:37 UTC
Created attachment 760028 [details]
pre-review

sorry for the late response. lets try to finish this

whats left:
- some (internal?) libs are defining rpaths
- unspecific license tag: actually most of the code is LGPL and BSD; I've also spotted some apache, MIT, ISC and MPL files (see licensecheck). Since this is basically a copy of webkit I also don't think the qt license terms do really apply here ("# See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html")
- include ChangeLog and VERSION (there is no license file, is it?)

thanks for your effort

Comment 25 Rex Dieter 2013-06-21 13:45:43 UTC
Re: licensing

$ licensecheck -r * | cut -d' ' -f2 | sort | uniq -c

      7 Apache
   9097 BSD
      3 BSL
     22 GENERATED
      6 GPL
      1 ISC
   2946 LGPL
      6 MIT/X11
     30 MPL
    451 *No
      1 Public
    492 UNKNOWN
      3 zlib/libpng

Of these, zlib is only used in configure tests, and only MPL is GPL incompatible (but ok, since all the MPL licensed files are also dual licensed GPL/LGPL).

There are a small handful of Qt-standard licensed files.  So... when all is said and done, the combined aggregate license still comes back to what we started with.

Working on the other items now...

Comment 26 Rex Dieter 2013-06-21 14:38:34 UTC
Spec URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtwebkit.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/qt5/qt5-qtwebkit-5.0.2-6.src.rpm

%changelog
* Fri Jun 21 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-6
- %%doc ChangeLog VERSION
- %%doc Source/WebCore/LICENSE*
- squash more rpaths

Comment 27 Gregor Tätzner 2013-06-22 10:57:13 UTC
okay, go ahead

APPROVED

Rpmlint
-------
Checking: qt5-qtwebkit-5.0.2-6.fc20.x86_64.rpm
          qt5-qtwebkit-devel-5.0.2-6.fc20.x86_64.rpm
qt5-qtwebkit.x86_64: W: shared-lib-calls-exit /usr/lib64/libQt5WebKit.so.5.0.2 exit@GLIBC_2.2.5
qt5-qtwebkit.x86_64: W: shared-lib-calls-exit /usr/lib64/libQt5WebKit.so.5.0.2 _exit@GLIBC_2.2.5
qt5-qtwebkit-devel.x86_64: W: no-documentation
2 packages and 0 specfiles checked; 0 errors, 3 warnings.

Comment 28 Rex Dieter 2013-06-24 11:38:52 UTC
New Package SCM Request
=======================
Package Name: qt5-qtwebkit
Short Description: Qt5 - QtWebKit components
Owners: than rdieter jreznik kkofler ltinkl rnovacek
Branches: f17 f18 f19
InitialCC:

Comment 29 Gwyn Ciesla 2013-06-24 12:21:24 UTC
Git done (by process-git-requests).

Comment 30 Rex Dieter 2013-08-02 15:19:04 UTC
fyi, still waiting on angleproject dep to build this, bug #967234

Comment 31 Fedora Update System 2013-08-05 13:51:58 UTC
qt5-qtsvg-5.0.2-1.fc19,qt5-qtwebkit-5.0.2-7.fc19,qt5-qtdeclarative-5.0.2-3.fc19,qt5-qtjsbackend-5.0.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qt5-qtsvg-5.0.2-1.fc19,qt5-qtwebkit-5.0.2-7.fc19,qt5-qtdeclarative-5.0.2-3.fc19,qt5-qtjsbackend-5.0.2-2.fc19

Comment 32 Fedora Update System 2013-08-05 13:52:57 UTC
qt5-qtsvg-5.0.2-1.fc18,qt5-qtwebkit-5.0.2-7.fc18,qt5-qtdeclarative-5.0.2-3.fc18,qt5-qtjsbackend-5.0.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qt5-qtsvg-5.0.2-1.fc18,qt5-qtwebkit-5.0.2-7.fc18,qt5-qtdeclarative-5.0.2-3.fc18,qt5-qtjsbackend-5.0.2-2.fc18

Comment 33 Fedora Update System 2013-08-06 00:23:17 UTC
Package qt5-qtsvg-5.0.2-1.fc19, qt5-qtwebkit-5.0.2-7.fc19, qt5-qtdeclarative-5.0.2-3.fc19, qt5-qtjsbackend-5.0.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt5-qtsvg-5.0.2-1.fc19 qt5-qtwebkit-5.0.2-7.fc19 qt5-qtdeclarative-5.0.2-3.fc19 qt5-qtjsbackend-5.0.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14290/qt5-qtsvg-5.0.2-1.fc19,qt5-qtwebkit-5.0.2-7.fc19,qt5-qtdeclarative-5.0.2-3.fc19,qt5-qtjsbackend-5.0.2-2.fc19
then log in and leave karma (feedback).

Comment 34 Fedora Update System 2013-08-15 02:47:42 UTC
qt5-qtsvg-5.0.2-1.fc19, qt5-qtwebkit-5.0.2-7.fc19, qt5-qtdeclarative-5.0.2-3.fc19, qt5-qtjsbackend-5.0.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 35 Fedora Update System 2013-08-15 03:01:58 UTC
qt5-qtsvg-5.0.2-1.fc18, qt5-qtwebkit-5.0.2-7.fc18, qt5-qtdeclarative-5.0.2-3.fc18, qt5-qtjsbackend-5.0.2-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 36 Rex Dieter 2013-09-10 17:02:55 UTC
Package Change Request
======================
Package Name: qt5-qtwebkit
New Branches: el6
Owners: hobbes1069 rdieter
InitialCC: 

Co-maintainers welcome!

Comment 37 Gwyn Ciesla 2013-09-10 17:55:58 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.