Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 911154 - User Portal will launch SPICE VM that is already open from Power User Portal.
Summary: User Portal will launch SPICE VM that is already open from Power User Portal.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal
Version: 3.1.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Frantisek Kobzik
QA Contact: movciari
URL:
Whiteboard: virt
: 919171 (view as bug list)
Depends On:
Blocks: 919171 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-02-14 13:55 UTC by Bill Sanford
Modified: 2014-09-18 12:24 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-12 16:10:39 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Bill Sanford 2013-02-14 13:55:54 UTC
Description of problem:
With one VM launched from the Power User Portal, you can launch the same VM from the User Portal.

Version-Release number of selected component (if applicable):

On RHEV-M 3.1:
spice-vdagent-0.8.1-3.el6.x86_64
rhevm-userportal-3.1.0-32.el6ev.noarch
rhevm-webadmin-portal-3.1.0-32.el6ev.noarch
rhevm-tools-common-3.1.0-32.el6ev.noarch
rhevm-spice-client-x64-cab-3.1-8.el6.noarch
rhev-guest-tools-iso-3.1-9.noarch
rhevm-spice-client-x86-cab-3.1-8.el6.noarch

On RHEL 5.9:
spice-client-0.8.1-6.el5_8.2
spice-xpi-2.4-4.el5

How reproducible:


Steps to Reproduce:
1. Launch VM from Power User Portal (Extended Tab).
2. From User Portal, launch same VM (Basic Tab)
3.
  
Actual results:
You can launch the identical VM from the User Portal that you did from Power User Portal.

Expected results:
The User Portal shouldn't launch a VM that is already open with a SPICE client.

Additional info:

Comment 1 Michal Skrivanek 2013-02-22 12:50:41 UTC
trouble is with MIME launched spice we'd have no way how to figure out if spice is still/already opened or not. So in 3.3 we would anyway have to give up on this behavior at least for non-plugin launched consoles
Another option is to connect this with SSO and logged in user reporting. A bit more complicated solution

How much of an issue is it?

Comment 2 Bill Sanford 2013-02-22 13:23:09 UTC
You could possibly disable USB access, disable sending CTRL-ALT-DEL to VM and open up in full-screen when you want windowed mode or just the opposite. If you have a VM open, the values in the console that you re-open with the User Portal could be all opposite. 

Why, when I open a VM from the User Portal, can't I open the same way from the Power User Portal? Why is this now an issue, when in 3.1, it seemed to work?

You shouldn't be asking me how much of an issue it is. That is for PM to decide.

Comment 3 Andrew Cathrow 2013-03-04 13:10:46 UTC
Handling this properly (eg. two different client machines) will require work from spice as well.
Pushing out to scope further

Comment 4 Michal Skrivanek 2013-03-11 10:00:00 UTC
*** Bug 919171 has been marked as a duplicate of this bug. ***

Comment 5 Michal Skrivanek 2013-07-09 12:50:40 UTC
per scrub mtg push to 3.4

Comment 6 Itamar Heim 2013-12-08 07:44:14 UTC
still planned for 3.4?

Comment 7 Michal Skrivanek 2013-12-08 15:55:30 UTC
I would think that we are not going to pursue the exclusive lock on console anymore with the .vv execution this is complicated and I doubt there is any benefit. Unless PM plans the SPICE changes for this...

Comment 8 Bill Sanford 2013-12-12 16:10:39 UTC
From what I have seen with 3.3, you can download the .vv file, you can launch the .vv file (If you have vv or a similar program to launch), or use the browser plugin. I think this bug is now not relevant due to the choices to open the VM.


Note You need to log in before you can comment on or make changes to this bug.