Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 911048 - Review Request: nodejs-q-io - Interfaces for IO using Q promises in JavaScript on Node.js
Summary: Review Request: nodejs-q-io - Interfaces for IO using Q promises in JavaScrip...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcelo Barbosa "firemanxbr"
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 910139 911025 911038 911047 911058
Blocks: nodejs-reviews 911040
TreeView+ depends on / blocked
 
Reported: 2013-02-14 09:47 UTC by Jamie Nguyen
Modified: 2013-07-21 18:39 UTC (History)
3 users (show)

Fixed In Version: nodejs-q-io-1.9.1-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-02 18:39:10 UTC
marcelo.barbosa: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Jamie Nguyen 2013-02-14 09:47:35 UTC
Spec URL: <http://jamielinux.fedorapeople.org/buddycloud-server/nodejs-q-io.spec
SRPM URL: http://jamielinux.fedorapeople.org/buddycloud-server/SRPMS/nodejs-q-io-1.5.2-1.fc18.src.rpm
Fedora Account System Username: jamielinux

Description:
Interfaces for IO using Q promises in JavaScript on Node.js.

Comment 1 Jamie Nguyen 2013-05-26 10:21:43 UTC
Spec URL: http://jamielinux.fedorapeople.org/buddycloud-server/nodejs-q-io.spec
SRPM URL: http://jamielinux.fedorapeople.org/buddycloud-server/SRPMS/nodejs-q-io-1.6.6-1.fc18.src.rpm

* Sun May 26 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 1.6.6-1
- update to upstream release 0.6.6

Comment 2 Jamie Nguyen 2013-06-20 19:07:31 UTC
Spec URL: http://jamielinux.fedorapeople.org/buddycloud-server/nodejs-q-io.spec
SRPM URL: http://jamielinux.fedorapeople.org/buddycloud-server/SRPMS/nodejs-q-io-1.7.3-1.fc19.src.rpm

* Thu Jun 20 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 1.7.3-1
- update to upstream release 1.7.3

Comment 3 Marcelo Barbosa "firemanxbr" 2013-06-20 19:27:22 UTC
Hi Jamie,

   I'm reviewing your package, please see this issues:

Issues:
=======
- Package installs properly.
  Note: Installation errors (see attachment)
  See: https://fedoraproject.org/wiki/Packaging:Guidelines

Thank you.

Marcelo Barbosa

Comment 4 Jamie Nguyen 2013-06-20 19:29:39 UTC
Hi Marcelo, thanks for picking this up! You'll want to review the two bugs that this package depends on first though, which is why the package can't install properly.

Comment 5 Marcelo Barbosa "firemanxbr" 2013-06-20 19:42:49 UTC
Jamie,

  Okay, i'm looking others tickets, i go catch other bugzillas, we go adjust all packages.

Thank you. 

Marcelo Barbosa

Comment 6 Marcelo Barbosa "firemanxbr" 2013-06-27 03:17:20 UTC
Jamie,

   Please see this is issues:

1) No latest version:

   Please see if your package this in the latest version, looking in main page:

      https://github.com/kriskowal/q-io

   It seemed that is in version 1.9.1 and its spec file this in 1.7.3

2) - Package installs properly.
  Note: Installation errors (see attachment)
  See: https://fedoraproject.org/wiki/Packaging:Guidelines

 Installation errors
-------------------
INFO: mock.py version 1.1.32 starting...
Start: init plugins
INFO: selinux disabled
Finish: init plugins
Start: run
Mock Version: 1.1.32
INFO: Mock Version: 1.1.32
Start: lock buildroot
INFO: installing package(s): /home/marcelo.barbosa/rpmbuild/SOURCES/reviews/911048-nodejs-q-io/results/nodejs-q-io-1.7.3-1.fc18.noarch.rpm
ERROR: Command failed:
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/fedora-18-x86_64/root/', 'install', '/home/marcelo.barbosa/rpmbuild/SOURCES/reviews/911048-nodejs-q-io/results/nodejs-q-io-1.7.3-1.fc18.noarch.rpm']
Error: Package: nodejs-q-io-1.7.3-1.fc18.noarch (/nodejs-q-io-1.7.3-1.fc18.noarch)
           Requires: npm(collections) < 0.2
Error: Package: nodejs-q-io-1.7.3-1.fc18.noarch (/nodejs-q-io-1.7.3-1.fc18.noarch)
           Requires: npm(mimeparse) < 0.2
Error: Package: nodejs-q-io-1.7.3-1.fc18.noarch (/nodejs-q-io-1.7.3-1.fc18.noarch)
           Requires: npm(q) >= 0.9.1
Error: Package: nodejs-q-io-1.7.3-1.fc18.noarch (/nodejs-q-io-1.7.3-1.fc18.noarch)
           Requires: npm(collections) >= 0.1.3
Error: Package: nodejs-q-io-1.7.3-1.fc18.noarch (/nodejs-q-io-1.7.3-1.fc18.noarch)
           Requires: npm(url2) >= 0.0.0
Error: Package: nodejs-q-io-1.7.3-1.fc18.noarch (/nodejs-q-io-1.7.3-1.fc18.noarch)
           Requires: npm(url2) < 0.1
 You could try using --skip-broken to work around the problem
Error: Package: nodejs-q-io-1.7.3-1.fc18.noarch (/nodejs-q-io-1.7.3-1.fc18.noarch)
           Requires: npm(q) < 0.10
Error: Package: nodejs-q-io-1.7.3-1.fc18.noarch (/nodejs-q-io-1.7.3-1.fc18.noarch)
           Requires: npm(mimeparse) >= 0.1.4
 You could try running: rpm -Va --nofiles --nodigest



Thank you

Marcelo Barbosa

Comment 7 Jamie Nguyen 2013-06-27 06:56:47 UTC
Can you build on rawhide as these packages have only just been submitted for stable tree. (In fact, all reviews should generally be done for rawhide. You can use "-m fedora-rawhide-x86_64" flag when running fedora-review.)


Spec URL: http://jamielinux.fedorapeople.org/buddycloud-server/nodejs-q-io.spec
SRPM URL: http://jamielinux.fedorapeople.org/buddycloud-server/SRPMS/nodejs-q-io-1.9.1-1.fc19.src.rpm

%changelog
* Thu Jun 27 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 1.9.1-1
- update to upstream release 1.9.1

Comment 8 Marcelo Barbosa "firemanxbr" 2013-07-01 04:08:39 UTC
- Outputs for rpmlint are false positives.

Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[-]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package complies to the Packaging Guidelines
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. No licenses
     found. Please check the source files for licenses manually.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[-]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 40960 bytes in 3 files.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Fully versioned dependency in subpackages, if present.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).

===== SHOULD items =====

Generic:
[x]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: nodejs-q-io-1.9.1-1.fc20.noarch.rpm
nodejs-q-io.noarch: W: spelling-error Summary(en_US) js -> dis, ks, j
nodejs-q-io.noarch: W: spelling-error %description -l en_US js -> dis, ks, j
nodejs-q-io.noarch: W: only-non-binary-in-usr-lib
nodejs-q-io.noarch: W: dangling-symlink /usr/lib/node_modules/q-io/node_modules/q /usr/lib/node_modules/q
nodejs-q-io.noarch: W: dangling-symlink /usr/lib/node_modules/q-io/node_modules/mime /usr/lib/node_modules/mime
nodejs-q-io.noarch: W: dangling-symlink /usr/lib/node_modules/q-io/node_modules/collections /usr/lib/node_modules/collections
nodejs-q-io.noarch: W: dangling-symlink /usr/lib/node_modules/q-io/node_modules/mimeparse /usr/lib/node_modules/mimeparse
nodejs-q-io.noarch: W: dangling-symlink /usr/lib/node_modules/q-io/node_modules/url2 /usr/lib/node_modules/url2
nodejs-q-io.noarch: W: dangling-symlink /usr/lib/node_modules/q-io/node_modules/qs /usr/lib/node_modules/qs
1 packages and 0 specfiles checked; 0 errors, 9 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint nodejs-q-io
nodejs-q-io.noarch: W: spelling-error Summary(en_US) js -> dis, ks, j
nodejs-q-io.noarch: W: spelling-error %description -l en_US js -> dis, ks, j
nodejs-q-io.noarch: W: only-non-binary-in-usr-lib
nodejs-q-io.noarch: W: dangling-symlink /usr/lib/node_modules/q-io/node_modules/q /usr/lib/node_modules/q
nodejs-q-io.noarch: W: dangling-symlink /usr/lib/node_modules/q-io/node_modules/mime /usr/lib/node_modules/mime
nodejs-q-io.noarch: W: dangling-symlink /usr/lib/node_modules/q-io/node_modules/collections /usr/lib/node_modules/collections
nodejs-q-io.noarch: W: dangling-symlink /usr/lib/node_modules/q-io/node_modules/mimeparse /usr/lib/node_modules/mimeparse
nodejs-q-io.noarch: W: dangling-symlink /usr/lib/node_modules/q-io/node_modules/url2 /usr/lib/node_modules/url2
nodejs-q-io.noarch: W: dangling-symlink /usr/lib/node_modules/q-io/node_modules/qs /usr/lib/node_modules/qs
1 packages and 0 specfiles checked; 0 errors, 9 warnings.
# echo 'rpmlint-done:'



Requires
--------
nodejs-q-io (rpmlib, GLIBC filtered):
    nodejs(engine)
    npm(collections)
    npm(mime)
    npm(mimeparse)
    npm(q)
    npm(qs)
    npm(url2)



Provides
--------
nodejs-q-io:
    nodejs-q-io
    npm(q-io)



Source checksums
----------------
http://registry.npmjs.org/q-io/-/q-io-1.9.1.tgz :
  CHECKSUM(SHA256) this package     : 3ae2641844998906dff9c3754a79a0e547368f20caacf5f53e1ecbec5a9602f5
  CHECKSUM(SHA256) upstream package : 3ae2641844998906dff9c3754a79a0e547368f20caacf5f53e1ecbec5a9602f5


Generated by fedora-review 0.4.1 (b2e211f) last change: 2013-04-29
Buildroot used: fedora-rawhide-x86_64
Command line :/usr/bin/fedora-review -b 911048 -m fedora-rawhide-x86_64

----------------

PACKAGE APPROVED

----------------


Follow the process from:
https://fedoraproject.org/wiki/Join_the_package_collection_maintainers#Add_Package_to_Source_Code_Management_.28SCM.29_system_and_Set_Owner


If you have any questions , feel free to contact me through my email or in the irc channel #fedora-devel, my nick is firemanxbr

Comment 9 Jamie Nguyen 2013-07-01 04:41:22 UTC
New Package SCM Request
=======================
Package Name: nodejs-q-io
Short Description: Interfaces for IO using Q promises in JavaScript on Node.js
Owners: jamielinux patches
Branches: f18 f19 el6
InitialCC:

Comment 10 Gwyn Ciesla 2013-07-01 12:18:22 UTC
Git done (by process-git-requests).

Comment 11 Fedora Update System 2013-07-02 17:11:36 UTC
nodejs-q-io-1.9.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nodejs-q-io-1.9.1-1.fc19

Comment 12 Fedora Update System 2013-07-02 17:12:06 UTC
nodejs-q-io-1.9.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nodejs-q-io-1.9.1-1.fc18

Comment 13 Fedora Update System 2013-07-02 17:14:04 UTC
nodejs-q-io-1.9.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nodejs-q-io-1.9.1-1.el6

Comment 14 Fedora Update System 2013-07-12 03:05:34 UTC
nodejs-q-io-1.9.1-1.fc18 has been pushed to the Fedora 18 stable repository.

Comment 15 Fedora Update System 2013-07-12 03:19:38 UTC
nodejs-q-io-1.9.1-1.fc19 has been pushed to the Fedora 19 stable repository.

Comment 16 Fedora Update System 2013-07-21 18:39:20 UTC
nodejs-q-io-1.9.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.


Note You need to log in before you can comment on or make changes to this bug.