Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 910791 - Review Request: uglify-js1 - JavaScript parser, mangler/compressor and beautifier toolkit
Summary: Review Request: uglify-js1 - JavaScript parser, mangler/compressor and beauti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jamie Nguyen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 894663 910159 911040 911050
TreeView+ depends on / blocked
 
Reported: 2013-02-13 15:14 UTC by T.C. Hollingsworth
Modified: 2013-04-05 23:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-19 14:19:30 UTC
jamielinux: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description T.C. Hollingsworth 2013-02-13 15:14:25 UTC
Spec URL: http://patches.fedorapeople.org/npm/uglify-js1.spec
SRPM URL:http://patches.fedorapeople.org/npm/uglify-js1-1.3.4-1.fc18.src.rpm
Fedora Account System Username: patches

JavaScript parser, mangler/compressor and beautifier toolkit.  This is the
classic 1.x version of uglify-js.  Consider using the new version provided
in the uglify-js package.

[This package is necessary because uglify-js 2.x is a complete rewrite and many node packages are not yet compatible with it.]

Comment 1 Jamie Nguyen 2013-02-13 23:01:51 UTC
Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. No licenses
     found. Please check the source files for licenses manually.
See: http://fedoraproject.org/wiki/Packaging/LicensingGuidelines#ValidLicenseShortNames


===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
     Note: Using prebuilt packages
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
     Note: Using prebuilt rpms.
[x]: Package contains no bundled libraries.
[!]: Changelog in prescribed format.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
     Note: %defattr present but not needed
[x]: Macros in Summary, %description expandable at SRPM build time.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Fully versioned dependency in subpackages, if present.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in %package
     common
[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. No licenses
     found. Please check the source files for licenses manually.
[!]: License file installed when any subpackage combination is installed.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[x]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[x]: Package is not relocatable.
[x]: Requires correct, justified where necessary.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[-]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 71680 bytes in 3 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[ ]: Buildroot is not present
     Note: Buildroot: present but not needed
[ ]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[ ]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[x]: Package functions as described.
[ ]: Latest version is packaged.
[ ]: Package does not include license text files separate from upstream.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: SourceX tarball generation or download is documented.
[!]: SourceX / PatchY prefixed with %{name}.
     Note: Source0 (uglify-js-1.3.4.tgz)
[x]: SourceX is a working URL.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[ ]: %check is present and all tests pass.
[ ]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.


Rpmlint
-------
Checking: uglify-js1-1.3.4-1.fc19.noarch.rpm
          uglify-js1-1.3.4-1.fc19.src.rpm
          uglify-js1-common-1.3.4-1.fc19.noarch.rpm
uglify-js1.noarch: W: spelling-error %description -l en_US js -> dis, ks, j
uglify-js1.noarch: W: incoherent-version-in-changelog 1.3.4 ['1.3.4-1.fc19', '1.3.4-1']
uglify-js1.noarch: W: only-non-binary-in-usr-lib
uglify-js1.noarch: W: no-documentation
uglify-js1.noarch: W: dangling-symlink /usr/lib/node_modules/uglify-js1/lib /usr/share/uglify-js1
uglify-js1.noarch: W: no-manual-page-for-binary uglifyjs1
uglify-js1.src: W: spelling-error %description -l en_US js -> dis, ks, j
uglify-js1.src: W: spelling-error %description -l en_US uglifyjs -> ugliness
uglify-js1-common.noarch: W: spelling-error %description -l en_US js -> dis, ks, j
uglify-js1-common.noarch: W: spelling-error %description -l en_US runtime -> run time, run-time, rudiment
3 packages and 0 specfiles checked; 0 errors, 10 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint uglify-js1-common uglify-js1
uglify-js1-common.noarch: W: spelling-error %description -l en_US js -> dis, ks, j
uglify-js1-common.noarch: W: spelling-error %description -l en_US runtime -> run time, run-time, rudiment
uglify-js1.noarch: W: spelling-error %description -l en_US js -> dis, ks, j
uglify-js1.noarch: W: incoherent-version-in-changelog 1.3.4 ['1.3.4-1.fc19', '1.3.4-1']
uglify-js1.noarch: W: only-non-binary-in-usr-lib
uglify-js1.noarch: W: no-documentation
uglify-js1.noarch: W: dangling-symlink /usr/lib/node_modules/uglify-js1/lib /usr/share/uglify-js1
uglify-js1.noarch: W: no-manual-page-for-binary uglifyjs1
2 packages and 0 specfiles checked; 0 errors, 8 warnings.
# echo 'rpmlint-done:'



Requires
--------
uglify-js1-1.3.4-1.fc19.noarch.rpm (rpmlib, GLIBC filtered):
    
    /usr/bin/env
    nodejs(engine)
    uglify-js1-common = 1.3.4-1.fc19

uglify-js1-common-1.3.4-1.fc19.noarch.rpm (rpmlib, GLIBC filtered):
    



Provides
--------
uglify-js1-1.3.4-1.fc19.noarch.rpm:
    
    npm(uglify-js) = 1.3.4
    uglify-js1 = 1.3.4-1.fc19

uglify-js1-common-1.3.4-1.fc19.noarch.rpm:
    
    uglify-js1-common = 1.3.4-1.fc19



MD5-sum check
-------------
http://registry.npmjs.org/uglify-js/-/uglify-js-1.3.4.tgz :
  CHECKSUM(SHA256) this package     : 60c484f7b872c19a3fbbdf160a5873fed6c8a38b908caebfdbdb0295cb7608cf
  CHECKSUM(SHA256) upstream package : 60c484f7b872c19a3fbbdf160a5873fed6c8a38b908caebfdbdb0295cb7608cf


Generated by fedora-review 0.3.1 (b71abc1) last change: 2012-10-16
Buildroot used: fedora-18-x86_64
Command line :/bin/fedora-review --rpm-spec -n uglify-js1-1.3.4-1.fc19.src.rpm -p

Comment 2 Jamie Nguyen 2013-02-13 23:02:18 UTC
Two things to do:
1) README.org contains the license text so also install in main package
2) First %changelog entry is missing a "-1" at the end of version


Otherwise package approved!

Comment 3 T.C. Hollingsworth 2013-02-13 23:14:03 UTC
Will fix #2.  As for #1, I thought that it was okay to leave it out as long as it depends on a package that contains the license file:
http://fedoraproject.org/wiki/Packaging:LicensingGuidelines#Subpackage_Licensing

Comment 4 T.C. Hollingsworth 2013-02-13 23:15:08 UTC
New Package SCM Request
=======================
Package Name: uglify-js1
Short Description: JavaScript parser, mangler/compressor, and beautifier toolkit
Owners: patches
Branches: f18 el6
InitialCC:

Comment 5 Jamie Nguyen 2013-02-14 06:46:32 UTC
> As for #1, I thought that it was okay to leave it out as long as
> it depends on a package that contains the license file

Ah, right you are :)

Comment 6 Gwyn Ciesla 2013-02-14 15:07:07 UTC
Git done (by process-git-requests).

Comment 7 Fedora Update System 2013-02-14 22:37:22 UTC
nodejs-amdefine-0.0.4-1.fc18, nodejs-buffer-equal-0.0.0-1.fc18, nodejs-charm-0.1.0-1.fc18, nodejs-deep-equal-0.0.0-2.fc18, nodejs-optimist-0.3.5-1.fc18, nodejs-source-map-0.1.8-3.fc18, nodejs-traverse-0.6.3-2.fc18, nodejs-wordwrap-0.0.2-2.fc18, nodejs-yamlish-0.0.5-1.fc18, nodejs-difflet-0.2.3-2.fc18, uglify-js1-1.3.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nodejs-amdefine-0.0.4-1.fc18,nodejs-buffer-equal-0.0.0-1.fc18,nodejs-charm-0.1.0-1.fc18,nodejs-deep-equal-0.0.0-2.fc18,nodejs-optimist-0.3.5-1.fc18,nodejs-source-map-0.1.8-3.fc18,nodejs-traverse-0.6.3-2.fc18,nodejs-wordwrap-0.0.2-2.fc18,nodejs-yamlish-0.0.5-1.fc18,nodejs-difflet-0.2.3-2.fc18,uglify-js1-1.3.4-1.fc18

Comment 8 Fedora Update System 2013-02-16 01:25:54 UTC
nodejs-amdefine-0.0.4-1.fc18, nodejs-buffer-equal-0.0.0-1.fc18, nodejs-charm-0.1.0-1.fc18, nodejs-deep-equal-0.0.0-2.fc18, nodejs-optimist-0.3.5-1.fc18, nodejs-source-map-0.1.8-3.fc18, nodejs-traverse-0.6.3-2.fc18, nodejs-wordwrap-0.0.2-2.fc18, nodejs-yamlish-0.0.5-1.fc18, nodejs-difflet-0.2.3-2.fc18, uglify-js1-1.3.4-1.fc18 has been pushed to the Fedora 18 testing repository.

Comment 9 Fedora Update System 2013-04-05 23:07:36 UTC
nodejs-amdefine-0.0.4-1.fc18, nodejs-buffer-equal-0.0.0-1.fc18, nodejs-charm-0.1.0-1.fc18, nodejs-deep-equal-0.0.0-2.fc18, nodejs-optimist-0.3.5-1.fc18, nodejs-source-map-0.1.8-3.fc18, nodejs-traverse-0.6.3-2.fc18, nodejs-wordwrap-0.0.2-2.fc18, nodejs-yamlish-0.0.5-1.fc18, nodejs-difflet-0.2.3-2.fc18, uglify-js1-1.3.4-1.fc18 has been pushed to the Fedora 18 stable repository.


Note You need to log in before you can comment on or make changes to this bug.