Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 90521 - apache does'nt serve documents from ncpfs volumes
Summary: apache does'nt serve documents from ncpfs volumes
Keywords:
Status: CLOSED DUPLICATE of bug 78224
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-09 08:32 UTC by Need Real Name
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:57 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-05-09 08:32:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
Apache httpd does'nt listing directories on mounted
ncpfs volumes from netware server and not serving any
files from ncpfs volumes

Version-Release number of selected component (if applicable):
httpd-2.0.40-21.1 ncpfs-2.2.1-1

How reproducible:
Always

Steps to Reproduce:
1. volume mounted from NW server by command :
   ncpmount -S NWSERV -U www -V usr:home/petrsi/www -f 770 -g 48 -
b /home/httpd/html/nwmount/
   
2. file i.htm in /home/httpd/html/nwmount/ contains html header
   and body with testing message

3. getting /nwmount/i.htm document from server
    

Actual Results:  httpd server give empty document, but in log file is record
about proper transfer - "GET /nwmount/i.htm HTTP/1.0" 200 380
with proper file size


Expected Results:  httpd server get content of the document i.htm


Additional info:

I make test with two volumes - ncpfs and ext2 , both mounted :
  TIX/WWW on /home/httpd/html/nwmount type ncpfs (rw)
  /dev/sdb1 on /home/httpd/html/e2mount type ext3 (rw)
and both accesible by user apache (uid/gid) 48 :
su - apache  then  cd /home/http/html ; ls -dla nwmount e2mount
  drwxr-xr-x    3 root     root         1024 May  9 09:56 e2mount
  drwxrwx---    1 root     apache        512 Dec 31  1985 nwmount
in both directories the same file i.htm and both accessible by
apache user by cat o more utilities 

  -bash-2.05b$ ls -la *mount/i.htm
  -rwxrwx---    1 root     apache        380 May  9 09:56 e2mount/i.htm
  -rwxrwx---    1 root     apache        380 May  7 12:12 nwmount/i.htm

  -bash-2.05b$ cat nwmount/i.htm | wc -c
      380

listing directories nwmount and e2mount is possible for apache user

Comment 1 Joe Orton 2003-05-12 13:22:45 UTC

*** This bug has been marked as a duplicate of 78224 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.