Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 900 - lsof broken with new Kernel (2.0.36) ?
Summary: lsof broken with new Kernel (2.0.36) ?
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lsof
Version: 5.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
: 1180 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-20 20:39 UTC by paolo.saggese
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-09 05:14:24 UTC


Attachments (Terms of Use)

Description paolo.saggese 1999-01-20 20:39:52 UTC
Program "lsof" does not work on my RH 5.2 boxes:

[root@pcsaggese /tmp]# lsof
lsof: WARNING: compiled for Linux release 2.0.34; this is
2.0.36.
lsof: kernel symbol address mismatch: get_options
      get_kernel_syms() value is 0x108d30; /boot/System.map
value is 0x108cf8.
      There were 335 additional mismatches.
      /boot/System.map and the booted kernel may not be a
matched set.
[root@pcsaggese /tmp]#

I have upgraded to kernel 2.0.36 using the official RedHat
updates rpms.

Comment 1 Jeff Johnson 1999-01-20 21:34:59 UTC
For now, try rebuilding from the lsof src.rpm, as in
	rpm --rebuild lsof-4.37-1.src.rpm
You might also try the 4.39 src rpm in Raw Hide.

Packaging for lsof that will work with any 2.0.x kernel cannot
be done. It may be possible with a 2.2.0 kernel ...

Comment 2 paolo.saggese 1999-01-21 20:01:59 UTC
I had already tried rebuilding lsof from the .src.rpm [both the one
for RHL5.2 and the one from "RawHide"]. Unfortunately, none worked.

...will wait 2.2.0

Comment 3 Jeff Johnson 1999-02-16 17:45:59 UTC
*** Bug 1180 has been marked as a duplicate of this bug. ***

lsof needs to be recompiled for kernel 2.0.36

------- Additional Comments From notting@redhat.com  02/15/99 17:13 -------


*** Bug 1181 has been marked as a duplicate of this bug. ***

lsof needs to be recompiled for kernel 2.0.36

Comment 4 Jeff Johnson 1999-03-09 05:14:59 UTC
Fixed in lsof-4.40 security errata.


Note You need to log in before you can comment on or make changes to this bug.