Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 894688 - [ovirt-iso-uploader] Can not use iso-uploader due to certificate issues
Summary: [ovirt-iso-uploader] Can not use iso-uploader due to certificate issues
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-iso-uploader
Version: 3.2.0
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: 3.2.0
Assignee: Kiril Nesenko
QA Contact: Ilanit Stein
URL:
Whiteboard: integration
Depends On:
Blocks: 915537
TreeView+ depends on / blocked
 
Reported: 2013-01-13 08:28 UTC by Kiril Nesenko
Modified: 2014-07-11 00:09 UTC (History)
11 users (show)

Fixed In Version: rhevm-iso-uploader-3.2.0-0.1.master.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Previously, the naming convention in place for the certificate file used by rhevm-iso-uploader to ensure secure communications prevented the uploader from working correctly. The certificate file, formerly named engine_ca, is now called cert_file, and the rhevm-iso-uploader functions correctly.
Clone Of:
Environment:
Last Closed: 2013-06-10 20:17:31 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0919 normal SHIPPED_LIVE Updated package: rhevm-iso-uploader 2013-06-11 00:14:38 UTC
oVirt gerrit 11021 None None None Never

Description Kiril Nesenko 2013-01-13 08:28:19 UTC
Description of problem:
Can not use iso-uploader due to certificate issues. 
the way optparse works is to first try and find an exact match of the param (that is to match "engine" with "engine"), and if there's no match, it will check whether "engine" could be an abbreviation of another param (that is there's only one parameter that begins with "engine") , and in this case "engine_ca" matches. This causes "engine_ca" param to get value of "engine" from the configuration file, and thus supply incorrect value to the API object creation. 

Fix is to replace "engine_ca" -> "ca_file"/"cert_file"/"certificate"

Version-Release number of selected component (if applicable):
rhevm-iso-uploader-3.1.0-9.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Kiril Nesenko 2013-01-15 09:00:56 UTC
Patch posted for review: http://gerrit.ovirt.org/#/c/11021/1

Comment 4 Ilanit Stein 2013-02-20 12:30:37 UTC
Verified on sf7:

[root@lilach-rhel ~]# engine-iso-uploader --engine lilach-rhel.qa.lab.tlv.redhat.com list
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to abort): 
ERROR: There are no ISO storage domains.

Comment 5 errata-xmlrpc 2013-06-10 20:17:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0919.html


Note You need to log in before you can comment on or make changes to this bug.