Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 891073 - [rhevm-dwh] History DB - Change Fields "Network Name" to "Logical Network Name"
Summary: [rhevm-dwh] History DB - Change Fields "Network Name" to "Logical Network Name"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.5.0
Assignee: Shirly Radco
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-01-01 14:44 UTC by David Botzer
Modified: 2016-02-10 19:07 UTC (History)
8 users (show)

Fixed In Version: oVirt 3.5 Alpha 1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 18:14:09 UTC
oVirt Team: Infra
Target Upstream Version:
dyasny: Triaged+


Attachments (Terms of Use)
NetworkName (deleted)
2013-01-01 14:44 UTC, David Botzer
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0177 normal SHIPPED_LIVE rhevm-dwh 3.5 bug fix and enhancement update 2015-02-11 23:11:50 UTC
oVirt gerrit 27733 master MERGED history: updated network_name in dwh views Never
oVirt gerrit 27789 master MERGED history: changed network_name column Never

Description David Botzer 2013-01-01 14:44:42 UTC
Created attachment 670984 [details]
NetworkName

Description of problem:
In webadmin the entity name is"Logical Network"
And in History DB / Reports this entity fields are called only "Network"
e.x
"Network Name"

In order to distinguish, and allow coralation between Webadmin & Reports

Version-Release number of selected component (if applicable):
3.1/si25.2

How reproducible:
always

Steps to Reproduce:
1.Examine Engine DB table "network" the field name is "Network Name"
2.Examine Engine DB "vds_interface" the field name is "Network Name"
3.Examine History DB "v3_1_host_interface_configuration_view" the field name is "Network Name"
4.Examine in Webadmin under cluster, See Logical Networks Tab
  name of entity is "Logical Network"
  
Actual results:
field name is "Network Name"

Expected results:
Should change to "Logical Network Name"

Additional info:

Comment 3 Barak Dagan 2014-06-11 12:52:03 UTC
Verified on oVirt 3.5 Alpha 1:

bash-4.1$ psql -d engine -c "select table_name, column_name from information_schema.columns where table_name like '%dwh%view%' and column_name like '%network%';"

                  table_name                   |     column_name      
-----------------------------------------------+----------------------
 dwh_host_interface_configuration_history_view | logical_network_name
 dwh_vm_interface_configuration_history_view   | logical_network_name



bash-4.1$ psql -d ovirt_engine_history -c "select table_name, column_name from information_schema.columns where table_name like 'v3_5%configuration%' and column_name like '%network%';"

                 table_name                  |     column_name      
---------------------------------------------+----------------------
 v3_5_configuration_history_hosts_interfaces | logical_network_name
 v3_5_latest_configuration_hosts_interfaces  | logical_network_name
 v3_5_configuration_history_vms_interfaces   | logical_network_name
 v3_5_latest_configuration_vms_interfaces    | logical_network_name

Comment 6 errata-xmlrpc 2015-02-11 18:14:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0177.html


Note You need to log in before you can comment on or make changes to this bug.