Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 891 - /etc/inetd.conf contains bogus entry for time protocol
Summary: /etc/inetd.conf contains bogus entry for time protocol
Keywords:
Status: CLOSED DUPLICATE of bug 1725
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: intimed
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 1023 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-20 15:33 UTC by tschenk
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-24 14:20:38 UTC


Attachments (Terms of Use)

Description tschenk 1999-01-20 15:33:03 UTC
/etc/inetd.conf contains the following two lines:

time   stream  tcp     nowait  nobody  /usr/sbin/tcpd
in.timed
time   dgram   udp     wait    nobody  /usr/sbin/tcpd
in.timed

This is incorrect for at least the following two reasons.

1.  in.timed should be running continuously if it is running
    at all.  It is not a on demand service, like telnet, but
    rather an active service like xntpd.
2.  The time protocol is built into inetd, just like daytime
    and chargen.

/etc/inetd.conf should have the two lines shown above taken
out and these two lines should be added:

time    stream  tcp     nowait  root    internal
time    dgram   udp     wait    root    internal

This mistake is in all versions that I have checked between
RedHat 4.2 and 5.2.

Tom Schenk
Systems Administrator
Deja News, Inc.

Comment 1 tschenk 1999-01-20 21:38:59 UTC
Reason 3 for the current entry being incorrect.

3.  in.timed doesn't talk time protocol.  It talks timed protocol.

Comment 2 seva 1999-01-21 17:44:59 UTC
while we are at it, why is gopher still there?

Comment 3 Jeff Johnson 1999-02-02 14:35:59 UTC
*** Bug 1023 has been marked as a duplicate of this bug. ***

UDP time requests to RH Linux systems (including 4.2, 5.0
and 5.1) fail. The symptoms are that no time is returned and
inetd reports "time/udp server failing (looping), service
terminated".

This turns out to be due to an error in inetd.conf.  The
time daemon in.timed is not suitable for handling udp
requests; however inetd provides an internal handler.
Therefore replacing the line:
time   dgram   udp     wait    nobody  /usr/sbin/tcpd
in.timed
with:
time    dgram   udp     wait    root    internal

gives the correct behaviour.

Peter

------- Additional Comments From ayn2@cornell.edu  02/02/99 01:49 -------
This is a duplicate of the report #891

Comment 4 Jeff Johnson 1999-02-11 18:35:59 UTC
This problem has been fixed in Raw Hide.

Comment 5 Jeff Johnson 1999-03-24 14:20:59 UTC
*** This bug has been marked as a duplicate of 1725 ***


Note You need to log in before you can comment on or make changes to this bug.