Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 889097 - vm's status is changed to pause for a short moment during volume refresh (after an extend)
Summary: vm's status is changed to pause for a short moment during volume refresh (aft...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.4.0
Assignee: Federico Simoncelli
QA Contact: Raz Tamir
URL:
Whiteboard: storage
: 912049 (view as bug list)
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2012-12-20 08:37 UTC by Dafna Ron
Modified: 2016-02-10 18:30 UTC (History)
13 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Previously, the status of virtual machines on which a volume refresh operation was being performed would appear as paused under certain conditions. This was caused by the logic used to handle the refresh operation, which would freeze the virtual machine on which the operation was being performed to avoid errors caused by input and output during the operation. When the refresh operation took several seconds to complete, this change in status was reported to the Red Hat Enterprise Virtualization Manager. Now, the logic used when refreshing volumes has been revised so that virtual machines are not paused during a refresh operation because the logical volume manager is responsible for freezing input and output.
Clone Of:
Environment:
Last Closed: 2014-06-09 13:24:30 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0504 normal SHIPPED_LIVE vdsm 3.4.0 bug fix and enhancement update 2014-06-09 17:21:35 UTC
oVirt gerrit 8382 None None None Never
oVirt gerrit 24038 None None None Never

Description Dafna Ron 2012-12-20 08:37:27 UTC
Description of problem:

following bug 883939:

At the moment vdsm needs to pause the VM for a short moment during the volume refresh (after an extend). In certain cases (or if the refresh takes few seconds) it might be also reported to the engine.

Version-Release number of selected component (if applicable):

vdsm-4.9.6-44.2.el6_3.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Run several thin provision vm's 
2. move the vm's disks to a second storage
3.
  
Actual results:

vm's status changes to pause -> up when we refresh the disk

Expected results:

vm status should not be changed

Additional info: logs can be found in bug 873145

Comment 1 Ayal Baron 2013-02-17 13:11:58 UTC
*** Bug 912049 has been marked as a duplicate of this bug. ***

Comment 2 Federico Simoncelli 2013-07-09 09:59:05 UTC
There is an old poc upstream for this:

[poc] vm: do not pause during refreshVolume

Signed-off-by: Federico Simoncelli <fsimonce@redhat.com>
Change-Id: I896993c00b94c3255ad2007486e0589bf10b3a98

http://gerrit.ovirt.org/#/c/8382

If we decide to go this way we need to consider that the patch affects many flows and it should be tested extensively.

Best idea is probably to introduce that at the beginning of a cycle of development (rather than at the end).

Bug is not frequent anyway (I haven't heard of it since a while). It is probably triggered only in special cases when the storage is under heavy load.

Comment 3 Ayal Baron 2013-12-18 09:30:29 UTC
Fede, update on verification of patch? it would be better to push this in asap to get the most testing we can...

Comment 4 Federico Simoncelli 2014-02-04 11:56:53 UTC
The patch was merged in master. Waiting for inclusion in 3.4.

Comment 5 Raz Tamir 2014-02-16 12:38:01 UTC
verified - followed the steps to reproduce

Comment 7 Raz Tamir 2014-02-19 13:28:36 UTC
it has been verified on beta2

Comment 11 errata-xmlrpc 2014-06-09 13:24:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0504.html


Note You need to log in before you can comment on or make changes to this bug.