Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88771 - rpm -Fhv glibc-2.3.2-27.9.i386.rpm results in broken system
Summary: rpm -Fhv glibc-2.3.2-27.9.i386.rpm results in broken system
Keywords:
Status: CLOSED DUPLICATE of bug 88456
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-13 21:07 UTC by Zenon Panoussis
Modified: 2016-11-24 15:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:39 UTC


Attachments (Terms of Use)

Description Zenon Panoussis 2003-04-13 21:07:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Upgrading from glibc-2.3.2-11.9 to glibc-2.3.2-27.9.i386 leaves *both* versions
on the system. Once that happens, everything segfaults. On reboot (brutal
reboot, the reboot command segfaults too), init gets confused, spits out a
"respawning too fast, disabled for 5 minutes" message for each and every
runlevel and stalls. 

Workaround: Boot from another installation/CD. If 
   # rpm -qa --root /your/root |grep glibc 
shows both versions of glibc present, do
   # rpm --force --root /your/root -e glibc-2.3.2-11.9 
and reboot again.


Version-Release number of selected component (if applicable):
glibc-2.3.2-27.9

How reproducible:
Twice

Steps to Reproduce:
This happened to me on two different systems. 

Expected Results:  The later version should uninstall the earlier one.

Comment 1 Jakub Jelinek 2003-04-13 21:10:47 UTC
Why are you "upgrading" from i686 version to i386 one?

*** This bug has been marked as a duplicate of 88456 ***

Comment 2 Zenon Panoussis 2003-04-13 21:44:28 UTC
Perhaps because I was too charmed by "wget -nd *; rpm -Fhv *.rpm". This still
shouldn't happen. 

BTW, having read the discussion on 88456, I can add that was upgrading 9, not
from 8.0. 

Comment 3 Red Hat Bugzilla 2006-02-21 18:52:39 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.