Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88748 - Second monitor turns off with ATI Radeon and Xinerama
Summary: Second monitor turns off with ATI Radeon and Xinerama
Keywords:
Status: CLOSED DUPLICATE of bug 87854
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-13 01:03 UTC by Andrew Rechenberg
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:39 UTC


Attachments (Terms of Use)
Fixes ATI Radeon second monitor turning off with xinerama (deleted)
2003-04-13 01:06 UTC, Andrew Rechenberg
no flags Details | Diff

Description Andrew Rechenberg 2003-04-13 01:03:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
The ATI Radeon dual head card is deteced and configured correctly upon upgrading
my workstation from Red Hat 8.0 to Red Hat 9.  However when I move my cursor to
the second monitor it shuts down.

According to the Shrike users list, this is caused by a typo in the
radeon_cursor.c file.  I patched the file as suggested on the mailing list and
rebuilt the RPMS and now my Xinerama configuration works.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat 9 on box with ATI Radeon 7000 (maybe others)
2. Configure Xinerama (or have redhat-config-xfree86 do it)
3. Move cursor onto second monitor and watch it turn off
    

Actual Results:  Monitor turns off

Expected Results:  Monitor should not turn off

Additional info:

Comment 1 Andrew Rechenberg 2003-04-13 01:06:40 UTC
Created attachment 91104 [details]
Fixes ATI Radeon second monitor turning off with xinerama

I added this patch as Patch136, and added '%patch136 -p0' as well to the
XFree86.spec file and then rebuilt the RPMS.

Comment 2 Mike A. Harris 2003-04-13 01:26:12 UTC
While this is allready reported in bugzilla, and the same patch present,
thanks nonetheless for your feedback and for attaching the patch as well.

*** This bug has been marked as a duplicate of 87544 ***

Comment 3 Mike A. Harris 2003-04-13 01:28:10 UTC
Argh, closed as dupe of wrong bug number.

Comment 4 Mike A. Harris 2003-04-13 01:30:26 UTC

*** This bug has been marked as a duplicate of 87854 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:52:39 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.