Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 886782 - Missed dump file in remote nfs/ssh server when cofigure kdump on Dell smbios 2.6+ machine via NFS/SSH
Summary: Missed dump file in remote nfs/ssh server when cofigure kdump on Dell smbios ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 892703 894951 1150377
Blocks: 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2012-12-13 06:53 UTC by haiyang,dong
Modified: 2016-02-10 20:09 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:43:32 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
Screenshot showing that /dev/HostVG/Data can not be found (deleted)
2012-12-14 16:04 UTC, Fabian Deutsch
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Description haiyang,dong 2012-12-13 06:53:01 UTC
Description of problem:
when configured kdump on Dell smbios 2.6+ machine via NFS/SSH to saving the dump file to remote nfs/ssh server.
There is no dump file in remote nfs/ssh server.

Also make a summary here:

1.configured kdump via NFS/SSH on 6.3 build

normal machine- 100% saved dump file in remote nfs/ssh server
Dell smbios 2.6+ machine - 100% saved dump file in remote nfs/ssh server
HP biosdevname 2.6 - 100% saved dump file in remote nfs/ssh server

2.configured kdump via NFS/SSH on 6.4 build

normal machine- sometimes could save dump file in remote nfs/ssh server(may the root cause is that Missed the line "link_delay 60" in /etc/kdump.conf)
Dell smbios 2.6+ machine - 100% missed dump file in remote nfs/ssh server
HP biosdevname 2.6 -   80% can send dump into remote nfs/ssh server

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121206.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor6-6.4-20121206.0.el6
2. Configure the Kernel Dump with NFS/SSH in the TUI.
3. echo c>/proc/sysrq-trigger to make the system coredump.
4. check the remote nfs/ssh server folder

Actual results:
1. There is no dump file in the remote nfs/ssh server.

Expected results:
There is dump file in remote nfs/ssh server.

Additional info:
----------

Comment 1 Fabian Deutsch 2012-12-14 16:04:17 UTC
Created attachment 663637 [details]
Screenshot showing that /dev/HostVG/Data can not be found

Seems to be that the VGs are not found/nodes created.

Comment 17 Fabian Deutsch 2013-01-08 11:01:48 UTC
An update from 892703 comment 7 : There is a fix for this problem but afterwards the bridge has problems to retrieve an IP address (seems to be a different bug, like 817157).

Comment 24 haiyang,dong 2013-10-20 07:38:24 UTC
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6

Test Steps
1. Install rhev-hypervisor6-6.4-20121206.0.el6
2. Configure the Kernel Dump with NFS/SSH/Local in the TUI.
3. echo c>/proc/sysrq-trigger to make the system coredump.
4. check the remote nfs/ssh server folder and local

Test results:
There is dump file in remote nfs/ssh server and local host.

so this bug has been fixed, change the status into "VERIFIED"

Comment 27 Ying Cui 2014-07-29 11:12:29 UTC
Change this bug to ON_QA, due to this bug flag is for rhev 3.5, we need to test and verify this bug on rhevh 7.0 + node 3.1.

Comment 28 haiyang,dong 2014-11-11 10:39:57 UTC
Test version:
rhev-hypervisor6-6.6-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch


Test Steps
1. Install rhev-hypervisor6-6.6-20141107.0.iso
2. Configure the Kernel Dump with NFS/SSH/Local in the TUI.
3. echo c>/proc/sysrq-trigger to make the system coredump.
4. check the remote nfs/ssh server folder and local

Test results:
There is dump file in remote nfs/ssh server and local host.

so this bug has been fixed in in rhevh 6.6 for RHEV 3.5 bulid version, change the status into "VERIFIED"

Comment 30 errata-xmlrpc 2015-02-11 20:43:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.