Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88642 - dateBackend.py fails line getNtpServer token index
Summary: dateBackend.py fails line getNtpServer token index
Keywords:
Status: CLOSED DUPLICATE of bug 78651
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date
Version: 8.0
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-11 17:21 UTC by Joseph G. Kneuer
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:37 UTC


Attachments (Terms of Use)

Description Joseph G. Kneuer 2003-04-11 17:21:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Root password request screen works normally, but actual calendar time
screen never opens.  Returns to console.

====
Console message reads:
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 176, in __init__
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 154, in __init__
    ntpServer = mainWindow.dateBackend.getNtpServer()
  File "/usr/share/redhat-config-date/dateBackend.py", line 184, in getNtpServer
    self.ntpServer = tokens[1]
IndexError: list index out of range
====
This program works perfectly on another machine (i586 laptop)
Files in /usr/share/redhat-config-date match between machines.

In both cases running over LAN using VNCViewer/VNCServer.  Both machines current
under "up2date". Both rpm-config-dates are version 1.5.2-10.  Was able to set
date on problem machine using
date --set=STRING
from the console

Version-Release number of selected component (if applicable):
redhat-config-date-1.5.2-10

How reproducible:
Always

Steps to Reproduce:
1. From console, type 
redhat-config-date &

2. Always behaves as in description
    

Actual Results:  As in description

Expected Results:  Normal redhat-config-date window allowing correction of
system date and time.

Additional info:

Comment 1 Brent Fox 2003-04-14 16:20:33 UTC

*** This bug has been marked as a duplicate of 78651 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:37 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.