Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 885 - delaying eth0 initialization?
Summary: delaying eth0 initialization?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: net-tools
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-20 01:36 UTC by Raymond Willis
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-01-21 01:20:50 UTC


Attachments (Terms of Use)

Description Raymond Willis 1999-01-20 01:36:37 UTC
I have been having intermitent problems with multiple NIC's
some times they both work or the second one doesnt.  I have
avoided these problems by putting the network config's in
the /etc/rc.d/rc.local i.e. modprobe io=xxx irq=x ifconfig
and all that jazz.  I am still not satisfied with this and
would like to know why it does delay the ethx
initialization.  How long does it delay anyway?  well we all
know that it does'nt if it doesnt start at boot.  just look
at the ifup script in /sbin/ifup.  I dont use X on most of
the machines that I install linux on, and I like to use
linuxconf but it is kinda buggy with multiple cards.  i.e.
it makes multiple copies of the same setup and enabling
them.  Is there a problem with linuxconf?  I also looked at
/sbin/ifup and noticed that it has a variable "if uid !=0
then "delaying {DEVICE} initialization"  is this what the
problem is?  I mostly configure servers with two nics after
installing i.e. I install one card during setup then hand
edit the second one in
/etc/sysconfig/network-scripts/ifcfg-ethx.  This is not
exceptable for a server platform to just default to one NIC
during install.  anyway that is what the problem is.

Regards,
Rayw
rayw@advanced-computer.com.

Comment 1 David Lawrence 1999-01-21 01:20:59 UTC
Delaying eth initialization is usually associated with the modules not
knowing that there are two eth cards in the system. The easiest way to
set this up is to place in your /etc/conf.modules file

alias eth0 <network module>
alias eth1 <network module>

and then if the cards are the same then add the following:

options <network module> io=0x300,0x280

or whatever address the cards are using. If Linuxconf has problems
configuring network interfaces then we need to have bug reports
specifically for linuxconf so we can fix problems associated with it.
We are continuously trying to improve functionality of linuxconf.

The reason for the ifup script to contain the if uid != 0 part, is so
that if the root user configures it that way, normal users can bring
up or down interfaces. The line USERCTL=yes/no in
/etc/sysconfig/network-scripts/ifcfg-eth0 dictates this. If the
ONBOOT= is set to yes then when you boot the machine the uid does not
matter.

------- Email Received From  Raymond Willis <rayw@infinity-technical.com> 01/21/99 10:15 -------


Note You need to log in before you can comment on or make changes to this bug.