Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88459 - redhat-config-network-gui:144:?:AttributeError: 'module' object has no attribute 'program_init'
Summary: redhat-config-network-gui:144:?:AttributeError: 'module' object has no attrib...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-10 07:56 UTC by Volker Meyer
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-11 14:10:30 UTC


Attachments (Terms of Use)
selection of "New" in device tab crashes application. (deleted)
2003-04-19 13:13 UTC, sean flaherty
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:183 normal SHIPPED_LIVE Updated redhat-config-network package available 2003-08-11 04:00:00 UTC

Description Volker Meyer 2003-04-10 07:56:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0 (BDP)

Description of problem:
Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/sbin/redhat-config-network-gui:144:?:AttributeError: 'module'
object has no attribute 'program_init'
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 144, in ?
    gnome.program_init(PROGNAME, PRG_VERSION)
AttributeError: 'module' object has no attribute 'program_init'

Local variables in innermost frame:
splash_screen: <function splash_screen at 0x8137b3c>
PRG_VERSION: 1.2.0
mainDialog: netconfpkg.gui.maindialog.mainDialog
__builtins__: <module '__builtin__' (built-in)>
progname: redhat-config-network-gui
PROGNAME: redhat-config-network
sys: <module 'sys' (built-in)>
cmdline: []
NETCONFDIR: /usr/share/redhat-config-network/
__name__: __main__
handleException: <function handleException at 0x82441ac>
netconfpkg: <module 'netconfpkg' from
'/usr/sbin/../share/redhat-config-network/netconfpkg/__init__.pyc'>
gnome: <module 'gnome' from '/usr/lib/python2.2/site-packages/gnome/__init__.pyc'>
get_pixpath: <function get_pixpath at 0x8160614>
signal: <module 'signal' (built-in)>
gtk: <module 'gtk' from '/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.pyc'>
gettext: <module 'gettext' from '/usr/lib/python2.2/gettext.pyc'>
NewInterfaceDialog: netconfpkg.gui.NewInterfaceDialog.NewInterfaceDialog
PRG_NAME: redhat-config-network
showprofile: 1
os: <module 'os' from '/usr/lib/python2.2/os.pyc'>
__doc__: None


Version-Release number of selected component (if applicable):
redhat-config-network-1.2.0-2

How reproducible:
Always

Steps to Reproduce:
1. launch redhat-control-network
2.  klick on "Configure" for an existing eth0
3.
    

Actual Results:  Window pops up telling me, that I found a bug, asking me to
report it.

Expected Results:  Configuration menue of eth0

Additional info:

Comment 1 Harald Hoyer 2003-04-14 13:36:40 UTC
Does the update on 
http://people.redhat.de/harald/redhat-config-network
help ?

Comment 2 Harald Hoyer 2003-04-14 13:37:34 UTC
Oops... wrong URL
http://people.redhat.com/harald/redhat-config-network


Comment 3 Volker Meyer 2003-04-16 08:59:00 UTC
No exactly.
Clicking the "Hardware" Tab gives me 3 cards.
If I try to delete one I get:
---
Component: redhat-config-network
Version: 1.2.3
Summary: TB
/var/tmp/redhat-config-network-1.2.3-root/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py:1371:on_hardwareDeleteButton_clicked:ValueError:
can't get text value
Traceback (most recent call last):
  File
"/var/tmp/redhat-config-network-1.2.3-root/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 603, in on_deleteButton_clicked
  File
"/var/tmp/redhat-config-network-1.2.3-root/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 1371, in on_hardwareDeleteButton_clicked
ValueError: can't get text value
---

Comment 4 Harald Hoyer 2003-04-16 09:08:40 UTC
oh.. that one is cool.. many thx! fixed in CVS.. 

Comment 5 Harald Hoyer 2003-04-17 10:09:52 UTC

*** This bug has been marked as a duplicate of 82805 ***

Comment 6 Harald Hoyer 2003-04-17 10:33:25 UTC
wrong bug, to duplicate ... tss..

Comment 8 sean flaherty 2003-04-19 13:13:21 UTC
Created attachment 91193 [details]
selection of "New" in device tab crashes application.

Re: case #88459. My installation has 2 NICs. They total three identifications
under the hardware tab of Network Device Control (etho status:ok twice, eth1
status:configured once). Attempt to rm the extra eth0 results in application
crash. Also, in devices tab selection of "New" results in application crash.

Comment 9 Harald Hoyer 2003-05-19 11:26:08 UTC
Please try the update on
http://people.redhat.com/harald/redhat-config-network

Comment 10 Harald Hoyer 2003-08-11 14:10:30 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html



Note You need to log in before you can comment on or make changes to this bug.