Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88457 - zsh startup fails to load /etc/profile.d/*.sh
Summary: zsh startup fails to load /etc/profile.d/*.sh
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: zsh
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Mike McLean
URL:
Whiteboard:
: 92132 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-10 07:47 UTC by Ben Liblit
Modified: 2007-04-18 16:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-01 01:19:01 UTC


Attachments (Terms of Use)

Description Ben Liblit 2003-04-10 07:47:35 UTC
Description of problem:

Many packages put shell initialization scripts into /etc/profile.d/*.{sh,csh}. 
Under Red Hat 8.0, zsh picked up the "*.sh" scripts, just like bash.  However,
under Red Hat 9, it no longer does this.

Version-Release number of selected component (if applicable):
zsh-4.0.6-5

How reproducible:
Easily reproduced every time.

Steps to Reproduce:
1. Install a package which uses profile.d scripts.  "less" is a good example.
2. Log in as a user whose shell is bash.  echo $LESSOPEN
3. Log in as a user whose shell is zsh.  echo $LESSOPEN
    
Actual results:
$LESSOPEN is set under bash, but not set under zsh.  More generally, no
/etc/profile.d/*.sh shell initialization scripts were run under zsh.

Expected results:
$LESSOPEN should have been set under zsh as well.  More generally, all
/etc/profile.d/*.sh shell initialization scripts should have been run.

Additional info:
Under Red Hat 8.0, /etc/zshenv contained the following:

	# Sourcing here to get it done on all invocations of zsh,
	# like bash.
	source /etc/profile

Those lines are no longer present in the Red Hat 9 release.  Perhaps they were
removed accidentally, and simply need to be added back in.

Comment 1 Jens Petersen 2003-05-01 01:19:01 UTC
Perhaps this should have gone into the release notes...

The lines were moved into /etc/skel/.zshrc because of
bug 65509 - not ideal for old users of course, but it seemed
to be the only compromise solution.


Comment 2 Jens Petersen 2003-06-03 05:03:17 UTC
*** Bug 92132 has been marked as a duplicate of this bug. ***

Comment 3 Jens Petersen 2003-09-04 06:32:45 UTC
*** Bug 102187 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.