Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88455 - SIGRTMAX defined differently in 2 header files
Summary: SIGRTMAX defined differently in 2 header files
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-10 05:21 UTC by Craig Worthington
Modified: 2016-11-24 15:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-17 04:10:08 UTC


Attachments (Terms of Use)

Description Craig Worthington 2003-04-10 05:21:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
When a program uses real-time signals then attempting to
use SIGRTMAX with sigaddset fails with EINVAL. The cause
is probably due to the mis-match:

[/usr/include]# uname -a
Linux *.*.* 2.4.20-9 #1 Wed Apr 2 13:42:50 EST 2003 i686 i686 i386 GNU/Linux
[/usr/include]# cat /etc/redhat-release
Red Hat Linux release 9 (Shrike)
[/usr/include]# grep SIGRTMAX */*.h
asm/signal.h:#define SIGRTMAX   (_NSIG-1)
bits/signum.h:#define SIGRTMAX        (__libc_current_sigrtmax ())
bits/signum.h:#define __SIGRTMAX        _NSIG

On a machine running Phoebe,
asm/signal.h:#define SIGRTMAX   (_NSIG-1)
bits/signum.h:#define SIGRTMAX        (__libc_current_sigrtmax ())
bits/signum.h:#define __SIGRTMAX        (_NSIG - 1)




Version-Release number of selected component (if applicable):
glibc-kernheaders-2.4-8.10 glibc-devel-2.3.2-27.9

How reproducible:
Always

Steps to Reproduce:
1.try to add SIGRTMAX to a signal set using sigaddset()
2.
3.
    

Actual Results:  sigaddset() failed with EINVAL

Expected Results:  sigaddset() should have succeeded

Additional info:

Comment 1 Ulrich Drepper 2003-04-17 04:10:08 UTC
It is none of your business to look at the kernel headers.  Their content is
valid for the kernel but not userlevel.


Note You need to log in before you can comment on or make changes to this bug.