Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88400 - De-selected package installed
Summary: De-selected package installed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-09 20:06 UTC by William WK Lee
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-05 03:09:14 UTC


Attachments (Terms of Use)

Description William WK Lee 2003-04-09 20:06:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
Red Hat Linux 9 Text Mode Installation Fault: I start the installation in text 
mode by specifying "linux text" at the boot prompt.  At the package selection 
manual, I de-select Webserver, X Windows system and Gnome windows manager.  
However, all these are installed and a Xconfigurator is presented at the end of 
the installation!

So poor in package management.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. At the boot prompt, type "linux text"
2. Follow the installation steps till selection of package
3. De-select webserver, X Windows system and Gnome
4. Let the installation complete.

    

Actual Results:  The de-selected items of Apache, XFree86, Gnome, etc. are 
installed.

Expected Results:  The de-selected packages should not be installed.

Additional info:

Comment 1 Mike Hoye 2003-09-03 03:10:10 UTC
The RH9 installer doesn't seem to care much about what you actually choose,
whether you're using text-only or graphical installers. I have unsuccessfully
tried to get through the process without installing cups, sendmail and anything
gnome-related, but the installer not only installs cups and sendmail anyway, but
they're up and running after the first reboot.

In install-related news, you can't actually uninstall them through the GUI at all.



Comment 2 Charles Curley 2003-10-02 17:36:44 UTC
I'll add this here rather than file a new bug, as it may be related. I found
this on severn Betas 1 and 2. I have not tested for it on RH 9.

OpenOffice.org has three RPMs, of an average size of 35 MB. If you install the
Office/Productivity group, you get all three. Fine. If you select
Office/Productivity and then deselect OpenOffice.org, openoffice-i18n-1.0.2-4
and openoffice-libs-1.0.2-4 are installed anyway. They have no purpose other
than to support openoffice-1.0.2-4, and can be removed immediately after
installation:
[root@issola root]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda3             1.6G  1.3G  235M  85% /
/dev/hda2              98M  6.2M   87M   7% /boot
none                   34M     0   34M   0% /dev/shm
[root@issola root]# rpm -e `rpm -qa | grep openoffice`
[root@issola root]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda3             1.6G  1.1G  460M  71% /
/dev/hda2              98M  6.2M   87M   7% /boot
none                   34M     0   34M   0% /dev/shm
[root@issola root]#

The problem is reproducable with kickstart files. The only workaround of which I
am aware is to use a kickstart file and deselect all the packages you don't want.

This error costs 225MB, which is significant on older machines, such as those
used by non-profits, educational institutions, and in poorer countries where
folks don't have a lot of money.


Comment 3 Jeremy Katz 2004-10-05 03:09:14 UTC
This should be better in newer releases.


Note You need to log in before you can comment on or make changes to this bug.