Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88392 - print jobs removed if printer stops
Summary: print jobs removed if printer stops
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: LPRng
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-09 18:01 UTC by Mel
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-08 14:12:14 UTC


Attachments (Terms of Use)

Description Mel 2003-04-09 18:01:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
If while printing, the printer runs out of paper, that print job and all other
print jobs will be lost after about 30 minutes. This is regardless of what I
have in /etc/lpd.conf. With the following uncommented lines in my lpd.conf, the
print jobs continue to be dropped.

db=5
lf=/var/log/lpd.log
mail_operator_on_error=root
mc#128
send_failure_action=retry
send_job_rw_timeout=0
send_query_rw_timeout=0
send_try=0

According to man lpd.conf, the above '0' for each field is supposed to be
infinite timeouts, infinite retrys, etc.

One of my printers in /etc/printcap looks like this:
lp:\
        :ml#0:\
        :mx#0:\
        :sd=/var/spool/lpd/lp:\
        :af=/var/spool/lpd/lp/lp.acct:\
        :sh:\
        :lp=/dev/lp0:\
        :lpd_bounce=true:\
        :if=/usr/share/printconf/util/mf_wrapper:



Version-Release number of selected component (if applicable):
LPRng-3.8.9-6

How reproducible:
Always

Steps to Reproduce:
1. edit /etc/lpd.conf, setting send_try=0, and send_failure_action=retry
2. restart lpd with "service lpd restart"
3. print a multi-page job
4. make the printer run out of paper while it is printing
5. wait 30 minutes
    

Actual Results:  print job is removed from queue without finishing

Expected Results:  print job should continue trying to print "forever", or until
paper is placed into the printer... whichever comes first

Additional info: All of our printers are setup as "Assume Unknown data is text"
and "Do not convert to postscript"

Comment 1 Tim Waugh 2004-12-08 14:12:14 UTC
Closing since we ship CUPS now instead of LPRng.


Note You need to log in before you can comment on or make changes to this bug.