Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8839 - NFS server does not respect netgroup or DNS settings
Summary: NFS server does not respect netgroup or DNS settings
Keywords:
Status: CLOSED DUPLICATE of bug 10332
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-25 15:33 UTC by Joseph Kotran
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-11-11 16:42:40 UTC


Attachments (Terms of Use)

Description Joseph Kotran 2000-01-25 15:33:32 UTC
The man page for the file /etc/exports defines a method of restricting NFS
access based upon membership in a netgroup or based upon DNS names.  The
NFS server does not respect these restrictions.  For example if you
restrict a NFS share to your local DNS domain (*.redhat.com), no clients
will be able to mount the file share.  The client will get a permission
denied error.  In order to share file systems you must export them to the
world.  I have never been able to make NIS netgroup restrictions work.
However, DNS domain restrictions worked up to Red Hat 5.2.

Regards,

Joe Kotran

Comment 1 Seth Vidal 2000-07-14 05:45:13 UTC
Can you make this reliably occur. I'm running rhat 6.2 on >20 nfs servers and I
don't see this problem on ANY of them.



Comment 2 Cristian Gafton 2000-08-09 02:34:43 UTC
assigned to johnsonm

Comment 3 Changed to DavidTangye@hotmail.com 2001-03-29 06:24:35 UTC
Refer my bug 33742 posted today. Maybe my permission denied is caused by the
same sort of thing: the way the exports file is coded.

Best regards,
David Tangye

------------------------------------------------------------------------
-- Public email :  DavidTangye@hotmail.com
-- Public website: http://www.ozemail.com.au/~dtangye
--
-- Quality Software Systems - Consulting and Development 
-- using Linux, Java, Oracle, Rational, Borland, & Corel
------------------------------------------------------------------------


Comment 4 Aleksey Nogin 2001-11-11 16:42:35 UTC
This may be a duplicate of 10332

Comment 5 Michael K. Johnson 2002-01-18 18:01:07 UTC
I think you are right, this probably is a duplicate of 10332.
Well, more like 10332 is a duplicate of this, but it all comes
down to the same thing in the end...

*** This bug has been marked as a duplicate of 10332 ***


Note You need to log in before you can comment on or make changes to this bug.