Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88373 - Packaging bug: libgnome-window-settings.so not included
Summary: Packaging bug: libgnome-window-settings.so not included
Keywords:
Status: CLOSED DUPLICATE of bug 88375
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: control-center
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-09 15:20 UTC by Andrew Sobala
Modified: 2013-04-02 04:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:35 UTC


Attachments (Terms of Use)

Description Andrew Sobala 2003-04-09 15:20:19 UTC
control-center includes these files:

libgnome-window-settings.so.1
libgnome-window-settings.so.1.0.0

It is missing:

libgnome-window-settings.so

So applications work, but ld refuses to link any new packages against this library.

Comment 1 Alexander Larsson 2003-08-29 10:39:02 UTC
The specfile specifically removes the .so file. Probably because nothing should link against this library (it has no headers for instance).

What tried to link against it?


Comment 2 Andrew Sobala 2003-08-29 11:43:53 UTC
This was from when themus was a standalone module; it needed this to change
window themes.

I'm going from memory here, but I think the relevant headers are installed by
the control-center tarball in include/gnome-window-settings-2.0/*.h. So if the
headers aren't meant to be installed then that's an upstream bug.

Comment 3 Marco Pesenti Gritti 2004-10-21 11:36:28 UTC
Marking this as a dup of 88375 and adding a comment there. These needs
to be fixed together.

*** This bug has been marked as a duplicate of 88375 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:52:35 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.