Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88341 - CPAN compile results in bogus Makefile
Summary: CPAN compile results in bogus Makefile
Keywords:
Status: CLOSED DUPLICATE of bug 84268
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-09 04:36 UTC by John Simpson
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:34 UTC


Attachments (Terms of Use)
Makefile generated by "perl Makefile.pl" (deleted)
2003-04-09 04:39 UTC, John Simpson
no flags Details

Description John Simpson 2003-04-09 04:36:51 UTC
Description of problem:
Trying to compile certain CPAN modules (so far CDB_File and updated CPAN) from
source generates an invalid Makefile, containing random four-line chunks of
Config.pm instead of single values.

Version-Release number of selected component (if applicable):
perl-5.8.0-88

How reproducible:
try to build CPAN CDB_File module

Steps to Reproduce:
1. wget http://search.cpan.org/CPAN/authors/id/M/MS/MSERGEANT/CDB_File-0.93.tar.gz
2. tar xvzf CDB_File-0.93.tar.gz
3. cd CDB_File-0.93
4. perl Makefile.PL
5. make
    
Actual results:
Makefile:82: *** missing separator.  Stop.

Expected results:
module builds correctly

Additional info:
same thing happened under the 8.1 beta, but module builds correctly under 7.3
and 8.0.

Comment 1 John Simpson 2003-04-09 04:39:25 UTC
Created attachment 91026 [details]
Makefile generated by "perl Makefile.pl"

Comment 2 John Simpson 2003-04-09 05:51:43 UTC
Found bug #84268, tried with LANG=C and with LANG totally unset. In both cases
it builds a valid makefile, and "make" works, but "make test" comes back with
errors. I am working with the module's author for a fix.

*** This bug has been marked as a duplicate of 84268 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:52:34 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.