Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88332 - NCDeviceFactory.py:43:getDeviceClass:KeyError
Summary: NCDeviceFactory.py:43:getDeviceClass:KeyError
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-09 00:47 UTC by Chris Ricker
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-11 14:10:29 UTC


Attachments (Terms of Use)
traceback from r-c-network (deleted)
2003-04-09 00:48 UTC, Chris Ricker
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:183 normal SHIPPED_LIVE Updated redhat-config-network package available 2003-08-11 04:00:00 UTC

Description Chris Ricker 2003-04-09 00:47:47 UTC
I have a user who consistently gets the attached traceback after starting
r-c-network.

I eventually hunted down the cause; the user has a typo in ifcfg-eth0:

[root@station12 root]# more /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=ethO
BOOTPROTO=dhcp
ONBOOT=yes
[root@station12 root]#

(ie, DEVICE="eth-Capital-O", not "eth-Zero")

the capital O always causes r-c-network to die.

Comment 1 Chris Ricker 2003-04-09 00:48:28 UTC
Created attachment 91023 [details]
traceback from r-c-network

Comment 2 Harald Hoyer 2003-04-09 12:20:20 UTC
oh...nice bug :) have to consider that ;) thx

Comment 4 Harald Hoyer 2003-05-19 11:26:57 UTC
Please try the update on
http://people.redhat.com/harald/redhat-config-network

Comment 5 Harald Hoyer 2003-08-11 14:10:29 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html



Note You need to log in before you can comment on or make changes to this bug.