Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88293 - logwatch chokes on ISO-8859 text in /var/log/messages
Summary: logwatch chokes on ISO-8859 text in /var/log/messages
Keywords:
Status: CLOSED DUPLICATE of bug 81144
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logwatch
Version: 9
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-08 16:52 UTC by Kai Thomsen
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:34 UTC


Attachments (Terms of Use)

Description Kai Thomsen 2003-04-08 16:52:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
logwatch's output mail contains the following lines:

 --------------------- Kernel Begin ------------------------ 

Malformed UTF-8 character (unexpected continuation byte 0xae, with no preceding
start byte) in pattern match (m//) at /etc/log.d/scripts/services/kernel line
112, <STDIN> line 145.
Malformed UTF-8 character (unexpected continuation byte 0xae, with no preceding
start byte) in pattern match (m//) at /etc/log.d/scripts/services/kernel line
112, <STDIN> line 145.
Malformed UTF-8 character (unexpected continuation byte 0xae, with no preceding
start byte) in pattern match (m//) at /etc/log.d/scripts/services/kernel line
112, <STDIN> line 145.

[repeats several times]

Malformed UTF-8 character (unexpected continuation byte 0xae, with no preceding
start byte) in pattern match (m//) at /etc/log.d/scripts/services/kernel line
112, <STDIN> line 348.

 ---------------------- Kernel End ------------------------- 

The offending line in /var/log/messages is:

Apr  7 01:52:58 cognitron kernel: input0: USB HID v1.00 Mouse [Microsoft
Microsoft IntelliMouse(R)Explorer] on usb1:2.0

(The "(R)" between "IntelliMouse" and "Explorer" is a single ISO-8859-1
character which I was unable to reproduce in Mozilla.)

Active locale settings are:

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=


Version-Release number of selected component (if applicable):
logwatch-4.3.1-2

How reproducible:
Always

Steps to Reproduce:
1. Plug in a Microsoft IntelliMouse Explorer USB mouse or similar.
2. Boot Red Hat Linux 9.
3. Wait for mail from logwatch.


Actual Results:  Multiple error messages about malformed UTF-8 characters appear
in the mail from logwatch.

Expected Results:  This (and any other ISO-8859-encoded) line should not cause
any errors in the logwatch output.

Additional info:

Comment 1 Elliot Lee 2003-04-11 16:58:00 UTC

*** This bug has been marked as a duplicate of 81144 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:34 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.