Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88290 - config-redhat-xfree86 fails to create config file
Summary: config-redhat-xfree86 fails to create config file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-08 16:06 UTC by Phil Schaffner
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-02-25 15:55:32 UTC


Attachments (Terms of Use)

Description Phil Schaffner 2003-04-08 16:06:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
After upgrade from Red Hat 8.0 to 9 on an IBM Thinkpad A21p type 2629 with ATI
Rage 128 Mobility, X failed to start.  After backing up /etc/X11/XF86config* I
ran config-redhat-xfree86 which resulted in error messages and screen blinks
ending with "Error, cannot start X server."
Also tried "config-redhat-xfree86 --reconfig" and got similar failure.

Searched for alternate config utilities, and finding none for RH 9, I grabbed
XFree86-4.3.0-2.src.rpm, installed, and built xf86config, in
/usr/src/redhat/BUILD/XFree86-4.3.0/xc/programs/Xserver/hw/xfree86/xf86config
which produced a working X configuration.  Beats me why tools such as xf86config
were omitted from RH 9.


Version-Release number of selected component (if applicable):
config-redhat-xfree86-0.7.3-2

How reproducible:
Always

Steps to Reproduce:
1. Upgrade from 8.0 to 9
2. Attempt to start X
3. Attempt to run config-redhat-xfree86
    

Actual Results:  Failure to start X or to produce /etc/X11/XF86config.


Expected Results:  X should work after upgrade, or at least one should be able
to produce a config file with supplied/documented tools.


Additional info:

config-redhat-xfree86 results:

[root@wx1 root]# redhat-config-xfree86
* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None

Couldn't start X server, trying with a fresh configuration
* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None

Trying with card: ATI Rage 128 Mobility
Error, cannot start X server.

Comment 1 Phil Schaffner 2003-04-10 17:52:53 UTC
Forgot to note that I was able to do the 8.0/9 upgrade in the GUI mode without
apparent problems, so "generic X" will run on the hardware -
config-redhat-xfree86 needs to learn the same tricks the installer knows.

Comment 2 Brent Fox 2003-04-14 19:58:11 UTC
Try this:

1) Move the existing /etc/X11/XF86Config out of the way (but don't delete it).
2) Then run redhat-config-xfree86 and see if it will generate a new file from
scratch.
3) If that works, please attach both files to this report so we can see how they
are different.

Comment 3 Phil Schaffner 2003-04-14 20:40:32 UTC
[Re]Moving the config files had no effect on the problem.  X still would not
start to allow config-redhat-xfree86 to generate new files.



Comment 4 Robert G. 'Doc' Savage 2003-09-17 20:01:28 UTC
In my experience neither redhat-config-xfree86 nor its predecessors can reliably
detect laptop screens -- at least on a ThinkPad.

X should work if you manually select the generic LCD Panel 1600x1200 monitor and
"millions of colors". I'm running fully-updated Severn 9.0.93 now on my A21p,
and I've successfully run 7.3/8.0/9 with this setting.

Comment 5 Brent Fox 2003-09-17 20:20:56 UTC
Doc, if you blow away the /etc/X11/XF86Config file, run redhat-config-xfree86,
and then click "OK" without selecting the correct monitor, does that config file
work?

I'm guessing that it doesn't.

Comment 6 Phil Schaffner 2003-11-12 21:21:10 UTC
Just upgraded to Fedora Core 1 - no change from RH9.  Still unable to
start X.  Saw an e-mail from September about a request to test - found
via a Google.  Would be glad to be a guinea-pig if you have something new.

Comment 7 Brent Fox 2004-02-24 20:18:42 UTC

*** This bug has been marked as a duplicate of 90409 ***

Comment 8 Brent Fox 2004-02-25 15:55:32 UTC
On second look, I believe that dsavage's comment is the right
solution.  Many older laptop screens cannot be probed like CRT's can.
 If we can't probe the screen, we try to load up some safe default
sync rates (which is 800x600).  

If you go to the "Hardware" tab and manually change the monitor model
to  whatever model you have, then the list of resolutions should
change to reflect the resolution cabapbilities of your monitor.


Note You need to log in before you can comment on or make changes to this bug.